Error in PREIN scriptlet in rpm package cpanel-letsencrypt-2.28-1.1.noarch

morteza3245

Well-Known Member
Sep 16, 2013
148
1
68
cPanel Access Level
Root Administrator
Hello
when i run below command:

/usr/local/cpanel/scripts/install_lets_encrypt_autossl_provider
i see below error and cant install:

[[email protected] ~]# /usr/local/cpanel/scripts/install_lets_encrypt_autossl_provider
info [install_lets_encrypt_autossl_provider] Starting yum execution “--assumeyes --config /etc/yum.conf install cpanel-letsencrypt --disablerepo=epel”.
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
* EA4: 208.74.123.61
* cpanel-addons-production-feed: 208.74.123.61
* cpanel-plugins: 208.74.123.61
* base: mirror.centos.org
Resolving Dependencies
--> Running transaction check
---> Package cpanel-letsencrypt.noarch 0:2.28-1.1 will be installed
--> Finished Dependency Resolution


Total download size: 42 k
Installed size: 104 k
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction

Error in PREIN scriptlet in rpm package cpanel-letsencrypt-2.28-1.1.noarch
Verifying : cpanel-letsencrypt-2.28-1.1.noarch 1/1

Complete!
info [install_lets_encrypt_autossl_provider] Completed yum execution “--assumeyes --config /etc/yum.conf install cpanel-letsencrypt --disablerepo=epel”: in 7.300 second(s).
Cpanel::Exception::IO::ExecError/(XID syxv5u) The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf install cpanel-letsencrypt --disablerepo=epel” because of an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf install cpanel-letsencrypt --disablerepo=epel” command (process 9825) reported error number 1 when it ended. : Error in PREIN scriptlet in rpmpackage cpanel-letsencrypt-2.28-1.1.noarch

at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 1017.
Cpanel::SysPkgs::YUM::_die_child_error(Cpanel::SafeRun::Object=HASH(0x2628d60), "Error in PREIN scriptlet in rpm package cpanel-letsencrypt-2."..., "_args", ARRAY(0x1faadf8), "packages", ARRAY(0x17b10e8)) called at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 998
Cpanel::SysPkgs::YUM::_exec_yum(Cpanel::SysPkgs::YUM=HASH(0x2624448), "packages", ARRAY(0x17b10e8), "_args", ARRAY(0x1faadf8)) called at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 928
Cpanel::SysPkgs::YUM::_call_yum(Cpanel::SysPkgs::YUM=HASH(0x2624448), "packages", ARRAY(0x17b10e8)) called at /usr/local/cpanel/Cpanel/SysPkgs/YUM.pm line 226
Cpanel::SysPkgs::YUM::install_packages(Cpanel::SysPkgs::YUM=HASH(0x2624448), "packages", ARRAY(0x17b10e8)) called at /usr/local/cpanel/Cpanel/Plugins.pm line 40
Cpanel::Plugins::install_plugins("cpanel-letsencrypt") called at /usr/local/cpanel/scripts/install_lets_encrypt_autossl_provider line 19
scripts::install_lets_encrypt_autossl_provider::run() called at /usr/local/cpanel/scripts/install_lets_encrypt_autossl_provider line 16

screenshot error: Screenshot

Thanks.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
@quietFinn has a point, if you're using v78 or prior you need to update to get the newer version of the Let's Encrypt plugin. Otherwise, it will be expecting the v1 package which is no longer usable.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
As indicated in the blog post which I linked above you need to update or switch AutoSSL providers but ultimately updating to a supported version of cPanel & WHM is advised, cPanel & WHM v82 is not supported and is End of Life.