The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error in setting up spam block

Discussion in 'General Discussion' started by pizzaman, Apr 26, 2005.

  1. pizzaman

    pizzaman Well-Known Member
    PartnerNOC

    Joined:
    Oct 1, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Just happened to a customer a coupe days ago, while he tried to add a spam block.

    (internal) Fri Apr 22 17:33:17 2005 [18443] warn: Missing language key
    "EFaddedto" at /usr/local/cpanel/Cpanel/TieLang.pm line 96, line 2013.
    Cpanel::TieLang::FETCH('Cpanel::TieLang=HASH(0x8afdd04)', 'EFaddedto')
    called at cpanel.pl line 2904 main::dolangprint('EFaddedto') called at
    cpanel.pl line 618 main::exectag('') called at cpanel.pl line 291
    main::dotag(undef) called at cpanel.pl line 3434
    main::parsehtml('GLOB(0x89a9054)') called at cpanel.pl line 285 A filter
    has been added that sends all mail header_subject: that contains
    aaaaaaaaaaaaaaaaaaa [an error occurred while processing this directive]

    This never happened before. Anybody has any idea what this could be? :confused:

    EDIT:
    Um, and I try again today without that wierd error msg, but there's still
    "[an error occurred while processing this directive]" in the msg.

    Thanks

    BTW, how can one expect an average user to diagnose that kind of error msg? :eek:
     
    #1 pizzaman, Apr 26, 2005
    Last edited: Apr 26, 2005
  2. rvskin

    rvskin Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    400
    Likes Received:
    1
    Trophy Points:
    18
    You may need to check log in /usr/local/cpanel/logs/error_log. It might help.
     
  3. pizzaman

    pizzaman Well-Known Member
    PartnerNOC

    Joined:
    Oct 1, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Here's another one just today.

    root@xxx [~]# tail /usr/local/cpanel/logs/error_log
    (internal) Wed Apr 27 12:39:24 2005 [4131] warn: Missing language key "BUAliasFilterTitle" at /usr/local/cpanel/Cpanel/TieLang.pm line 96, <BASELANGFD> line 1864.
    Cpanel::TieLang::FETCH('Cpanel::TieLang=HASH(0x8a833c4)', 'BUAliasFilterTitle') called at cpanel.pl line 2904
    main::dolangprint('BUAliasFilterTitle') called at cpanel.pl line 618
    main::exectag('<cpanel langprint="BUAliasFilterTitle">') called at cpanel.pl line 291
    main::dotag(undef) called at cpanel.pl line 3434
    main::parsehtml('GLOB(0x89a900c)') called at cpanel.pl line 285

    A glance at /usr/local/cpanel/Cpanel/TieLang.pm gets me to this file,

    root@xxx [~]# grep -i BUAliasFilter /usr/local/cpanel/lang/english
    BUAliasFilterRestoreTitle=Restore an Alias/Filter Backup
    BUAliasFilterRestoreTitle=Restore an Alias/Filter

    and this, I guess it's a fix for my earlier post

    root@xxx [~]# grep -i EFaddedto /usr/local/cpanel/lang/english
    EFAddedto=to

    see the date of that lang file

    root@xxx [~]# ll /usr/local/cpanel/lang/english
    -rw-r--r-- 1 root root 69386 Apr 22 04:43 /usr/local/cpanel/lang/english

    just a couple days ago.. probably this fixed the problem for my earlier customer

    I suspect that if we added this

    BUAliasFilterTitle=1234

    to this lang file, the problem today will go away.

    What's this all about?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  5. pizzaman

    pizzaman Well-Known Member
    PartnerNOC

    Joined:
    Oct 1, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
Loading...

Share This Page