The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

error in upcp

Discussion in 'General Discussion' started by youp, Aug 4, 2006.

  1. youp

    youp Well-Known Member

    Joined:
    Oct 30, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    i have this error whith upcp :

    Creating new 'Build' script for 'version' version '0.662'
    CPAN: YAML loaded ok
    Can't locate object method "up_to_date" via package "version::Builder" at ./Build line 45.
    ./Build -- NOT OK
    Running Build install
    make had returned bad status, install seems impossible

    ???
     
  2. edumadma

    edumadma Well-Known Member

    Joined:
    May 11, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Same problem

    I have the same problem ! :rolleyes:
     
  3. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    Does any one have a work arround for this..
    Perl has been upgraded for several times now.. we are using 5.8.7

    Thanks for any suggestion or fixes in advance.
     
  4. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    Ok.. I have fixed this by installing 'version' modules manually from cpan.org..
     
  5. edumadma

    edumadma Well-Known Member

    Joined:
    May 11, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    how to install ?


    What do you install ? and how to install ?
     
  6. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Login to WHM >> Install a Perl Module
    Type the name of the module you want to install in the field.
     
  7. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    Or from shell use the perlinstaller script (same thing really)...

    /scripts/perlinstaller version::Builder
     
  8. youp

    youp Well-Known Member

    Joined:
    Oct 30, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    output of /scripts/perlinstaller version::Builder =>

    Warning: Cannot install version::Builder, don't know what it is.
    Try the command

    i /version::Builder/

    to find objects with matching identifiers.
    perlmod--Install done
     
  9. edumadma

    edumadma Well-Known Member

    Joined:
    May 11, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Version

    What a Version ? :eek:

    /scripts/perlinstaller version::Builder
    Method: Perl Expect
    Testing connection speed...(this could take a while)...Done
    Ping:0.408 Testing mirror speed and update status (cpan.belfry.net) using wget..
    .(10100000 bytes/s)...Done
    Ping:0.267 Testing mirror speed and update status (cpan.erlbaum.net) using wget.
    ..(14090000 bytes/s)...Done
    Ping:10.032 Testing mirror speed and update status (mirror.hyperian.net) using w
    get...(287460 bytes/s)...Done
    Three usable mirrors located
    Mirror Check passed for cpan.erlbaum.net (/index.html)
    commit: wrote '/usr/lib/perl5/5.8.0/CPAN/Config.pm'
    CPAN: File::HomeDir loaded ok
    CPAN: Storable loaded ok
    Going to read /home/.cpan/Metadata
    Database was generated on Sat, 05 Aug 2006 02:31:41 GMT
    Warning: Cannot install version::Builder, don't know what it is.
    Try the command

    i /version::Builder/

    to find objects with matching identifiers.
    perlmod--Install done
     
  10. micron

    micron Member

    Joined:
    Dec 1, 2002
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    did anyone find a solution to this? im having the same problem on a newly installed rh4...
     
  11. liwiplus

    liwiplus Member

    Joined:
    Jul 22, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Try installing version manually by,

    cd /home/.cpan/build/version-0.662

    perl Makefile.PL
    make
    make install

    This should fix the issue.
     
  12. youp

    youp Well-Known Member

    Joined:
    Oct 30, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    thanks that work now ;)
     
  13. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    Yep, sorry - should have just been /scripts/perlinstaller Version. I guess it's all one big bundle for version... ;)
     
  14. dropby23

    dropby23 Well-Known Member

    Joined:
    Jan 16, 2005
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    cpan> install K/KW/KWILLIAMS/Module-Build-0.28.tar.gz
    cpan> install version
    cpan> install Module::Build
     
  15. edumadma

    edumadma Well-Known Member

    Joined:
    May 11, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Warning:

    cpan> install K/KW/KWILLIAMS/Module-Build-0.28.tar.gz
    WARNING: This key is not certified with a trusted signature!
    Primary key fingerprint: 2E66 557A B97C 19C7 91AF 8E20 328D A867 450F 89EC
    WARNING: This key is not certified with a trusted signature!
    Primary key fingerprint: ADCB DB05 B40E B2A2 A555 5462 82BB CC04 B7EF 9476
    Can't locate the perl binary used to run this script in (/usr/bin /usr/bin /usr/bin /usr/local/jdk/bin /usr/kerberos/sbin /usr/kerberos/bin /usr/local/sbin /usr/local/bin /sbin /bin /usr/sbin /usr/bin /usr/X11R6/bin /usr/local/bin /usr/X11R6/bin /root/bin)
     
  16. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    try clean all at cpan prompt and retry. Maybe something is untarred part way or corrupted in some way... ?
     
  17. coderoyal

    coderoyal Well-Known Member

    Joined:
    Mar 8, 2005
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Hi! I'm having the same issue as well. The same exact error. I also ran "/scripts/perlinstaller Version" per a previous post, but got the ame error below:

    /usr/bin/perl -MCrypt::TripleDES -e exit;
    Can't locate Crypt/TripleDES.pm in @INC (@INC contains: /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .).
    BEGIN failed--compilation aborted.
    make: *** [checks] Error 2

    /usr/bin/make -- NOT OK
    Running make install
    make had returned bad status, install seems impossible
    perlmod--Install done

    I can try access the cpanl prompt and executing that command, but I'm not familiar with cpan. Does anyone have any other suggestions?
     
  18. coderoyal

    coderoyal Well-Known Member

    Joined:
    Mar 8, 2005
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    NM.. Liwiplus' steps fixed the issue for me as well :)
     
  19. flash7

    flash7 Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Same here (x86_64)

    Module::Build is not configured with C_support at /usr/lib/perl5/site_perl/5.8.7/Module/Build/Base.pm line 3734.
    ./Build -- NOT OK
    Running Build install
    make had returned bad status, install seems impossible
     
Loading...

Share This Page