Error installing Cpanel on CentOS 7

Operating System & Version
CentOS 7

mzn3r

Registered
Mar 21, 2020
1
0
1
Iraq
cPanel Access Level
Root Administrator
Hi there,
i'm trying to setup Cpanel/WHM on centOS 7 but i have the following error

--> Finished Dependency Resolution
2020-03-21 15:25:36 414 [20165] (DEBUG): Error: Package: nscd-2.17-196.el7_4.2.x86_64 (ultra-centos-7.4-updates)
2020-03-21 15:25:36 414 [20165] (DEBUG): Requires: glibc = 2.17-196.el7_4.2
2020-03-21 15:25:36 414 [20165] (DEBUG): Installed: glibc-2.17-222.el7.x86_64 (installed)
2020-03-21 15:25:36 414 [20165] (DEBUG): glibc = 2.17-222.el7
2020-03-21 15:25:36 414 [20165] (DEBUG): Available: glibc-2.17-196.el7.x86_64 (ultra-centos-7.4-base)
2020-03-21 15:25:36 414 [20165] (DEBUG): glibc = 2.17-196.el7
2020-03-21 15:25:36 414 [20165] (DEBUG): Available: glibc-2.17-196.el7_4.2.x86_64 (ultra-centos-7.4-updates)
2020-03-21 15:25:36 414 [20165] (DEBUG): glibc = 2.17-196.el7_4.2
2020-03-21 15:25:36 414 [20165] (DEBUG): You could try using --skip-broken to work around the problem
2020-03-21 15:25:37 414 [20165] (DEBUG): You could try running: rpm -Va --nofiles --nodigest
2020-03-21 15:25:37 414 [20165] (ERROR): - ssystem [EXIT_CODE] '/usr/bin/yum' exited with 1 (ignored)
2020-03-21 15:25:37 414 [20165] (DEBUG): - ssystem [END]
2020-03-21 15:25:37 418 [20165] (FATAL): yum failed 6 times. The installation process cannot continue.
tried yum clean all
yum update
but still the same , any ideas ?
 

cPanelLauren

Technical Support Community Manager
Staff member
Nov 14, 2017
13,252
1,234
313
Houston
The issue is the package you're trying to install from the ultra-centos-7.4 updates repository requires a lower version of glibc than what is installed:

Requires: glibc = 2.17-196.el7_4.2
Available: glibc-2.17-196.el7.x86_64
Installed: glibc-2.17-222.el7.x86_64

I'm not familiar with the repository in use there, it's not the standard CentOS base or CentOS updates repo. Official CentOS repos are listed here: AdditionalResources/Repositories - CentOS Wiki