Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error Installing cPanel on CloudLinux 7.1

Discussion in 'General Discussion' started by Angel Benites, Nov 27, 2017.

Tags:
  1. Angel Benites

    Angel Benites Registered

    Joined:
    Feb 11, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lima
    cPanel Access Level:
    Root Administrator
    uh get an ovh server and installed your cloudlinux 7.1 template and when you run

    cd / home & curl -o latest -L https://securedownloads.cpanel.net/latest && sh latest

    I throw the following error.



    Code:
    (fINFO): cPanel & WHM installation started at: Mon Nov 27 17:24:36 2017!
     (fINFO): This installation will require 20-50 minutes, depending on your hardware.
     (fINFO): Now is the time to go get another cup of coffee/jolt.
     (fINFO): The install will log to the /var/log/cpanel-install.log (file.
     (fINFO):
     (fINFO): Beginning Installation v3...
     (fINFO): cloudlinux 7.4 (Linux) detected!
     INFO): Checking RAM now...
     INFO): Validating that the system hostname ('eon.hostingweb.pe') is a FQDN...
     INFO): Checking for NetworkManager now...
     INFO): NetworkManager is not installed.
     INFO): Checking for essential system files...
     INFO): Checking the CloudLinux registration for updates...
     WARN): Attempting to install the critical 'rdate' package for the installer...
    (DEBUG):   - ssystem [BEGIN]: yum -y install rdate
    (DEBUG):     Loaded plugins: fastestmirror, rhnplugin
    (DEBUG):     This system is receiving updates from CLN.
    (DEBUG):     Loading mirror speeds from cached hostfile
    (DEBUG):      * cloudlinux-x86_64-server-7: xmlrpc.cln.cloudlinux.com
     last):
    (DEBUG):       File "/usr/bin/yum", line 29, in <module>
    (DEBUG):         yummain.user_main(sys.argv[1:], exit_code=True)
    (DEBUG):       File "/usr/share/yum-cli/yummain.py", line 367, in user_main
    (DEBUG):         errcode = main(args)
    (DEBUG):       File "/usr/share/yum-cli/yummain.py", line 174, in main
    (DEBUG):         result, resultmsgs = base.doCommands()
    (DEBUG):       File "/usr/share/yum-cli/cli.py", line 571, in doCommands
    (DEBUG):         return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
    (DEBUG):       File "/usr/share/yum-cli/yumcommands.py", line 440, in doCommand
    (DEBUG):         return base.installPkgs(extcmds, basecmd=basecmd)
    (DEBUG):       File "/usr/share/yum-cli/cli.py", line 967, in installPkgs
    (DEBUG):         txmbrs = self.install(pattern=arg)
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 4764, in install
    (DEBUG):         mypkgs = self.pkgSack.returnPackages(patterns=pats,
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1079, in <lambda>
    (DEBUG):         pkgSack = property(fget=lambda self: self._getSacks(),
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 784, in _getSacks
    (DEBUG):         self.repos.populateSack(which=repos)
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/repos.py", line 383, in populateSack
    (DEBUG):         sack.populate(repo, mdtype, callback, cacheonly)
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 224, in populate
     mydbtype):
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 316, in _check_db_version
    (DEBUG):         return repo._check_db_version(mdtype)
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1484, in _check_db_version
    (DEBUG):         repoXML = self.repoXML
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1670, in <lambda>
    (DEBUG):         repoXML = property(fget=lambda self: self._getRepoXML(),
    (DEBUG):       File "/usr/share/yum-plugins/rhnplugin.py", line 599, in _getRepoXML
    (DEBUG):         return YumRepository._getRepoXML(self)
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1666, in _getRepoXML
    (DEBUG):         self._loadRepoXML(text=self.ui_id)
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1657, in _loadRepoXML
    (DEBUG):         return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1631, in _groupLoadRepoXML
    (text):
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1456, in _commonLoadRepoXML
    (DEBUG):         result = self._getFileRepoXML(local, text)
    (DEBUG):       File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1234, in _getFileRepoXML
    (DEBUG):         size=102400) # setting max size as 100K
    (DEBUG):       File "/usr/share/yum-plugins/rhnplugin.py", line 410, in _getFile
    (DEBUG):         start, end, copy_local, checkfunc, text, reget, cache, size)
    (DEBUG):       File "/usr/share/yum-plugins/rhnplugin.py", line 490, in _noExceptionWrappingGet
    (DEBUG):         retry_no_cache=self._retry_no_cache
    (DEBUG):     AttributeError: 'RhnRepo' object has no attribute '_retry_no_cache'
    (ERROR):   - ssystem [EXIT_CODE] 'yum' exited with 1 (ignored)
    (DEBUG):   - ssystem [END]
    (ERROR): The system could not set the system clock because an rdate binary is missing.
     WARN): The current system time is set to: Mon Nov 27 17:24:37 EST 2017
    
     WARN): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
     WARN): The installation process could not verify the system time. The utility to set time from a remote host, rdate, is not installed.
     WARN): If your system time is incorrect by more than a few hours, source compilations will subtly fail.
     WARN): This issue may result in an overall installation failure.
     WARN): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
     INFO): The installation process will now set up the necessary empty cpanel directories.
     INFO): The installation process will now ensure that GPG is set up properly before it imports keys.
     INFO): The installation process will now import GPG keys for yum.
    (DEBUG):   Retrieving http://httpupdate.cpanel.net/cpanelsync/TIERS to the TIERS file...
    (DEBUG):   Retrieving http://httpupdate.cpanel.net/cpanelsync/TIERS.asc to the TIERS.asc file...
     INFO): Downloading GPG public key, cPanelPublicKey.asc
     INFO): Valid signature for TIERS
     INFO): Running health checks prior to start.
     INFO): Validating whether the system can look up domains...
    (DEBUG):   Testing cpanel.net...
    (DEBUG):   Testing www.cpanel.net...
    (DEBUG):   Testing updates.cpanel.net...
    (DEBUG):   Testing httpupdate.cpanel.net...
    (DEBUG):   Testing layer2.cpanel.net...
    (DEBUG):   Testing layer1.cpanel.net...
    (DEBUG):   Testing www.google.com...
    (ERROR): Your operating system's RPM update method (yum) could not locate the glibc package. This is an indication of an improper setup. You must correct this error before you proceed.
    (FATAL):
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,455
    Likes Received:
    1,608
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This seems like an issue with the CloudLinux 7.1 image offered by your hosting provider. Can you report this issue to them so they can verify if there are any issues with the image they provide? Or, consider using a minimal CentOS 7 image and converting it to CloudLinux using the instructions at:

    CloudLinux Documentation

    Thank you.
     
Loading...

Share This Page