SOLVED Error Installing cPanel on CloudLinux

Juan Antonio

Registered
Mar 30, 2015
2
1
3
Spain
cPanel Access Level
Root Administrator
Hi everyone,

I'm trying to install cPanel on a clean server (OVH). I've tried with CLoudLinux 7.6 and Centos 7 and after several minutes it always gets with a fatal error:


[2019-08-08 11:36:58 +0200] [6574] ( INFO): Queuing system package update
[2019-08-08 11:36:58 +0200] [6574] (FATAL): The background process “Apps that require deferred RPMs” failed with a fatal error: The subprocess reported error number 25 when it ended.
2019-08-08 11:36:58 338 [6252] (FATAL): The system failed to run the /usr/local/cpanel/scripts/cpanel_initial_install script.


Most of the software is installed (ie. mysql) .
There are also some some yellow warnings which I don't know if they are related.



[2019-08-08 11:36:19 +0200] Another app is currently holding the yum lock; waiting for it to exit...
[2019-08-08 11:36:19 +0200] The other application is: yum
[2019-08-08 11:36:19 +0200] Memory : 126 M RSS (1.5 GB VSZ)
[2019-08-08 11:36:19 +0200] Started: Thu Aug 8 11:35:51 2019 - 00:28 ago
[2019-08-08 11:36:19 +0200] State : Sleeping, pid: 7759




I've followed the instructions on Installation Guide - System Requirements - Version 82 Documentation - cPanel Documentation (disabled selinux, checked valid hostname, disabled firewall and NetWorkManager).

This is the first time I'm getting this error with a cPanel installation. Any ideas?

Thank you

Juan
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,262
313
Houston
Hi @Juan Antonio

It sounds like there is another stuck yum process. For the quickest help with installation and troubleshooting your installation, I would suggest opening a ticket. You can do so using the link in my signature. Once open reply here with the ticket ID so we can update this thread with the outcome.

***Edit***
There is also an internal case that sounds similar to this issue: CPANEL-28579 - cPanel install fails on CentOS7 with CloudLinux License. This should be fixed in 11.82.07 of cPane/WHM but I believe there are still some issues with the CloudLinux Netowrk and you might try running the following before attempting to install (as a workaround)

Code:
touch /var/cpanel/nocloudlinux
 
OR
 
sh latest --skip-cloudlinux

Thanks!
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello Juan,

You can execute the following command to see the last 10 lines of the installation log:

tail -10 /var/log/cpanel-install.log

Also, I noticed a recent support ticket where a similar issue occurred due to the server's inability to connect to rdate.cpanel.net. Here's a command you can use to check if this happened on your server as well:

grep rdate /var/log/cpanel-install.log | grep connect

Can you share the output from these commands here?

Thank you.