[email protected]

Well-Known Member
Aug 3, 2016
54
5
8
Everywhere
cPanel Access Level
Root Administrator
Hello,

After yesterdays cpanel update I have a problem.

Message Below:
----
The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf update --disablerepo=epel” because of an error:

reported error number 1 when it ended. : Error: Multilib version problems found.
This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem.
---
Code:
1. You have an upgrade for libssh2 which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of libssh2 of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude libssh2.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of libssh2 installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of libssh2 installed already.
You can use "yum check" to get yum show these errors...
I see from these commands:

Code:
# rpm -qa | grep libssh2
libssh2-1.8.0-1.0.cf.rhel6.x86_64

# yum list libssh2
Installed Packages
libssh2.x86_64
1.8.0-1.0.cf.rhel6       @city-fan.org
Available Packages
libssh2.i686
1.4.2-2.el6_7.1          base
Can please advice how to solve it?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,259
313
Houston
Hi @[email protected]


It seems like you have a non-standard version of libssh2 (or at least one that isn't being recognized) 1.8.0-1.0

On my test server running CentOS 7.5, the latest CentOS kernel and cPanel's edge:

Code:
rpm -qa |grep libssh
libssh2-1.4.3-10.el7_2.1.x86_64
The package showing as available is for 32-bit systems so it wouldn't work for you, but the version is correct.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,259
313
Houston
Hi @[email protected]


I've also done some more digging and found that repo has caused issues in the past. It needs to be disabled completely, in order to move forward. Once it's disabled you need to find out how many packages you have installed on the system that were added from that repository:

The following should give you a list:
Code:
yum list installed |grep @city
pending ONLY the libssh2/libssh2-devel packages were installed from this repo the following should work to move to a supported version:

Code:
rpm -ev --nodeps --justdb libssh2 libssh2-devel
Code:
yum install libssh2 libssh2-devel
If you have other packages installed from that repository there could be a number of other dependencies that could interfere and cause serious issues if you were to make the modifications suggested so it is extremely important to understand what was added.
 
  • Like
Reactions: [email protected]

N32D

Registered
Nov 16, 2018
1
0
1
US
cPanel Access Level
Root Administrator
I'm having a very similar Multilib error with libssh2 as well:

Protected multilib versions: libssh2-1.4.2-2.el6_7.1.i686 != libssh2-1.8.0-5.0.cf.rhel6.x86_64

Code:
# rpm -qa | grep libssh2
libssh2-1.8.0-5.0.cf.rhel6.x86_64

# yum list libssh2
Installed Packages
libssh2.x86_64                1.8.0-5.0.cf.rhel6        @city-fan.org
Available Packages
libssh2.i686                     1.4.2-2.el6_7.1          base
I wasn't sure how to disable the @city-fan.org repository to proceed, but I'm concerned that I may have other dependent packages installed.

Code:
# yum list installed |grep @city
results in numerous packages listed from @city-fan.org

Please advise how best to move forward.

CentOS 6.10, WHM v76.0.7.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,259
313
Houston
Hi @N32D


If you've got a number of other city fan packages installed you might have a number of dependencies/things that will be broken if you just uninstall. You need to work with a system administrator to analyze the breadth of the situation and how to move forward with removing them. This is a non-standard repository and not something that is specific to cPanel, nor are we experts with this specific item. If you don't have a system administrator you might find one here: System Administration Services | cPanel Forums.
 

[email protected]

Well-Known Member
Aug 3, 2016
54
5
8
Everywhere
cPanel Access Level
Root Administrator
Hello @cPanelLauren

I have only those packages installed and the repo is completely disabled.

Code:
yum list installed |grep @city

c-ares.x86_64                  1.12.0-1.0.cf.rhel6  @city-fan.org
curl.x86_64                      7.51.0-1.0.cf.rhel6  @city-fan.org
libcurl.x86_64                   7.51.0-1.0.cf.rhel6  @city-fan.org
libssh2.x86_64                  1.8.0-1.0.cf.rhel6   @city-fan.org
What do you suggest I must do to move to a supported version?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,259
313
Houston
Hi @[email protected]


You are more than welcome to try the method I gave you to remove libssh2 - looking at the packages I believe you should be alright though I would still suggest a system administrator if you're uncomfortable making the changes.


Thanks!
 

asterix_jv

Registered
Nov 28, 2018
1
0
1
El Salvador
cPanel Access Level
Root Administrator
Hello,

I have the same error in my CENTOS 6.10 kvm with cPanel v76.0.9 since got the last cPanel update.

When I tried to yum update got this error:

<code>
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for libssh2 which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of libssh2 of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude libssh2.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of libssh2 installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of libssh2 installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: libssh2-1.4.2-2.el6_7.1.i686 != libssh2-1.8.0-5.0.cf.rhel6.x86_64
</code>

I tried with your solution but without success:
<code>
yum list installed |grep @city
libssh2.x86_64 1.8.0-5.0.cf.rhel6 @city-fan.org

with a lot of packages

rpm -ev --nodeps --justdb libssh2 libssh2-devel
error: package libssh2-devel is not installed

yum install libssh2 libssh2-devel


and said me again:
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a........

</code>

So I tried to see the duplicates packages with
<code>
yum check
Loaded plugins: fastestmirror, protectbase, security, universal-hooks
check all

yum-complete-transaction

0 packages excluded due to repository protections
No unfinished transactions left.

package-cleanup --dupes
Loaded plugins: fastestmirror, protectbase
</code>

not show nothing
<code>
package-cleanup --problems
Loaded plugins: fastestmirror, protectbase
No Problems Found
</code>

Then I proceed to make <code> yum update</code> again but always show me the same alert

Can you help me with this?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,259
313
Houston
Hi @asterix_jv

The problem isn't that you have duplicates, it's that you have the package installed from a non-standard repository. You need to follow the instructions provided to remove it including first removing/disabling the city-fan repo.
 

Stefaans

Well-Known Member
Mar 5, 2002
461
4
318
Vancouver, Canada
Replying to an old thread, but brand new problem for us....

We had exactly the same city-fan.org packages installed as quoted below by @[email protected]. (Who knows how or why; we rely on cPanel to manage this for us.) Note the absence of libssh2-devel. Trying the @cPanelLauren instructions caused curl to break, which caused yum to break.

The way I could get things to work was to add libssh2-devel package from the city-fan.org repository, which is the opposite of removing the city-fan.org packages:

Code:
wget http://www.city-fan.org/ftp/contrib/yum-repo/rhel7/x86_64/libssh2-devel-1.8.0-10.0.cf.rhel7.x86_64.rpm
rpm -i libssh2-devel-1.8.0-10.0.cf.rhel7.x86_64.rpm
The version above is time-dependent and for Redhat/Centos 7 specifically. Check for the latest at RepoView: city-fan.org repository for Red Hat Enterprise Linux 7 (x86_64)

I hope this helps someone!


Hello @cPanelLauren

I have only those packages installed and the repo is completely disabled.

Code:
yum list installed |grep @city

c-ares.x86_64                  1.12.0-1.0.cf.rhel6  @city-fan.org
curl.x86_64                      7.51.0-1.0.cf.rhel6  @city-fan.org
libcurl.x86_64                   7.51.0-1.0.cf.rhel6  @city-fan.org
libssh2.x86_64                  1.8.0-1.0.cf.rhel6   @city-fan.org
What do you suggest I must do to move to a supported version?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,259
313
Houston
Hi @Stefaans

The instructions I provided the user were specific and tested, done correctly shouldn't have caused anything to break. That being said while I'm happy that you were able to get things back in working order I do need to point out that there are issues with compatibility with that repository and we do not support it being enabled.


Thanks!