The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error occurred when installing GD Lib with EasyApache

Discussion in 'EasyApache' started by Wael Ammar, Dec 12, 2011.

  1. Wael Ammar

    Wael Ammar Registered

    Joined:
    Dec 12, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ariana, Tunisia, Tunisia
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm trying to install the GD library on my server, so I used the script EasyApache on the WHM, I selected "Start customizing an existing profile" and I just checked the "GD"

    After a few moment the build process failed with this error
    In the bottom I have this
    Like it said, I tried to run manually the failed yum command and this is the output :
    I checked this link EaError < AllDocumentation < TWiki and I didn't find an explanation for this purpose...

    What do I have to do? can I simply remove libtool-ltdl-devel with yum remove command and re-run easy apache?

    Thanks in advance for your help.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Can you provide the output for the following commands?

    Code:
    cat /var/cpanel/sysinfo.config
    uname -a
    cat /etc/redhat-release
     
  3. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    462
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi Wael Ammar,

    Run the following command.

    1)yum clean metadata
    2)yum clean all

    Check resolv.conf and put the correct IP addresses. If everything appears to be corrected then re-install yum.
    Your host will help you for re-installing yum.
     
  4. Wael Ammar

    Wael Ammar Registered

    Joined:
    Dec 12, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ariana, Tunisia, Tunisia
    cPanel Access Level:
    Root Administrator
    Hi,

    this is the output of the command

    Code:
    root@SERVER [~]# cat /var/cpanel/sysinfo.config
    rpm_arch=x86_64
    rpm_dist_ver=5
    release=5.6
    ises=2
    rpm_dist=centos
    
    root@SERVER [~]# uname -a
    Linux SERVER.ovh.net 2.6.38.2-grsec-xxxx-grs-ipv6-64 #1 SMP Fri Apr 15 17:44:15 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
    
    root@SERVER [~]# cat /etc/redhat-release
    CentOS release 5.7 (Final)
     
  5. Wael Ammar

    Wael Ammar Registered

    Joined:
    Dec 12, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ariana, Tunisia, Tunisia
    cPanel Access Level:
    Root Administrator
    I made the cleanup, everything is correct on my resolv.conf... but I have the same error when I want to install the list of the packages

    Code:
    Transaction Check Error:
      package libtool-ltdl-devel-2.2.6-15.5.el5.1.x86_64 (which is newer than libtool-ltdl-devel-1.5.22-7.el5_4.i386) is already installed
    
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    There is no reason to re-install yum for the error being reported. The issue is possibly two conflicting rpms, one for 64-bit and one for 32-bit. Let's try to troubleshoot the rpms first.

    Can you please run the following command now:

    Code:
    rpm -qa --qf "%{n}-%{v}-%{r}.%{arch}\n" | grep -i libtool-ltdl-devel-*
     
Loading...

Share This Page