Error: Package: alt-php74-imunify-mbstring - Oniguruma

Operating System & Version
CENTOS 7.8 kvm
cPanel & WHM Version
v88.0.10

SweptSquash

Member
Apr 16, 2016
6
0
76
UK
cPanel Access Level
Root Administrator
Hi,

I went to perform a System Update and ran into the following error, I did a quick search on the forums and google but didn't come across anyone having a similar issue. Any assistance would be greatly appericated :) Thanks

Code:
“yum” reported error code “1” when it ended:  w/ yum -y --exclude=kernel-*
Loaded plugins: fastestmirror, universal-hooks, versionlock
Loading mirror speeds from cached hostfile
 * EA4: 91.197.228.252
 * cpanel-addons-production-feed: 91.197.228.252
 * cpanel-plugins: 91.197.228.252
 * base: mirror.cc.columbia.edu
 * epel: d2lzkl7pfhq30w.cloudfront.net
 * extras: mirror.rackspace.com
 * updates: mirrors.rit.edu
Excluding 1 update due to versionlock (use "yum versionlock status" to show it)
Resolving Dependencies
--> Running transaction check
---> Package oniguruma.x86_64 0:5.9.5-3.el7 will be updated
--> Processing Dependency: libonig.so.2()(64bit) for package: alt-php74-imunify-mbstring-7.4.4-3.1.el7.x86_64
---> Package oniguruma.x86_64 0:6.8.2-1.el7 will be an update
--> Finished Dependency Resolution
<span class='text-danger'>Error: Package: alt-php74-imunify-mbstring-7.4.4-3.1.el7.x86_64 (@imunify360)</span>
           Requires: libonig.so.2()(64bit)
           Removing: oniguruma-5.9.5-3.el7.x86_64 (@epel)
               libonig.so.2()(64bit)
           Updated By: oniguruma-6.8.2-1.el7.x86_64 (epel)
              ~libonig.so.5()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Often errors like this can be resolved by running `yum makecache`
 

Nirjonadda

Well-Known Member
May 8, 2013
722
27
78
cPanel Access Level
Root Administrator
Getting error from yum update. Please let me know that how can fix this issue?

Code:
[[email protected] ~]# yum update
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 91.197.228.252
 * EA4-experimental: 91.197.228.252
 * cpanel-addons-production-feed: 91.197.228.252
 * cpanel-plugins: 91.197.228.252
 * base: centos.mirror.triple-it.nl
 * epel: mirrors.ukfast.co.uk
 * extras: mirror.hostnet.nl
 * remi-safe: mirrors.ukfast.co.uk
 * updates: mirror.mijn.host
Resolving Dependencies
--> Running transaction check
---> Package elasticsearch.x86_64 0:7.7.1-1 will be updated
---> Package elasticsearch.x86_64 0:7.8.0-1 will be an update
---> Package librsync.x86_64 0:2.3.0-1.el7 will be updated
---> Package librsync.x86_64 0:2.3.1-1.el7 will be an update
---> Package librsync-devel.x86_64 0:2.3.0-1.el7 will be updated
---> Package librsync-devel.x86_64 0:2.3.1-1.el7 will be an update
---> Package oniguruma.x86_64 0:5.9.5-3.el7 will be updated
--> Processing Dependency: libonig.so.2()(64bit) for package: alt-php74-imunify-mbstring-7.4.6-2.el7.x86_64
---> Package oniguruma.x86_64 0:6.8.2-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: alt-php74-imunify-mbstring-7.4.6-2.el7.x86_64 (@imunify360)
           Requires: libonig.so.2()(64bit)
           Removing: oniguruma-5.9.5-3.el7.x86_64 (@epel)
               libonig.so.2()(64bit)
           Updated By: oniguruma-6.8.2-1.el7.x86_64 (epel)
              ~libonig.so.5()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[[email protected] ~]#
 

lestat69

Member
Jul 30, 2016
9
2
3
New Jersey
cPanel Access Level
Root Administrator
System update process has started.

“yum” reported error code “1” when it ended: w/ yum -y
Loaded plugins: universal-hooks
Resolving Dependencies
--> Running transaction check
---> Package oniguruma.x86_64 0:5.9.5-3.el7 will be updated
--> Processing Dependency: libonig.so.2()(64bit) for package: alt-php74-imunify-mbstring-7.4.6-2.el7.x86_64
---> Package oniguruma.x86_64 0:6.8.2-1.el7 will be an update
--> Finished Dependency Resolution
<span class='text-danger'>Error: Package: alt-php74-imunify-mbstring-7.4.6-2.el7.x86_64 (@imunify360)</span>
Requires: libonig.so.2()(64bit)
Removing: oniguruma-5.9.5-3.el7.x86_64 (@epel)
libonig.so.2()(64bit)
Updated By: oniguruma-6.8.2-1.el7.x86_64 (epel)
~libonig.so.5()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Often errors like this can be resolved by running `yum makecache`

System update process has finished.
 

nullmem

Member
Jan 21, 2018
11
1
3
Austin, TX
cPanel Access Level
Root Administrator
I am having same problem.

Code:
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 70.87.220.252
 * cpanel-addons-production-feed: 70.87.220.252
 * cpanel-plugins: 70.87.220.252
 * base: mirrors.radwebhosting.com
 * epel: mirror.dal.nexril.net
 * extras: www.gtlib.gatech.edu
 * updates: repos.hou.layerhost.com
Resolving Dependencies
--> Running transaction check
---> Package oniguruma.x86_64 0:5.9.5-3.el7 will be updated
--> Processing Dependency: libonig.so.2()(64bit) for package: alt-php74-imunify-mbstring-7.4.4-3.1.el7.x86_64
---> Package oniguruma.x86_64 0:6.8.2-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: alt-php74-imunify-mbstring-7.4.4-3.1.el7.x86_64 (@imunify360)
           Requires: libonig.so.2()(64bit)
           Removing: oniguruma-5.9.5-3.el7.x86_64 (@epel)
               libonig.so.2()(64bit)
           Updated By: oniguruma-6.8.2-1.el7.x86_64 (epel)
              ~libonig.so.5()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 

lestat69

Member
Jul 30, 2016
9
2
3
New Jersey
cPanel Access Level
Root Administrator
Same problem here


System update process has started.

“yum” reported error code “1” when it ended: w/ yum -y
Loaded plugins: universal-hooks
Resolving Dependencies
--> Running transaction check
---> Package oniguruma.x86_64 0:5.9.5-3.el7 will be updated
--> Processing Dependency: libonig.so.2()(64bit) for package: alt-php74-imunify-mbstring-7.4.6-2.el7.x86_64
---> Package oniguruma.x86_64 0:6.8.2-1.el7 will be an update
--> Finished Dependency Resolution
<span class='text-danger'>Error: Package: alt-php74-imunify-mbstring-7.4.6-2.el7.x86_64 (@imunify360)</span>
Requires: libonig.so.2()(64bit)
Removing: oniguruma-5.9.5-3.el7.x86_64 (@epel)
libonig.so.2()(64bit)
Updated By: oniguruma-6.8.2-1.el7.x86_64 (epel)
~libonig.so.5()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Often errors like this can be resolved by running `yum makecache`

System update process has finished.
 

tesae

Registered
Jun 18, 2020
1
0
1
Greece
cPanel Access Level
Root Administrator
Same issue here.
Excluding the package with --exclude=oniguruma seems to run but I don't know if anything will break.

ex: yum update --downloadonly --exclude=oniguruma
 

JonathanJ

Registered
Jun 18, 2020
1
0
1
Toronto
cPanel Access Level
DataCenter Provider
Same issue, same attempt at resolution, same result.

Disabling epel let's me yum update, but if I re-enable epel, same problem, tracking down the package specifically, but we're getting a security update alert for it.

So it is oniguruma that is being reported by "yum --security check-update":

Code:
1 package(s) needed for security, out of 1 available

oniguruma.x86_64                                                                 6.8.2-1.el7                                                                 epel
And of course if you hide that update by disabling epel the packages needed for security disappears
 
Last edited:

nullmem

Member
Jan 21, 2018
11
1
3
Austin, TX
cPanel Access Level
Root Administrator
This didn't work
Code:
yum clean expire-cache; yum update
This also did not work
Code:
yum remove imunify-antivirus
rm -rf /etc/sysconfig/imunify360
rm /etc/yum.repos.d/imunify360*
curl https://repo.imunify360.cloudlinux.com/defence360/imav-deploy.sh | bash
Not sure why it's trying to install an alt-php package on a non Coudlinux machine, but these types of bugs from Cloudlinux/Imunify are pretty common. I think someone is drinking too much vodka when deploying package updates.
 

cosmomedia

Registered
Jun 18, 2020
1
1
1
MOntreal, Qc
cPanel Access Level
Root Administrator
The issue is with third party repo EPEL on CloudLinux:
oniguruma-6.8.2-1.el7.x86_64 (epel)

Code:
yum-config-manager --disable epel
yum clean all
yum makecache
yum reinstall oniguruma
yum update
Worked…

(oniguruma.x86_64 -- 5.9.5-3.el7 -- @cloudlinux-imunify360)
 
Last edited:
  • Like
Reactions: SweptSquash

BillyS

Well-Known Member
Mar 22, 2013
56
3
8
cPanel Access Level
Root Administrator
I'm pretty sure if you elected to install Imunify, this will happen. I was sick of getting warnings in CSF concerning the php.ini file used by this program, so when I saw it broke the yum update for easyapache, I unistalled it using the information found here:


Code:
wget https://repo.imunify360.cloudlinux.com/defence360/imav-deploy.sh
bash imav-deploy.sh --uninstall
All problems solved.
 

kdean

Well-Known Member
Oct 19, 2012
346
47
28
Orlando, FL
cPanel Access Level
Root Administrator
edit /etc/yum.repos.d/epel.repo

Add in the [epel] section:

exclude=oniguruma*

Error no longer appears

Further if you want the current installed oniguruma to reflect that it's from the imunify360 repo instead of the epel repo, after adding the above you can do:

yum reinstall oniguruma

Then a "yum list oniguruma" will now show:

oniguruma.x86_64 5.9.5-3.el7 @imunify360
 
Last edited:
  • Like
Reactions: nullmem

wbmichael

Registered
Dec 31, 2017
1
0
1
Germany
cPanel Access Level
Root Administrator
The issue is with third party repo EPEL on CloudLinux:
oniguruma-6.8.2-1.el7.x86_64 (epel)
Epel doesn´t matter.... as long as you have imunify installed, updates do not work. I needed to remove imunify360 (or imunify-av) completely, then updating with
yum update -y
then remove oniguruma and reinstall imunify. (If you don´t remove oniguruma you can´t install imunify360)

Really annoying bug in cloudlinux/imunify repo.
 

CloudLinux Skhristich

Well-Known Member
Verifed Vendor
May 23, 2019
53
29
18
kiev
cPanel Access Level
Root Administrator
Hello,
As workaround:
You can completely disable the epel repository or you can try adding the oniguruma package to the exceptions for EPEL. To exclude a package from EPEL repo, add the following line:
Code:
exclude=oniguruma
To the section [epel] in file /etc/yum.repos.d/epel.repo. It will look like:

Code:
[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
metalink=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch&infra=$infra&content=$contentdir
failovermethod=priority
enabled = 1
gpgcheck=1
exclude=oniguruma
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
With this fix, you will exclude the conflicting package from EPEL repo and can try to keep the repository turned on.
Thank you
 

RufusLive

Registered
Jun 20, 2020
1
0
0
US
cPanel Access Level
Root Administrator
My server provider switched to a different control panel because of the pricing, but I stayed with cPanel, and pay the extra money for the cPanel licence through here so I could get the support but the support ticket system is not working and there is no response for a solution on here.