Error package on Postgres installation

Brukenzeper

Registered
Jan 21, 2021
2
0
1
Philippines
cPanel Access Level
Root Administrator
Hi, I am technically new to Cpanel, and I was installing Postgres to my server using this guide from Cpanel Install or Update PostgreSQL® on Your cPanel & WHM Server | cPanel & WHM Documentation. As I execute /usr/local/cpanel/scripts/installpostgres I am encountering these errors:

Code:
[email protected] [~]# /usr/local/cpanel/scripts/installpostgres
This script installs PostgreSQL 9.2.x or later.
Are you certain that you wish to proceed? [y/(n)]:y
info [installpostgres] Installing Postgres...
info [installpostgres] Starting yum execution “--assumeyes --color=never --config /etc/yum.conf install rh-postgresql rh-postgresql-devel rh-postgresql-libs rh-postgresql-server postgresql postgresql-devel postgresql-libs postgresql-server --disablerepo=epel”.
Loaded plugins: tsflags, universal-hooks
No package rh-postgresql available.
No package rh-postgresql-devel available.
No package rh-postgresql-libs available.
No package rh-postgresql-server available.
Resolving Dependencies
--> Running transaction check
---> Package postgresql.x86_64 0:9.2.24-4.el7_8 will be installed
--> Processing Dependency: rtld(GNU_HASH) for package: postgresql-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: postgresql-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: postgresql-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libz.so.1()(64bit) for package: postgresql-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libssl.so.10()(64bit) for package: postgresql-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libreadline.so.6()(64bit) for package: postgresql-9.2.24-4.el7_8.x86_64
---> Package postgresql-devel.x86_64 0:9.2.24-4.el7_8 will be installed
--> Processing Dependency: /bin/sh for package: postgresql-devel-9.2.24-4.el7_8.x86_64
---> Package postgresql-libs.x86_64 0:9.2.24-4.el7_8 will be installed
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT)(64bit) for package: postgresql-libs-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libgssapi_krb5.so.2(gssapi_krb5_2_MIT)(64bit) for package: postgresql-libs-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libldap_r-2.4.so.2()(64bit) for package: postgresql-libs-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libkrb5.so.3()(64bit) for package: postgresql-libs-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libgssapi_krb5.so.2()(64bit) for package: postgresql-libs-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libcom_err.so.2()(64bit) for package: postgresql-libs-9.2.24-4.el7_8.x86_64
---> Package postgresql-server.x86_64 0:9.2.24-4.el7_8 will be installed
--> Processing Dependency: systemd-units for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: systemd-units for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: systemd-sysv for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0)(64bit) for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libxml2.so.2(LIBXML2_2.4.30)(64bit) for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libpam.so.0(LIBPAM_1.0)(64bit) for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: chkconfig for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: /usr/sbin/useradd for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libxml2.so.2()(64bit) for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Processing Dependency: libpam.so.0()(64bit) for package: postgresql-server-9.2.24-4.el7_8.x86_64
--> Running transaction check
---> Package bash.x86_64 0:4.2.46-34.el7 will be installed
--> Processing Dependency: libtinfo.so.5()(64bit) for package: bash-4.2.46-34.el7.x86_64
---> Package chkconfig.x86_64 0:1.7.6-1.el7 will be installed
--> Processing Dependency: libpopt.so.0(LIBPOPT_0)(64bit) for package: chkconfig-1.7.6-1.el7.x86_64
--> Processing Dependency: libsepol.so.1()(64bit) for package: chkconfig-1.7.6-1.el7.x86_64
--> Processing Dependency: libselinux.so.1()(64bit) for package: chkconfig-1.7.6-1.el7.x86_64
--> Processing Dependency: libpopt.so.0()(64bit) for package: chkconfig-1.7.6-1.el7.x86_64
---> Package glibc.x86_64 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.x86_64
--> Processing Dependency: libgcc for package: glibc-2.17-317.el7.x86_64
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3)(64bit) for package: glibc-2.17-317.el7.x86_64
--> Processing Dependency: basesystem for package: glibc-2.17-317.el7.x86_64
--> Processing Dependency: libfreebl3.so()(64bit) for package: glibc-2.17-317.el7.x86_64
---> Package krb5-libs.x86_64 0:1.15.1-50.el7 will be installed
--> Processing Dependency: keyutils-libs >= 1.5.8 for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: sed for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.5)(64bit) for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.0)(64bit) for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3)(64bit) for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: grep for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: gawk for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: coreutils for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: libverto.so.1()(64bit) for package: krb5-libs-1.15.1-50.el7.x86_64
--> Processing Dependency: libkeyutils.so.1()(64bit) for package: krb5-libs-1.15.1-50.el7.x86_64
---> Package libcom_err.x86_64 0:1.42.9-19.el7 will be installed
---> Package libxml2.x86_64 0:2.9.1-6.el7.5 will be installed
--> Processing Dependency: liblzma.so.5(XZ_5.0)(64bit) for package: libxml2-2.9.1-6.el7.5.x86_64
--> Processing Dependency: liblzma.so.5()(64bit) for package: libxml2-2.9.1-6.el7.5.x86_64
---> Package openldap.x86_64 0:2.4.44-22.el7 will be installed
--> Processing Dependency: rpm for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: nss-tools for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libnss3.so(NSS_3.9)(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libnss3.so(NSS_3.2)(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libnss3.so(NSS_3.12.5)(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libnss3.so(NSS_3.12)(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: findutils for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libssl3.so()(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libsmime3.so()(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libplds4.so()(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libplc4.so()(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libnssutil3.so()(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libnss3.so()(64bit) for package: openldap-2.4.44-22.el7.x86_64
--> Processing Dependency: libnspr4.so()(64bit) for package: openldap-2.4.44-22.el7.x86_64
---> Package openssl-libs.x86_64 1:1.0.2k-21.el7_9 will be installed
--> Processing Dependency: ca-certificates >= 2008-5 for package: 1:openssl-libs-1.0.2k-21.el7_9.x86_64
---> Package pam.x86_64 0:1.1.8-23.el7 will be installed
--> Processing Dependency: libpwquality >= 0.9.9 for package: pam-1.1.8-23.el7.x86_64
--> Processing Dependency: cracklib-dicts >= 2.8 for package: pam-1.1.8-23.el7.x86_64
--> Processing Dependency: audit-libs >= 1.0.8 for package: pam-1.1.8-23.el7.x86_64
--> Processing Dependency: libdb-5.3.so()(64bit) for package: pam-1.1.8-23.el7.x86_64
--> Processing Dependency: libcrack.so.2()(64bit) for package: pam-1.1.8-23.el7.x86_64
--> Processing Dependency: libaudit.so.1()(64bit) for package: pam-1.1.8-23.el7.x86_64
---> Package readline.x86_64 0:6.2-11.el7 will be installed
--> Processing Dependency: /sbin/install-info for package: readline-6.2-11.el7.x86_64
--> Processing Dependency: /sbin/install-info for package: readline-6.2-11.el7.x86_64
---> Package shadow-utils.x86_64 2:4.6-5.el7 will be installed
--> Processing Dependency: setup for package: 2:shadow-utils-4.6-5.el7.x86_64
--> Processing Dependency: libsemanage.so.1(LIBSEMANAGE_1.0)(64bit) for package: 2:shadow-utils-4.6-5.el7.x86_64
--> Processing Dependency: libattr.so.1(ATTR_1.1)(64bit) for package: 2:shadow-utils-4.6-5.el7.x86_64
--> Processing Dependency: libacl.so.1(ACL_1.1)(64bit) for package: 2:shadow-utils-4.6-5.el7.x86_64
--> Processing Dependency: libsemanage.so.1()(64bit) for package: 2:shadow-utils-4.6-5.el7.x86_64
--> Processing Dependency: libattr.so.1()(64bit) for package: 2:shadow-utils-4.6-5.el7.x86_64
--> Processing Dependency: libacl.so.1()(64bit) for package: 2:shadow-utils-4.6-5.el7.x86_64
---> Package systemd.x86_64 0:219-78.el7_9.2 will be installed
--> Processing Dependency: systemd-libs = 219-78.el7_9.2 for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: kmod >= 18-4 for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libmount.so.1(MOUNT_2.20)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libmount.so.1(MOUNT_2.19)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libkmod.so.2(LIBKMOD_5)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libelf.so.1(ELFUTILS_1.0)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libdw.so.1(ELFUTILS_0.158)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libdw.so.1(ELFUTILS_0.130)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libdw.so.1(ELFUTILS_0.122)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libblkid.so.1(BLKID_2.18)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libblkid.so.1(BLKID_2.17)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libblkid.so.1(BLKID_2.15)(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: diffutils for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: dbus for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: acl for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libqrencode.so.3()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libmount.so.1()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: liblz4.so.1()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libkmod.so.2()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libgcrypt.so.11()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libelf.so.1()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libdw.so.1()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libcurl.so.4()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libcryptsetup.so.12()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libcap.so.2()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libbz2.so.1()(64bit) for package: systemd-219-78.el7_9.2.x86_64
--> Processing Dependency: libblkid.so.1()(64bit) for package: systemd-219-78.el7_9.2.x86_64
---> Package systemd-sysv.x86_64 0:219-78.el7_9.2 will be installed
--> Processing Dependency: /usr/bin/python for package: systemd-sysv-219-78.el7_9.2.x86_64
---> Package zlib.x86_64 0:1.2.7-18.el7 will be installed
--> Running transaction check
---> Package acl.x86_64 0:2.2.51-15.el7 will be installed
---> Package audit-libs.x86_64 0:2.8.5-4.el7 will be installed
--> Processing Dependency: libcap-ng.so.0()(64bit) for package: audit-libs-2.8.5-4.el7.x86_64
---> Package basesystem.noarch 0:10.0-7.el7.centos will be installed
--> Processing Dependency: filesystem for package: basesystem-10.0-7.el7.centos.noarch
---> Package bzip2-libs.x86_64 0:1.0.6-13.el7 will be installed
---> Package ca-certificates.noarch 0:2020.2.41-70.0.el7_8 will be installed
--> Processing Dependency: p11-kit-trust >= 0.23.5 for package: ca-certificates-2020.2.41-70.0.el7_8.noarch
--> Processing Dependency: p11-kit >= 0.23.5 for package: ca-certificates-2020.2.41-70.0.el7_8.noarch
---> Package coreutils.x86_64 0:8.22-24.el7_9.2 will be installed
--> Processing Dependency: ncurses for package: coreutils-8.22-24.el7_9.2.x86_64
--> Processing Dependency: gmp for package: coreutils-8.22-24.el7_9.2.x86_64
--> Processing Dependency: libgmp.so.10()(64bit) for package: coreutils-8.22-24.el7_9.2.x86_64
---> Package cracklib.x86_64 0:2.9.0-11.el7 will be installed
--> Processing Dependency: gzip for package: cracklib-2.9.0-11.el7.x86_64
---> Package cracklib-dicts.x86_64 0:2.9.0-11.el7 will be installed
---> Package cryptsetup-libs.x86_64 0:2.0.3-6.el7 will be installed
--> Processing Dependency: libuuid.so.1(UUID_1.0)(64bit) for package: cryptsetup-libs-2.0.3-6.el7.x86_64
--> Processing Dependency: libdevmapper.so.1.02(DM_1_02_97)(64bit) for package: cryptsetup-libs-2.0.3-6.el7.x86_64
--> Processing Dependency: libdevmapper.so.1.02(Base)(64bit) for package: cryptsetup-libs-2.0.3-6.el7.x86_64
--> Processing Dependency: libuuid.so.1()(64bit) for package: cryptsetup-libs-2.0.3-6.el7.x86_64
--> Processing Dependency: libjson-c.so.2()(64bit) for package: cryptsetup-libs-2.0.3-6.el7.x86_64
--> Processing Dependency: libgpg-error.so.0()(64bit) for package: cryptsetup-libs-2.0.3-6.el7.x86_64
--> Processing Dependency: libdevmapper.so.1.02()(64bit) for package: cryptsetup-libs-2.0.3-6.el7.x86_64
---> Package cyrus-sasl-lib.x86_64 0:2.1.26-23.el7 will be installed
---> Package dbus.x86_64 1:1.10.24-15.el7 will be installed
--> Processing Dependency: dbus-libs(x86-64) = 1:1.10.24-15.el7 for package: 1:dbus-1.10.24-15.el7.x86_64
--> Processing Dependency: libdbus-1.so.3(LIBDBUS_PRIVATE_1.10.24)(64bit) for package: 1:dbus-1.10.24-15.el7.x86_64
--> Processing Dependency: libdbus-1.so.3(LIBDBUS_1_3)(64bit) for package: 1:dbus-1.10.24-15.el7.x86_64
--> Processing Dependency: libexpat.so.1()(64bit) for package: 1:dbus-1.10.24-15.el7.x86_64
--> Processing Dependency: libdbus-1.so.3()(64bit) for package: 1:dbus-1.10.24-15.el7.x86_64
---> Package diffutils.x86_64 0:3.3-5.el7 will be installed
---> Package elfutils-libelf.x86_64 0:0.176-5.el7 will be installed
---> Package elfutils-libs.x86_64 0:0.176-5.el7 will be installed
--> Processing Dependency: default-yama-scope for package: elfutils-libs-0.176-5.el7.x86_64
---> Package findutils.x86_64 1:4.5.11-6.el7 will be installed
---> Package gawk.x86_64 0:4.0.2-4.el7_3.1 will be installed
---> Package glibc-common.x86_64 0:2.17-317.el7 will be installed
--> Processing Dependency: tzdata >= 2003a for package: glibc-common-2.17-317.el7.x86_64
---> Package grep.x86_64 0:2.20-3.el7 will be installed
--> Processing Dependency: libpcre.so.1()(64bit) for package: grep-2.20-3.el7.x86_64
---> Package imh-libcurl.x86_64 0:7.45.0-20.el7.centos will be installed
--> Processing Dependency: libssh2 >= 1.2 for package: imh-libcurl-7.45.0-20.el7.centos.x86_64
--> Processing Dependency: libidn.so.11(LIBIDN_1.0)(64bit) for package: imh-libcurl-7.45.0-20.el7.centos.x86_64
--> Processing Dependency: libssh2.so.1()(64bit) for package: imh-libcurl-7.45.0-20.el7.centos.x86_64
--> Processing Dependency: libidn.so.11()(64bit) for package: imh-libcurl-7.45.0-20.el7.centos.x86_64
---> Package info.x86_64 0:5.1-5.el7 will be installed
---> Package keyutils-libs.x86_64 0:1.5.8-3.el7 will be installed
---> Package kmod.x86_64 0:20-28.el7 will be installed
--> Processing Dependency: dracut for package: kmod-20-28.el7.x86_64
--> Processing Dependency: /usr/bin/xz for package: kmod-20-28.el7.x86_64
--> Processing Dependency: /usr/bin/nm for package: kmod-20-28.el7.x86_64
--> Processing Dependency: /usr/bin/cpio for package: kmod-20-28.el7.x86_64
---> Package kmod-libs.x86_64 0:20-28.el7 will be installed
---> Package libacl.x86_64 0:2.2.51-15.el7 will be installed
---> Package libattr.x86_64 0:2.4.46-13.el7 will be installed
---> Package libblkid.x86_64 0:2.23.2-65.el7 will be installed
---> Package libcap.x86_64 0:2.22-11.el7 will be installed
---> Package libdb.x86_64 0:5.3.21-25.el7 will be installed
---> Package libgcc.x86_64 0:4.8.5-44.el7 will be installed
---> Package libgcrypt.x86_64 0:1.5.3-14.el7 will be installed
---> Package libmount.x86_64 0:2.23.2-65.el7 will be installed
---> Package libpwquality.x86_64 0:1.2.3-5.el7 will be installed
---> Package libselinux.x86_64 0:2.5-15.el7 will be installed
---> Package libsemanage.x86_64 0:2.5-14.el7 will be installed
--> Processing Dependency: libustr-1.0.so.1(USTR_1.0.1)(64bit) for package: libsemanage-2.5-14.el7.x86_64
--> Processing Dependency: libustr-1.0.so.1(USTR_1.0)(64bit) for package: libsemanage-2.5-14.el7.x86_64
--> Processing Dependency: libustr-1.0.so.1()(64bit) for package: libsemanage-2.5-14.el7.x86_64
---> Package libsepol.x86_64 0:2.5-10.el7 will be installed
---> Package libverto.x86_64 0:0.2.5-4.el7 will be installed
---> Package lz4.x86_64 0:1.8.3-1.el7 will be installed
---> Package ncurses-libs.x86_64 0:5.9-14.20130511.el7_4 will be installed
--> Processing Dependency: ncurses-base = 5.9-14.20130511.el7_4 for package: ncurses-libs-5.9-14.20130511.el7_4.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: ncurses-libs-5.9-14.20130511.el7_4.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: ncurses-libs-5.9-14.20130511.el7_4.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: ncurses-libs-5.9-14.20130511.el7_4.x86_64
---> Package nspr.x86_64 0:4.25.0-2.el7_9 will be installed
---> Package nss.x86_64 0:3.53.1-3.el7_9 will be installed
--> Processing Dependency: nss-softokn(x86-64) >= 3.53.1-2 for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: nss-system-init for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: nss-pem(x86-64) for package: nss-3.53.1-3.el7_9.x86_64
---> Package nss-softokn-freebl.x86_64 0:3.53.1-6.el7_9 will be installed
---> Package nss-tools.x86_64 0:3.53.1-3.el7_9 will be installed
---> Package nss-util.x86_64 0:3.53.1-1.el7_9 will be installed
---> Package popt.x86_64 0:1.13-16.el7 will be installed
---> Package python.x86_64 0:2.7.5-90.el7 will be installed
--> Processing Dependency: python-libs(x86-64) = 2.7.5-90.el7 for package: python-2.7.5-90.el7.x86_64
--> Processing Dependency: libpython2.7.so.1.0()(64bit) for package: python-2.7.5-90.el7.x86_64
---> Package qrencode-libs.x86_64 0:3.4.1-3.el7 will be installed
---> Package rpm.x86_64 0:4.11.3-45.el7 will be installed
--> Processing Dependency: curl for package: rpm-4.11.3-45.el7.x86_64
--> Processing Dependency: /usr/bin/db_stat for package: rpm-4.11.3-45.el7.x86_64
--> Processing Dependency: librpmio.so.3()(64bit) for package: rpm-4.11.3-45.el7.x86_64
--> Processing Dependency: librpm.so.3()(64bit) for package: rpm-4.11.3-45.el7.x86_64
--> Processing Dependency: liblua-5.1.so()(64bit) for package: rpm-4.11.3-45.el7.x86_64
---> Package sed.x86_64 0:4.2.2-7.el7 will be installed
---> Package setup.noarch 0:2.8.71-11.el7 will be installed
---> Package systemd-libs.x86_64 0:219-78.el7_9.2 will be installed
---> Package xz-libs.x86_64 0:5.2.2-1.el7 will be installed
--> Running transaction check
---> Package basesystem.noarch 0:10.0-7.el7.centos will be installed
--> Processing Dependency: filesystem for package: basesystem-10.0-7.el7.centos.noarch
---> Package binutils.x86_64 0:2.27-44.base.el7 will be installed
---> Package cpio.x86_64 0:2.11-28.el7 will be installed
---> Package curl.x86_64 0:7.29.0-59.el7_9.1 will be installed
--> Processing Dependency: libcurl = 7.29.0-59.el7_9.1 for package: curl-7.29.0-59.el7_9.1.x86_64
---> Package dbus-libs.x86_64 1:1.10.24-15.el7 will be installed
---> Package device-mapper-libs.x86_64 7:1.02.170-6.el7_9.3 will be installed
--> Processing Dependency: device-mapper = 7:1.02.170-6.el7_9.3 for package: 7:device-mapper-libs-1.02.170-6.el7_9.3.x86_64
---> Package dracut.x86_64 0:033-572.el7 will be installed
--> Processing Dependency: util-linux >= 2.21 for package: dracut-033-572.el7.x86_64
--> Processing Dependency: filesystem >= 2.1.0 for package: dracut-033-572.el7.x86_64
--> Processing Dependency: tar for package: dracut-033-572.el7.x86_64
--> Processing Dependency: procps-ng for package: dracut-033-572.el7.x86_64
--> Processing Dependency: kpartx for package: dracut-033-572.el7.x86_64
--> Processing Dependency: hardlink for package: dracut-033-572.el7.x86_64
--> Processing Dependency: /usr/bin/pkg-config for package: dracut-033-572.el7.x86_64
---> Package elfutils-default-yama-scope.noarch 0:0.176-5.el7 will be installed
---> Package expat.x86_64 0:2.1.0-12.el7 will be installed
---> Package gmp.x86_64 1:6.0.0-15.el7 will be installed
---> Package gzip.x86_64 0:1.5-10.el7 will be installed
---> Package json-c.x86_64 0:0.11-4.el7_0 will be installed
---> Package libcap-ng.x86_64 0:0.7.5-4.el7 will be installed
---> Package libdb-utils.x86_64 0:5.3.21-25.el7 will be installed
---> Package libgpg-error.x86_64 0:1.12-3.el7 will be installed
---> Package libidn.x86_64 0:1.28-4.el7 will be installed
---> Package libssh2.x86_64 0:1.8.0-4.el7 will be installed
---> Package libstdc++.x86_64 0:4.8.5-44.el7 will be installed
---> Package libuuid.x86_64 0:2.23.2-65.el7 will be installed
---> Package lua.x86_64 0:5.1.4-15.el7 will be installed
---> Package ncurses.x86_64 0:5.9-14.20130511.el7_4 will be installed
---> Package ncurses-base.noarch 0:5.9-14.20130511.el7_4 will be installed
---> Package nss-pem.x86_64 0:1.0.3-7.el7 will be installed
---> Package nss-softokn.x86_64 0:3.53.1-6.el7_9 will be installed
--> Processing Dependency: libsqlite3.so.0()(64bit) for package: nss-softokn-3.53.1-6.el7_9.x86_64
---> Package nss-sysinit.x86_64 0:3.53.1-3.el7_9 will be installed
---> Package p11-kit.x86_64 0:0.23.5-3.el7 will be installed
--> Processing Dependency: libffi.so.6()(64bit) for package: p11-kit-0.23.5-3.el7.x86_64
---> Package p11-kit-trust.x86_64 0:0.23.5-3.el7 will be installed
--> Processing Dependency: libtasn1.so.6(LIBTASN1_0_3)(64bit) for package: p11-kit-trust-0.23.5-3.el7.x86_64
--> Processing Dependency: libtasn1.so.6()(64bit) for package: p11-kit-trust-0.23.5-3.el7.x86_64
---> Package pcre.x86_64 0:8.32-17.el7 will be installed
---> Package python-libs.x86_64 0:2.7.5-90.el7 will be installed
--> Processing Dependency: libgdbm_compat.so.4()(64bit) for package: python-libs-2.7.5-90.el7.x86_64
--> Processing Dependency: libgdbm.so.4()(64bit) for package: python-libs-2.7.5-90.el7.x86_64
---> Package rpm-libs.x86_64 0:4.11.3-45.el7 will be installed
---> Package tzdata.noarch 0:2020d-2.el7 will be installed
---> Package ustr.x86_64 0:1.0.4-16.el7 will be installed
---> Package xz.x86_64 0:5.2.2-1.el7 will be installed
--> Running transaction check
---> Package basesystem.noarch 0:10.0-7.el7.centos will be installed
--> Processing Dependency: filesystem for package: basesystem-10.0-7.el7.centos.noarch
---> Package device-mapper.x86_64 7:1.02.170-6.el7_9.3 will be installed
---> Package dracut.x86_64 0:033-572.el7 will be installed
--> Processing Dependency: filesystem >= 2.1.0 for package: dracut-033-572.el7.x86_64
---> Package gdbm.x86_64 0:1.10-8.el7 will be installed
---> Package hardlink.x86_64 1:1.0-19.el7 will be installed
---> Package kpartx.x86_64 0:0.4.9-134.el7_9 will be installed
---> Package libcurl.x86_64 0:7.29.0-59.el7_9.1 will be installed
---> Package libffi.x86_64 0:3.0.13-19.el7 will be installed
---> Package libtasn1.x86_64 0:4.10-1.el7 will be installed
---> Package pkgconfig.x86_64 1:0.27.1-4.el7 will be installed
--> Processing Dependency: libglib-2.0.so.0()(64bit) for package: 1:pkgconfig-0.27.1-4.el7.x86_64
---> Package procps-ng.x86_64 0:3.3.10-28.el7 will be installed
---> Package sqlite.x86_64 0:3.7.17-8.el7_7.1 will be installed
---> Package tar.x86_64 2:1.26-35.el7 will be installed
---> Package util-linux.x86_64 0:2.23.2-65.el7 will be installed
--> Processing Dependency: libsmartcols = 2.23.2-65.el7 for package: util-linux-2.23.2-65.el7.x86_64
--> Processing Dependency: libutempter.so.0(UTEMPTER_1.1)(64bit) for package: util-linux-2.23.2-65.el7.x86_64
--> Processing Dependency: libsmartcols.so.1(SMARTCOLS_2.25)(64bit) for package: util-linux-2.23.2-65.el7.x86_64
--> Processing Dependency: libutempter.so.0()(64bit) for package: util-linux-2.23.2-65.el7.x86_64
--> Processing Dependency: libuser.so.1()(64bit) for package: util-linux-2.23.2-65.el7.x86_64
--> Processing Dependency: libsmartcols.so.1()(64bit) for package: util-linux-2.23.2-65.el7.x86_64
--> Running transaction check
---> Package basesystem.noarch 0:10.0-7.el7.centos will be installed
--> Processing Dependency: filesystem for package: basesystem-10.0-7.el7.centos.noarch
---> Package dracut.x86_64 0:033-572.el7 will be installed
--> Processing Dependency: filesystem >= 2.1.0 for package: dracut-033-572.el7.x86_64
---> Package glib2.x86_64 0:2.56.1-8.el7 will be installed
--> Processing Dependency: shared-mime-info for package: glib2-2.56.1-8.el7.x86_64
---> Package libsmartcols.x86_64 0:2.23.2-65.el7 will be installed
---> Package libuser.x86_64 0:0.60-9.el7 will be installed
---> Package libutempter.x86_64 0:1.1.6-4.el7 will be installed
--> Running transaction check
---> Package basesystem.noarch 0:10.0-7.el7.centos will be installed
--> Processing Dependency: filesystem for package: basesystem-10.0-7.el7.centos.noarch
---> Package dracut.x86_64 0:033-572.el7 will be installed
--> Processing Dependency: filesystem >= 2.1.0 for package: dracut-033-572.el7.x86_64
---> Package shared-mime-info.x86_64 0:1.8-5.el7 will be installed
--> Finished Dependency Resolution
Error: Package: basesystem-10.0-7.el7.centos.noarch (base)
Error: Package: dracut-033-572.el7.x86_64 (base)
You could try using --skip-broken to work around the problem
info [installpostgres] Completed yum execution “--assumeyes --color=never --config /etc/yum.conf install rh-postgresql rh-postgresql-devel rh-postgresql-libs rh-postgresql-server postgresql postgresql-devel postgresql-libs postgresql-server --disablerepo=epel”: in 3.260 second(s).
(XID v2jsbf) “/usr/bin/yum” reported error code “1” when it ended:
Use of uninitialized value $pg_data in concatenation (.) or string at /usr/local/cpanel/scripts/installpostgres line 148.
Use of uninitialized value $out in scalar chomp at /usr/local/cpanel/scripts/installpostgres line 75.
info [installpostgres] Updating postgresql configuration now...
Failed to determine postgresql data directory
info [installpostgres] Attempting to restart postgresql...
The PostgreSQL installation failed!
[email protected] [~]#
I was digging for information as to why this is occurring but with no success.
Do you guys know what's happening? And how to resolve the issue?

Thank you!
 
Last edited by a moderator:

Brukenzeper

Registered
Jan 21, 2021
2
0
1
Philippines
cPanel Access Level
Root Administrator
Hey there! Could you send the output of the following command so we know what your base operating system is and that it is reporting correct details?

Code:
uname -srvo
Hi! Thank you for your quick response. This is the output after running uname -srvo:
Code:
[email protected] [~]# uname -srvo
Linux 3.10.0-1127.18.2.vz7.163.46 #1 SMP Fri Nov 20 21:47:55 MSK 2020 GNU/Linux
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,418
999
313
cPanel Access Level
Root Administrator
That all looks normal to me. It seems like there is an issue with Yum on the system that needs to be resolved, as it's not properly detecting your operating system. Could you open a support ticket with our team so we can look into that for you on our end? If you do create a ticket, please post the number here so I can follow along and make sure this thread gets updated.