Error Package Requires: httpd24-httpd

babbler

Member
Mar 10, 2015
10
0
1
New Zealand
cPanel Access Level
Root Administrator
I'm not sure this is the right forum but here is my problem.

I am trying to install mod_wsgi (rh-python36-mod_wsgi.x86_64) from the centos-sclo-rh repo but I get the following error:

Error: Package: rh-python36-mod_wsgi-4.5.18-1.el7.x86_64 (centos-sclo-rh)
Requires: httpd24-httpd-mmn = 20120211x8664
Error: Package: rh-python36-mod_wsgi-4.5.18-1.el7.x86_64 (centos-sclo-rh)
Requires: httpd24-httpd >= 2.4.6-2

My question is how can I install httpd24-httpd as required via EA4 or is there a better way?

I have found httpd24 here:
httpd24-httpd-2.4.18-11.el7.x86_64.rpm CentOS 7 Download

but am nervous about installing it as I'm not sure how, and I don't know whether it will cause problems?

Many thanks for your suggestions and time.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Hello,

Manually installing third-party Apache-related RPMs with EasyApache 4 is unsupported and won't automatically integrate. If you need wsgi on EasyApache 4, you could setup the EA4 experimental repo using the instructions at:

The Experimental Repository - EasyApache 4 - cPanel Documentation

Then, install wsgi using the following command:

Code:
yum install ea-apache24-mod_wsgi
Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Hello,

You can use the following command to see which Python library mod_wsgi is associated with after it's installed:

Code:
ldd /usr/lib64/apache2/modules/mod_wsgi.so
Note that Python 3 is not included with CentOS 7 by default. You will need to first install Python 3 on the server (this is unsupported and untested).

Thank you.