Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)

Sep 29, 2016
12
2
3
Portugal
cPanel Access Level
Root Administrator
Hello.
I've been receiving error reports about /usr/local/cpanel/scripts/rpmup for weeks.

I ran it manually also and the error messages are this:

Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)
Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
info [rpmup] Completed yum execution “--assumeyes --config /etc/yum.conf update --disablerepo=epel”: in 15.474 second(s).
(XID 7bx3xe) The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf update --disablerepo=epel” because of an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf update --disablerepo=epel” command (process 1899) reported error number 1 when it ended. : Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)
Requires: libsemanage >= 2.5-13
Installed: libsemanage-2.5-8.el7.x86_64 (@base)
libsemanage = 2.5-8.el7
Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)
Requires: policycoreutils >= 2.5-24
Error: Package: 32:bind-9.9.4-74.el7_6.1.x86_64 (updates)
Requires: policycoreutils-python
Error: Package: 32:bind-9.9.4-74.el7_6.1.x86_64 (updates)
Requires: libselinux-utils
checkyum version 22.3 (excludes: bind-chroot perl ruby)​


As suggested in the above text, I also ran:

rpm -Va --nofiles --nodigest
/usr/local/cpanel/scripts/rpmup --skip-broken

But the errors are similar:
(XID 68qjnq) The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf update --disablerepo=epel” because of
an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf update --disablerepo=epel” command (process 2296) reported error number 1 when it ended. :
Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)
Requires: libsemanage >= 2.5-13
Installed: libsemanage-2.5-8.el7.x86_64 (@base)
libsemanage = 2.5-8.el7
Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)
Requires: policycoreutils >= 2.5-24
Error: Package: 32:bind-9.9.4-74.el7_6.1.x86_64 (updates)
Requires: policycoreutils-python
Error: Package: 32:bind-9.9.4-74.el7_6.1.x86_64 (updates)
Requires: libselinux-utils
checkyum version 22.3 (excludes: bind-chroot perl ruby)​

My system is a CentOS managed by cPanel/WHM.

Any hints?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,298
1,279
313
Houston
It looks like it's wanting to update dependencies but it's unable to do so:

What's the output of the following:

Code:
yum info libsemanage policycoreutils policycoreutils-python libselinux-utils |egrep 'Name|Version|Release'
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,298
1,279
313
Houston
The output of that indicates that the packages policycoreutils policycoreutils-python libselinux-utils aren't present or being found in the repository. Can you show me the output of the following?

Code:
yum list enabled
You could also try cleaning the cache and looking for the packages again:

Code:
yum clean all
Code:
yum info libsemanage policycoreutils policycoreutils-python libselinux-utils |egrep 'Name|Version|Release'
 
Sep 29, 2016
12
2
3
Portugal
cPanel Access Level
Root Administrator
yum list enabled
Loaded plugins: fastestmirror, langpacks, tsflags, universal-hooks
Loading mirror speeds from cached hostfile
* EA4: 185.15.22.168
* cpanel-addons-production-feed: 185.15.22.168
* cpanel-plugins: 185.15.22.168
* base: mirror.fccn.pt
* epel: mirrors.up.pt
* extras: mirror.fccn.pt
* updates: mirror.fccn.pt
Error: No matching Packages to list

I also cleaned the cache and retried yum info, but got the same result.

Thanks for your help.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,298
1,279
313
Houston
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!