fly_in_the_sky

Active Member
Nov 3, 2013
35
0
6
Pyrénnée, France
cPanel Access Level
Root Administrator
Hello,
I just install whm and cpanel over my server centos 6.
Wenn i trye to insert image on a new articel in prestashop
Fatal error: Call to undefined function imagecreatefromjpeg() in /home/jeuxcoop/public_html/shop/images.inc.php on line 212
I don't now wath to do ?
Tanks you for your help
Nicolas
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
Hello,
I just install whm and cpanel over my server centos 6.
Wenn i trye to insert image on a new articel in prestashop

I don't now wath to do ?
Tanks you for your help
Nicolas
Run Easyapache and add GD.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Yes, please select "GD" in your EasyApache build profile. EasyApache is accessible via:

/scripts/easyapache

Or;

"WHM Home » Software » EasyApache (Apache Update)"

Thank you.
 

fly_in_the_sky

Active Member
Nov 3, 2013
35
0
6
Pyrénnée, France
cPanel Access Level
Root Administrator
Hi tank you for your help

Code:
[email protected] [/home/casse-noisettes]# /scripts/easyapache
!! Object fetch succeeded with {"status":"1"} for EasyApache v32219 and Cpanel v1140 !!
!! Pre allocation testing was successfully able to allocate 90MB !!
!! 
Output from '/bin/sh -c "ulimit -a"': 
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 7835
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) 7835
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited
!!



!! 'Xen' environment detected !!
!! Please read below carefully !!
!! 
Xen's 'xm console' does NOT support curses.

If you are logged in via 'xm console' you should exit now and re-login in via SSH or you will experience an unusable UI.

Once you are logged in via SSH you can use --skip-xen-broken-xm-check to avoid this prompt if you wish.
!!

Hit enter (or wait 30 seconds) to exit or type 'not xm' and hit enter to continue:

And after watt i have to do ?
 

fly_in_the_sky

Active Member
Nov 3, 2013
35
0
6
Pyrénnée, France
cPanel Access Level
Root Administrator
I trye with esayappach in WHM but i have one error :

Code:
!! Object fetch succeeded with {"status":"1"} for EasyApache v32219 and Cpanel v1140 !!
Content-type: text/html
If the browser window is closed or stopped the build will continue in the background.
The build output should start shortly...

Distilled successfully
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1383853686' !!
!! 
Output from '/bin/sh -c "ulimit -a"': 
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 7835
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) 7835
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited
!!
!! Creating backup of working apache in '/usr/local/apache.backup'. !!
!! Symlink encountered (/usr/local/apache/etc), preserving target (conf)... !!

!! Backup of working apache complete. !!
Checking that all tarballs are present and up to date.
Checking that all packages are present and up to date.
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Setting up Install Process
Package gettext-0.17-16.el6.i686 already installed and latest version
No package automake19 available.
Package 2:libpng-devel-1.2.49-1.el6_2.i686 already installed and latest version
Package openssl-1.0.0-27.el6_4.2.i686 already installed and latest version
No package libpng-dev available.
Package zlib-devel-1.2.3-29.el6.i686 already installed and latest version
No package autoconf261 available.
Package libidn-devel-1.18-2.el6.i686 already installed and latest version
No package gmake available.
Package libidn-1.18-2.el6.i686 already installed and latest version
Package libXpm-3.5.10-2.el6.i686 already installed and latest version
Package openssl-devel-1.0.0-27.el6_4.2.i686 already installed and latest version
Package automake-1.11.1-4.el6.noarch already installed and latest version
Package coreutils-8.4-19.el6_4.2.i686 already installed and latest version
Package patch-2.6-6.el6.i686 already installed and latest version
No package libstdc++-dev available.
No package libltdl3-devel available.
No package libltdl available.
No package libopenssl0.9.7-static-devel available.
Package libtool-ltdl-devel-2.2.6-15.5.el6.i686 already installed and latest version
Package libXpm-devel-3.5.10-2.el6.i686 already installed and latest version
Package sed-4.2.1-10.el6.i686 already installed and latest version
No package libXpm-dev available.
Package lsof-4.82-4.el6.i686 already installed and latest version
No package krb5-dev available.
Package flex-2.5.35-8.el6.i686 already installed and latest version
No package glibc-dev available.
No package expat-dev available.
Package krb5-devel-1.10.3-10.el6_4.6.i686 already installed and latest version
No package xorg-x11-devel available.
Package libtool-ltdl-2.2.6-15.5.el6.i686 already installed and latest version
No package libssl-dev available.
Package pam-devel-1.1.1-13.el6.i686 already installed and latest version
No package libopenssl0-devel available.
No package zlib1-devel available.
Package expat-devel-2.0.1-11.el6_2.i686 already installed and latest version
No package libopenssl0-dev available.
Package glibc-devel-2.12-1.107.el6_4.5.i686 already installed and latest version
Package expat-2.0.1-11.el6_2.i686 already installed and latest version
Package gcc-c++-4.4.7-3.el6.i686 already installed and latest version
Package libstdc++-4.4.7-3.el6.i686 already installed and latest version
Package zlib-1.2.3-29.el6.i686 already installed and latest version
Package compat-expat1-1.95.8-8.el6.i686 already installed and latest version
Package bison-2.4.1-5.el6.i686 already installed and latest version
Package libstdc++-devel-4.4.7-3.el6.i686 already installed and latest version
Package libjpeg-turbo-devel-1.2.1-1.el6.i686 already installed and latest version
No package libtool-libltdl-devel available.
Package libtool-2.2.6-15.5.el6.i686 already installed and latest version
No package openssl-dev available.
No package libopenssl0 available.
No package libz-devel available.
No package libjpeg-dev available.
No package pam-dev available.
Package coreutils-8.4-19.el6_4.2.i686 already installed and latest version
No package libltdl-devel available.
No package libopenssl0.9.7-devel available.
Package e2fsprogs-devel-1.41.12-14.el6_4.4.i686 already installed and latest version
No package ca_root_nss available.
Package 1:make-3.81-20.el6.i686 already installed and latest version
Package libX11-devel-1.5.0-4.el6.i686 already installed and latest version
No package libstdc++-devel.x86_64 available.
Package gd-2.0.35-11.el6.i686 already installed and latest version
Package cpp-4.4.7-3.el6.i686 already installed and latest version
No package xorg-x11-dev available.
Package gcc-4.4.7-3.el6.i686 already installed and latest version
No package ssl-dev available.
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
No package lex available.
Nothing to do
!! Processing RPMs... !!


-- Begin opt 'Deflate' --

    -- Begin step 'to config options' --
    -- End step 'to config options' --
-- End opt 'Deflate' --

-- Begin opt 'Expires' --

    -- Begin step 'to config options' --
    -- End step 'to config options' --
-- End opt 'Expires' --

-- Begin opt 'Fileprotect' --
    -- Begin dryrun test 'turning it on...' --
    -- End dryrun test 'turning it on...' --

    -- Begin step 'Run /scripts/enablefileprotect after Apache is installed' --
    -- End step 'Run /scripts/enablefileprotect after Apache is installed' --
-- End opt 'Fileprotect' --

-- Begin opt 'Frontpage' --
    -- Begin dryrun test 'Check for installed frontpage' --
    -- End dryrun test 'Check for installed frontpage' --
    -- Begin dryrun test 'Remove immutable bit from fpexe' --
    -- End dryrun test 'Remove immutable bit from fpexe' --
    -- Begin dryrun test 'Create directories' --
    -- End dryrun test 'Create directories' --
    -- Begin dryrun test 'Set permissions on cpupdates' --
    -- End dryrun test 'Set permissions on cpupdates' --
    -- Begin dryrun test 'Download frontpage' --
    -- End dryrun test 'Download frontpage' --
    -- Begin dryrun test 'Install frontpage' --
    -- End dryrun test 'Install frontpage' --
    -- Begin dryrun test 'Clean up temporary frontpage files' --
    -- End dryrun test 'Clean up temporary frontpage files' --
    -- Begin dryrun test 'Protect fpexe' --
    -- End dryrun test 'Protect fpexe' --
    -- Begin dryrun test 'frontpage execution test' --
    -- End dryrun test 'frontpage execution test' --
    -- Begin dryrun test 'Create task list to do after apache is built' --
    -- End dryrun test 'Create task list to do after apache is built' --

    -- Begin step 'Create task list to do after apache configure' --
    -- End step 'Create task list to do after apache configure' --
-- End opt 'Frontpage' --

-- Begin opt 'Headers' --

    -- Begin step 'to config options' --
    -- End step 'to config options' --
-- End opt 'Headers' --

-- Begin opt 'Mod SuPHP' --

    -- Begin step 'Setting version variable' --
    -- End step 'Setting version variable' --

    -- Begin step 'Patching mod_suphp' --
Patch tested at -p1; ../cppatch/01_suphp_paths.patch
Applying patch; ../cppatch/01_suphp_paths.patch
patching file src/apache/mod_suphp.c
patching file src/apache2/mod_suphp.c
Patch tested at -p1; ../cppatch/02_suphp_userdir.patch
Applying patch; ../cppatch/02_suphp_userdir.patch
patching file src/apache/mod_suphp.c
patching file src/apache2/mod_suphp.c
patching file src/Application.cpp
patching file src/Configuration.cpp
patching file src/Configuration.hpp
Patch tested at -p1; ../cppatch/03_suphp_full_php_process_display.patch
Applying patch; ../cppatch/03_suphp_full_php_process_display.patch
patching file src/Application.cpp
patching file src/Configuration.cpp
patching file src/Configuration.hpp
Patch tested at -p1; ../cppatch/04_suphp_paranoid_checks.patch
Applying patch; ../cppatch/04_suphp_paranoid_checks.patch
patching file src/Application.cpp
patching file src/Configuration.cpp
patching file src/Configuration.hpp
Patch tested at -p1; ../cppatch/05_suphp_phprc.patch
Applying patch; ../cppatch/05_suphp_phprc.patch
patching file src/Application.cpp
patching file src/Application.hpp
patching file src/Configuration.cpp
patching file src/Configuration.hpp
Patch tested at -p1; ../cppatch/07_suphp_apache24_detect.patch
Applying patch; ../cppatch/07_suphp_apache24_detect.patch
patching file configure
    -- End step 'Patching mod_suphp' --

    -- Begin step 'Create task list to do after apache is built' --
    -- End step 'Create task list to do after apache is built' --
-- End opt 'Mod SuPHP' --

-- Begin opt 'Proxy' --

    -- Begin step 'Adding --enable-proxy to Apache configure line' --
    -- End step 'Adding --enable-proxy to Apache configure line' --
-- End opt 'Proxy' --

-- Begin opt 'Apache 2.2' --
!! Failed to install CPAN Perl module(s) Digest::SHA1 Crypt::PasswdMD5 !!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
!! Failed to install CPAN Perl module(s) Digest::SHA1 Crypt::PasswdMD5 !!
Check to see if there are multiple Perl installations on this system with a command such as:

Code:
ls -l /usr/bin/perl /usr/local/bin/perl
If there are not, check for specific errors when attempting to install this Perl module manually:

Code:
/scripts/perlinstaller Digest::SHA1 Crypt::PasswdMD5
Thank you.
 

fly_in_the_sky

Active Member
Nov 3, 2013
35
0
6
Pyrénnée, France
cPanel Access Level
Root Administrator
Code:
[email protected] [/home/casse-noisettes]# /usr/bin/perl -v

This is perl, v5.10.1 (*) built for i386-linux-thread-multi

Copyright 1987-2009, Larry Wall

Perl may be copied ......

[email protected] [/home/casse-noisettes]# /usr/local/bin/perl -v
bash: /usr/local/bin/perl: Aucun fichier ou dossier de ce type

[email protected] [/home/casse-noisettes]# /scripts/perlinstaller Digest::SHA1 Crypt::PasswdMD5
Can't locate Cwd.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /usr/local/cpanel/Cpanel/cPCPAN.pm line 41.
[email protected] [/home/casse-noisettes]#

I have only one instaltion
Tank you
 

fly_in_the_sky

Active Member
Nov 3, 2013
35
0
6
Pyrénnée, France
cPanel Access Level
Root Administrator
I trye diffent thing .. .but nothing good

Code:
[email protected] [/home/casse-noisettes]# /scripts/autorepair scalarutil
Requesting script ... Done
Auto Repair is running......Auto Repair is done.

[email protected] [/home/casse-noisettes]# cpan
Can't locate File/Spec.pm in @INC (@INC contains: /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /usr/share/perl5/CPAN.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/CPAN.pm line 10.
Compilation failed in require at /usr/share/perl5/App/Cpan.pm line 218.
BEGIN failed--compilation aborted at /usr/share/perl5/App/Cpan.pm line 218.
Compilation failed in require at /usr/bin/cpan line 9.
BEGIN failed--compilation aborted at /usr/bin/cpan line 9.

[email protected] [/home/casse-noisettes]# /usr/local/cpanel/bin/cpanm -n Digest::SHA1 Crypt::PasswdMD5
Can't locate Cwd.pm in @INC (@INC contains: CODE(0x8068890) /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /loader/0x8068890/App/cpanminus/script.pm line 4.
BEGIN failed--compilation aborted at /loader/0x8068890/App/cpanminus/script.pm line 4.
Compilation failed in require at /usr/local/cpanel/bin/cpanm line 20668.
BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cpanm line 20668.

[email protected] [/home/casse-noisettes]# /usr/local/cpanel/scripts/perlinstaller Digest::SHA1
Can't locate Cwd.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /usr/local/cpanel/Cpanel/cPCPAN.pm line 41.

[email protected] [/home/casse-noisettes]# /scripts/autorepair scalarutil
Requesting script ... Done
Auto Repair is running......Auto Repair is done.

[email protected] [/home/casse-noisettes]# /scripts/perlinstaller Crypt::PasswdMD5
Can't locate Cwd.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /usr/local/cpanel/Cpanel/cPCPAN.pm line 41.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
It looks like there may be an issue with the installation of Perl on your system. Feel free to open a support ticket so we can take a closer look:

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

fly_in_the_sky

Active Member
Nov 3, 2013
35
0
6
Pyrénnée, France
cPanel Access Level
Root Administrator
It looks like there may be an issue with the installation of Perl on your system. Feel free to open a support ticket so we can take a closer look:

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
Yes tanks you, my tiquet : tickets ID# 4390529

Perl was totaly broke on my server,

the cp staff make these code : yum reinstall perl

Now it's work
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
To update, it appears the system installation of Perl was not functioning properly. The resolution, as indicated in the previous post, was to reinstall the system Perl via:

Code:
yum reinstall perl
Thank you.