The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error reloading bind on server

Discussion in 'Bind / DNS / Nameserver Issues' started by mahdionline, Aug 11, 2004.

  1. mahdionline

    mahdionline Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    127
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    I have a big problem, we have a RHE3 server , when i add a account , server cannot reload the bind and show this error :

    Bind reloading on server using rndc
    Error reloading bind on server: rndc: connect failed: connection refused

    but if i restart the server this problem solved !

    what should i do for fix this problem ?

    Regard
     
  2. Fillos

    Fillos Active Member

    Joined:
    Mar 24, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Northern Ontario
    Try "/scripts/fixndc". If that doesn't work, try this tutorial that I gleaned from someone else on the net (From: http://www.soapi.com/howto/bind.htm). It has solved this problem for me in the past:



    Now that we have established that we need to create a key and configure BIND, the first thing to do is to backup the files we are going to alter, so type the following commands:

    cp /etc/rndc.conf /etc/rndc.conf.backup
    cp /etc/named.conf /etc/named.conf.backup
    cp /etc/rndc.key /etc/rndc.key.backup


    4
    The next step is to use rndc-confgen to create the key. However, we do not want named.conf to be altered, so the command to type is:

    rndc-confgen -a
    The program will generate a key, which will be put in rndc.key. It will also put the necessary information into rndc.conf, and suggest values to enter into named.conf.



    5
    The next step is to modify the configuration files. Type the following command:

    pico -w /etc/rndc.conf
    Modify the file to read:

    options {
    default-server localhost;
    default-key rndc_key;
    };

    server localhost {
    key rndc_key;
    };

    key rndc_key {
    algorithm hmac-md5;
    secret "ViQerSyUBXwosrWGekrJpXuxTraFNaESgtAFqkLhSGdgNdcAKsImEQX";
    };
    Type Ctrl-X and then Y and then Enter to save the file.



    6
    Type the following command:

    pico -w /etc/named.conf
    Modify the file to read:


    key rndc_key {
    algorithm hmac-md5;
    secret "ViQerSyUBXwosrWGekrJpXuxTraFNaESgtAFqkLhSGdgNdcAKsImEQX";
    };

    controls {
    inet 127.0.0.1 port 953
    allow { 127.0.0.1; } keys { rndc_key; };
    };
    Type Ctrl-X and then Y and then Enter to save the file.



    7
    Type the following command:

    pico -w /etc/rndc.key
    Modify the file to read:

    key rndc_key {
    algorithm hmac-md5;
    secret "ViQerSyUBXwosrWGekrJpXuxTraFNaESgtAFqkLhSGdgNdcAKsImEQX";
    };
    Type Ctrl-X and then Y and then Enter to save the file.



    7
    Now that the configuration files have been modified, it is time to test them out. Restart named by typing the following command:

    service named restart
    Next, query the status of the service:

    service named status
    If all went well, there should be no errors,

    Hope that helps
     
    #2 Fillos, Aug 12, 2004
    Last edited: Aug 12, 2004
  3. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    named-checkconf
     
  4. atul

    atul Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Try this

    Hello,
    do
    #rndc reload
    Then restart named
    See if it solves ur problem..
     
Loading...

Share This Page