The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

error restarting imap services

Discussion in 'General Discussion' started by anish sidhan, Dec 7, 2003.

  1. anish sidhan

    anish sidhan Well-Known Member

    Joined:
    Sep 26, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    When I tried to restart imap services via whm i get the following error message. When I tried to restart it via shell I was suceesfull.

    imap: [ != ..OK] imap has failed, please contact the sysadmin.

    I checked the /etc/xinetd.d/cpimap file.

    I also tried
    /etc/rc.d/init.d/portsentry stop
    restart imap
    /etc/rc.d/init.d/portsentry start

    Still the error is not fixed. Is this a BUG. Please help. Thanks in advance.

    --Anish
     
  2. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Did you find a fix to this as I am getting the same error.
     
  3. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    it be better if you post your distro along with cpanel/whm version. If will help people to help you.
     
  4. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    WHM 8.8.0 cPanel 8.8.0-R119
    RedHat Enterprise 3 - WHM X v2.1.2

    Upgradeing/Downgrading cpanel did not help. Reinstalling IMAP did not help.
     
  5. freshstartup

    freshstartup Member

    Joined:
    Jan 26, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Probably too drastic a measure. Did you check your logs?
     
  6. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Move to stable, then restart the services and post results here.
     
  7. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Results:

    imap: [ != ..OK] imap has failed, please contact the sysadmin.
     
  8. freshstartup

    freshstartup Member

    Joined:
    Jan 26, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I don't mean to repeat myself, but I really think checking the logs would be a good idea.

    Try cat /var/log/messages* | grep imap

    Post the most recent results.
     
  9. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Feb 18 17:16:03 server xinetd: xinetd shutdown failed
    Feb 18 17:16:03 server xinetd[19794]: Server in.ntalkd is not executable [file=/etc/xinetd.d/ntalk] [line=9]
    Feb 18 17:16:03 server xinetd[19794]: Error parsing attribute server - DISABLING SERVICE [file=/etc/xinetd.d/ntalk] [line=9]
    Feb 18 17:16:03 server xinetd[19794]: Server in.qpopper is not executable [file=/etc/xinetd.d/pop-3] [line=9]
    Feb 18 17:16:03 server xinetd[19794]: Error parsing attribute server - DISABLING SERVICE [file=/etc/xinetd.d/pop-3] [line=9]
    Feb 18 17:16:03 server xinetd[19794]: Server in.talkd is not executable [file=/etc/xinetd.d/talk] [line=9]
    Feb 18 17:16:03 server xinetd[19794]: Error parsing attribute server - DISABLING SERVICE [file=/etc/xinetd.d/talk] [line=9]
    Feb 18 17:16:03 server xinetd[19794]: Server in.telnetd is not executable [file=/etc/xinetd.d/telnet] [line=9]
    Feb 18 17:16:03 server xinetd[19794]: Error parsing attribute server - DISABLING SERVICE [file=/etc/xinetd.d/telnet] [line=9]
    Feb 18 17:16:03 server xinetd: xinetd startup succeeded
    Feb 18 17:16:03 server xinetd[19794]: xinetd Version 2.3.12 started with libwrap loadavg options compiled in.
    Feb 18 17:16:03 server xinetd[19794]: Started working: 1 available service

    Then i get imap has failed notices every 10 mintues.


    The permissions on those files in /etc/xinetd.d are the same as on the other servers.

    -rw-r--r-- 1 root root 201 Feb 18 17:15 cpimap
    -rw-r--r-- 1 root root 368 Feb 18 17:15 imap
    -rw-r--r-- 1 root root 363 Feb 18 17:15 imaps
    -rw-r--r-- 1 root root 451 Feb 18 17:15 ipop2
    -rw-r--r-- 1 root root 357 Feb 18 17:15 ipop3
    -rw-r--r-- 1 root root 151 Feb 18 17:15 ntalk
    -rw-r--r-- 1 root root 173 Feb 18 17:15 pop-3
    -rw-r--r-- 1 root root 333 Feb 18 17:15 pop3s
    -rw-r--r-- 1 root root 149 Feb 18 17:15 talk
    -rw-r--r-- 1 root root 153 Feb 18 17:15 telnet


    root@server [/etc/xinetd.d]# more telnet
    service telnet
    {
    disable = yes
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = in.telnetd
    }
     
  10. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    have you tried this?:

    pico /etc/xinetd.d/imap
    Change the line server = imapd into
    server = /usr/sbin/imapd
     
  11. freshstartup

    freshstartup Member

    Joined:
    Jan 26, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I don't see anything about imap in those log file lines.. did you grep out imap? I'm only looking for imap related entries.. anything?
     
  12. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    that is what is displayed in messages when restarting imap using WebHost Manager. It doesn't say anything about IMAP.

    cat messages | grep imap is blank.


     
  13. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
     
  14. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    That makes since, but I changed it to:

    # default: off
    # description: The IMAP service allows remote users to access their mail using \
    # an IMAP client such as Mutt, Pine, fetchmail, or Netscape \
    # Communicator.
    service imap
    {
    disable = no
    socket_type = stream
    wait = no
    user = root
    server = /usr/sbin/imapd
    log_on_success += HOST DURATION
    log_on_failure += HOST
    }



    And then tried to restart and got:

    imap: [* BY != ..OK] imap has failed, please contact the sysadmin. Same error in logs.
     
Loading...

Share This Page