SOLVED Error trying to update whm/cpanel

Secmas

Well-Known Member
Feb 18, 2005
364
13
168
Hi!
Hope you can give me a hint about how to fix the following error when trying to update to the latest version 98.0.9, thanks.

The error that I got is:
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (16056) at Wed Oct 6 22:00:53 2021
[2021-10-06 22:00:53 -0600] Detected cron=0 (manual flag passed on command line)
[2021-10-06 22:00:55 -0600] Running Standardized hooks
[2021-10-06 22:00:55 -0600] mtime on upcp is 1614954056 (Fri Mar 5 08:20:56 2021)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow (16070) at Wed Oct 6 22:01:06 2021
[2021-10-06 22:01:06 -0600] Running version '11.96.0.11' of updatenow.
[2021-10-06 22:01:06 -0600] Detected version '11.96.0.11' from version file.
[2021-10-06 22:01:06 -0600] Target version set to '11.98.0.9'
[2021-10-06 22:01:06 -0600] Switching to version 11.98.0.9 of updatenow to determine if we can reach that version without failure.
[2021-10-06 22:01:06 -0600] Retrieving and staging /cpanelsync/11.98.0.9/cpanel/scripts/updatenow.static.bz2
[2021-10-06 22:01:06 -0600] Using mirror '74.50.120.123' for host 'httpupdate.cpanel.net'.
[2021-10-06 22:01:06 -0600] Using mirror '208.74.123.61' for host 'httpupdate.cpanel.net'.
[2021-10-06 22:01:06 -0600] Successfully verified signature for cpanel (key types: release).
[2021-10-06 22:01:06 -0600] Become an updatenow.static for version: 11.98.0.9
=> Log closed Wed Oct 6 22:01:06 2021
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync (16070) at Wed Oct 6 22:01:10 2021
[2021-10-06 22:01:10 -0600] Running version '11.98.0.9' of updatenow.
[2021-10-06 22:01:10 -0600] Detected version '11.96.0.11' from version file.
[2021-10-06 22:01:10 -0600] Target version set to '11.98.0.9'
[2021-10-06 22:01:10 -0600] Checking license
[2021-10-06 22:01:09 -0600] License file check complete
[2021-10-06 22:01:09 -0600] Checking that the RPM DB is OK...
[2021-10-06 22:01:09 -0600] glibc-2.17-324.el7_9.x86_64
[2021-10-06 22:01:09 -0600] OK: RPM DB is responding to queries
[2021-10-06 22:01:09 -0600] Testing if rpm_is_working RPM is installed
[2021-10-06 22:01:09 -0600] package rpm_is_working is not installed
[2021-10-06 22:01:09 -0600] Testing if it's possible to install a simple RPM
[2021-10-06 22:01:10 -0600] Preparing... ########################################
[2021-10-06 22:01:10 -0600] Updating / installing...
[2021-10-06 22:01:10 -0600] rpm_is_working-1.0-0 ########################################
[2021-10-06 22:01:11 -0600] E The install encountered a fatal error: Incorrect file format version in /var/cpanel/rpm.versions.d/local.versions at /usr/local/cpanel/scripts/updatenow.static-cpanelsync line 34932.
=> Log closed Wed Oct 6 22:01:11 2021
[2021-10-06 22:01:11 -0600] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.16056.230227672.1631276976.log` failed, exited with code 1 (signal = 0)

=> Log closed Wed Oct 6 22:01:12 2021
=> Log closed Wed Oct 6 22:01:12 2021


I have ran:
[[email protected] ~]# /usr/local/cpanel/scripts/check_cpanel_rpms -- fix

and it shows:
Incorrect file format version in /var/cpanel/rpm.versions.d/local.versions at /usr/local/cpanel/Cpanel/RPM/Versions/File/YAML.pm line 67.

Thanks,
Sergio
 
Last edited:

Secmas

Well-Known Member
Feb 18, 2005
364
13
168
@cPRex,
thank you, it has been fixed.
After 2 days trying to fix it myself, I had to ask for help at the data center and I don't know what was done but it was corrected.

Sergio