error update cpanel : incompatble version of exim

gtraxx

Member
Nov 30, 2011
12
0
51
cPanel Access Level
Root Administrator
Hello, I followed the recommendations to update the software after a exim mail received from cpanel to a problem with the automatic update.

1. Enter WHM at https://xxxx:2087/
2. Enter the Exim Configuration Editor:
(Service Configuration >> Exim Configuration Editor >> Advanced Configuration Editor)
3. Notate any custom changes you have made in the ACL section.
You may also which to make a copy of /etc/exim.conf.local
and /etc/exim.conf.localopts as it they your custom settings.
4. Click the 'Reset ACL Config to Defaults' button.
5. Reinstall your advanced custom settings.

Here is the error message

Unable to write /etc/exim.conf: Permission denied at /usr/local/cpanel/scripts/buildeximconf line 77.
Progressive Reset failed. This is usually due to an incompatble version of exim being installed.

Current Config Version: 10.160000
New Config Version: 10.170000

I can not change permissions !!!

Best regards
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,606
33
238
somewhere over the rainbow
cPanel Access Level
Root Administrator
It couldn't write to /etc/exim.conf file, likely because the file is either +i or +a on it:

Code:
lsattr /etc/exim.conf
If you see i or a in the return, then do the following:

Code:
chattr -ia /etc/exim.conf
At that point, try to upgrade exim again.