The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error updating cPanel (WHM)

Discussion in 'General Discussion' started by Bogdan Stoica, Mar 16, 2015.

Tags:
  1. Bogdan Stoica

    Bogdan Stoica Member

    Joined:
    Feb 10, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bucharest, Romania, Romania
    cPanel Access Level:
    DataCenter Provider
    I have a VPS which was running cPanel WHM 11.44. I did an upgrade and now it is running 11.46.3 (build 0). However, I got this error:

    Problems were detected with cPanel-provided files which are RPM controlled.
    If you did not make these changes intentionally, you can correct them by running:

    > /usr/local/cpanel/scripts/check_cpanel_rpms --fix

    The following RPMs are missing from your system:
    cpanel-jquery-1.10.2-2.cp1140


    I checked the installed rpm packages and it seems that the package above is allready installed on my system:

    Code:
    root@infomedic [~]# rpm -qa | grep cpanel-jquery
    cpanel-jquery-1.7.2-devel-1.7.2-2.cp1140
    cpanel-jquery-1.7.2-1.7.2-2.cp1140
    cpanel-jquery-ui-1.8.18-1.8.18-3.cp1140
    cpanel-jquery-ui-1.8.18-devel-1.8.18-3.cp1140
    cpanel-jquery-ui-themes-1.8.18-1.8.18-3.cp1140
    cpanel-jquery-1.10.2-2.cp1140
    cpanel-jquery-1.10.2-1.cp1140

    Nevertheless, I am unable to upgrade to a superior cPanel version, even if I use upcp --force. I still get the same error, that I miss that cpanel-jquery-1.10.2-2.cp1140 package.

    Any help would be really appreciated.

    UPDATE: I just ran the suggested fix (/usr/local/cpanel/scripts/check_cpanel_rpms --fix). After a very long wait, I got this:

    Code:
    root@infomedic [~]# /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    [20150316.114150]
    [20150316.114150]   Problems were detected with cPanel-provided files which are RPM controlled.
    [20150316.114150]   If you did not make these changes intentionally, you can correct them by running:
    [20150316.114150]
    [20150316.114150]   > /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    [20150316.114150]   The following RPMs are missing from your system:
    [20150316.114150]   cpanel-jquery-1.10.2-2.cp1140
    [20150316.115643]   Removing 0 broken rpms:
    [20150316.115643]   rpm: no packages given for erase
    [20150316.115645]   Downloading http://httpupdate.cpanel.net/RPM/11.40/centos/5/x86_64/rpm.md5
    [20150316.115645]   cpanel-jquery-1.10.2-2.cp1140.noarch.rpm already downloaded
    [20150316.115646]   Hooks system enabled
    [20150316.115646]   Checking for and running RPM::Versions 'pre' hooks for any RPMs about to be installed
    [20150316.115646]   All required 'pre' hooks have been run
    [20150316.115647]   No RPMS need to be uninstalled
    [20150316.115647]   Installing new rpms: cpanel-jquery-1.10.2-2.cp1140.noarch.rpm
    [20150316.115647]   Preparing packages for installation...
    [20150316.115647]       package cpanel-jquery-1.10.2-2.cp1140.noarch is already installed
    [20150316.115647] W Error Code: 2
    [20150316.115647]   Prelinking shared libraries and binaries: /usr/sbin/prelink -av -mR
    [20150316.115821]   Checking for and running RPM::Versions 'post' hooks for any RPMs just installed
    [20150316.115821]   All required 'post' hooks have been run
     
    #1 Bogdan Stoica, Mar 16, 2015
    Last edited by a moderator: Mar 16, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Please let us know if the following commands address this issue:

    Code:
    rpm -e cpanel-jquery-1.10.2-1.cp1140 cpanel-jquery-1.10.2-2.cp1140
    /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    Thank you.
     
    Bogdan Stoica likes this.
  3. Bogdan Stoica

    Bogdan Stoica Member

    Joined:
    Feb 10, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bucharest, Romania, Romania
    cPanel Access Level:
    DataCenter Provider

    Indeed, it helped. I think everything is fixed. Thank you!


    Code:
    [20150316.155614]
    [20150316.155614]   Problems were detected with cPanel-provided files which are RPM controlled.
    [20150316.155614]   If you did not make these changes intentionally, you can correct them by running:
    [20150316.155614]
    [20150316.155614]   > /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    [20150316.155614]   The following RPMs are missing from your system:
    [20150316.155614]   cpanel-jquery-1.10.2-2.cp1140
    [20150316.161120]   Removing 0 broken rpms:
    [20150316.161120]   rpm: no packages given for erase
    [20150316.161122]   Downloading http://httpupdate.cpanel.net/RPM/11.40/centos/5/x86_64/rpm.md5
    [20150316.161123]   Downloading http://httpupdate.cpanel.net/RPM/11.40/centos/5/x86_64/cpanel-jquery-1.10.2-2.cp1140.noarch.rpm
    [20150316.161124]   Hooks system enabled
    [20150316.161124]   Checking for and running RPM::Versions 'pre' hooks for any RPMs about to be installed
    [20150316.161124]   All required 'pre' hooks have been run
    [20150316.161125]   No RPMS need to be uninstalled
    [20150316.161125]   Installing new rpms: cpanel-jquery-1.10.2-2.cp1140.noarch.rpm
    [20150316.161125]   Preparing packages for installation...
    [20150316.161125]   cpanel-jquery-1.10.2-2.cp1140
    [20150316.161125]   Prelinking shared libraries and binaries: /usr/sbin/prelink -av -mR
    [20150316.161251]   Checking for and running RPM::Versions 'post' hooks for any RPMs just installed
    [20150316.161251]   All required 'post' hooks have been run
     
    #3 Bogdan Stoica, Mar 16, 2015
    Last edited by a moderator: Mar 16, 2015
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page