The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error updating/installing secure certificate "unknown error"

Discussion in 'Security' started by BasicLink SA, Apr 13, 2016.

  1. BasicLink SA

    BasicLink SA Member

    Joined:
    Aug 30, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    I have an existing site that already has a working secure certificate but it will expire in a few weeks. I renewed the certificate using the same key/CSR and received the new certificate.

    I used the root account to access WHM and then selected the account to access it's cPanel interface.

    I uploaded the cert to the SSL manager and can see it in the "SSL Certificates" along with the old but live cert.

    I click "install" and it takes me to the "Manage SSL Hosts" page. I select the domain, the CRT, KEY and CABUNDLE fields are all automatically filled in. I click the "Install Certificate" button and I get this error after a short wait:

    The certificate could not be installed on the domain “<domain.name>”.
    error unknown error

    "<domain.name>" is the domain name of the site that is currently live and working fine.

    This is the server details:
    /etc/redhat-release:CentOS release 6.7 (Final)
    /usr/local/cpanel/version:11.54.0.21
    /var/cpanel/envtype:xen hvm
    CPANEL=release
    Server version: Apache/2.2.31 (Unix)
    Server built: Sep 10 2015 22:23:02
    Cpanel::Easy::Apache v3.32.0 rev9999
    PHP 5.4.45 (cli) (built: Sep 10 2015 22:28:47)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader v4.7.5, Copyright (c) 2002-2014, by ionCube Ltd.
    mysql Ver 14.14 Distrib 5.5.48, for Linux (x86_64) using readline 5.1



    Anyone know why or where I can look for more information? This happened before and I manually installed the cert (think "vi") to make it work. I don't remember the server details though.

    Any help will be appreciated.
    Stephane


    Edit:

    Looks like the new cert was installed, it is live on the site now. In addition the error is actually just "unknown error", I wish I could change the subject.
     
    #1 BasicLink SA, Apr 13, 2016
    Last edited: Apr 13, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you verify if the issue is now resolved? Also, you can review /usr/local/cpanel/logs/error_log to receive additional output about the "unkown error" you noticed in the cPanel interface.

    Thank you.
     
  3. dialhost

    dialhost Registered

    Joined:
    Jun 17, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello everyone,

    We're the same issue here, install_ssl and delete_ssl are not working properly.

    Recently we have launched a Let's Encrypt feature (we built it), the Let's Encrypt generate all the stuff we need and we dispatch it (via UAPI) to cPanel.

    $cpanel->uapi('SSL', 'delete_ssl', ["domain" => $domain]);
    $install_ssl = $cpanel->uapi('SSL', 'install_ssl', $ceritificates);

    As you can see in the log file below, its not working...
    Code:
    [2016-05-13 15:09:02 -0300] warn [cpanel] Cpanel::Wrap::send_cpwrapd_request error: namespace=[Cpanel] module=[ssl] function=[ADD]: statusmsg=[Cpanel::AdminBin::Server: Received invalid syntax from adminbin: Cpanel/ssl/ADD: syntax_ok=[[A warning occurred while processing this directive.]]] at /usr/local/cpanel/Cpanel/Wrap.pm line 123, <$socket> line 1.
            Cpanel::Wrap::send_cpwrapd_request("no_cperror", 1, "function", "ADD", "namespace", "Cpanel", "env", HASH(0x5887e40), "action", ...) called at /usr/local/cpanel/Cpanel/Wrap.pm line 54
            Cpanel::Wrap::send_cpwrapd_request_no_cperror("namespace", "Cpanel", "module", "ssl", "function", "ADD", "data", HASH(0x415beb0), "action", ...) called at /usr/local/cpanel/Cpanel/AdminBin.pm line 252
            Cpanel::AdminBin::_adminfetch("module", "ssl", "function", "ADD", "format", "storable", "cache_check_files", "", "cache", ...) called at /usr/local/cpanel/Cpanel/AdminBin.pm line 178
            Cpanel::AdminBin::fetch_adminbin_nocache_with_status("ssl", undef, "ADD", "storable", HASH(0x415beb0)) called at /usr/local/cpanel/Cpanel/API/SSL.pm line 1808
            Cpanel::API::SSL::_install("sandoces.com.br", "sandoces_com_br_c1183_3da0f_1470935340_fc3817f68642b696bc4c57"..., "c1183_3da0f_0285be4c5a81bca6a32659650270b1e7", undef, Cpanel::Result=HASH(0x5715d28), undef) called at /usr/local/cpanel/Cpanel/API/SSL.pm line 1388
            Cpanel::API::SSL::install_ssl(Cpanel::Args=HASH(0x5730440), Cpanel::Result=HASH(0x5715d28)) called at /usr/local/cpanel/Cpanel/API.pm line 213
            Cpanel::API::__ANON__() called at /usr/local/cpanel/Cpanel/API.pm line 285
            eval {...} called at /usr/local/cpanel/Cpanel/API.pm line 285
            Cpanel::API::_eval_guard(Cpanel::Result=HASH(0x5715d28), CODE(0x5713f50)) called at /usr/local/cpanel/Cpanel/API.pm line 213
            Cpanel::API::_run_module_function(Cpanel::Args=HASH(0x5730440), Cpanel::Result=HASH(0x5715d28), "SSL", "install_ssl") called at /usr/local/cpanel/Cpanel/API.pm line 115
            Cpanel::API::execute("SSL", "install_ssl", HASH(0x572f158)) called at cpanel.pl line 1473
            cpanel::cpanel::docpanelaction("<cpanelaction>\x{a}{\"module\":\"SSL\",\"reqtype\":\"exec\",\"func\":\"insta"...) called at cpanel.pl line 4137
            cpanel::cpanel::dotag_finished_headers(0) called at cpanel.pl line 3927
            cpanel::cpanel::cpanel_parseblock("<cpanelaction>\x{a}{\"module\":\"SSL\",\"reqtype\":\"exec\",\"func\":\"insta"...) called at cpanel.pl line 5197
            cpanel::cpanel::run_standard_mode() called at cpanel.pl line 869
            cpanel::cpanel::script("cpanel::cpanel", "./frontend/dialpanel/index.live.php") called at cpanel.pl line 331
    
    Also, some certs cannot be deleted

    Code:
    
    [2016-05-13 15:08:47 -0300] warn [cpanel] Cpanel::Wrap::send_cpwrapd_request The adminbin “ssl” in the “Cpanel” namespace call to function “DEL” ended prematurely: The subprocess reported error number 5 when it ended.: namespace=[Cpanel] module=[ssl] function=[DEL]: raw_response=[{"statusmsg":"The adminbin “ssl” in the “Cpanel” namespace call to function “DEL” ended prematurely: The subprocess reported error number 5 when it ended.","mode":"full","status":1,"version":"2.4","data":"Você não tem um site ativo para o domínio “sandoces.com.br”.\n","exit_code":1280,"timeout":0,"error":1,"action":"run"}] at /usr/local/cpanel/Cpanel/Wrap.pm line 114, <$socket> line 1.
            Cpanel::Wrap::send_cpwrapd_request("no_cperror", 1, "function", "DEL", "namespace", "Cpanel", "env", HASH(0x5715470), "action", ...) called at /usr/local/cpanel/Cpanel/Wrap.pm line 54
            Cpanel::Wrap::send_cpwrapd_request_no_cperror("namespace", "Cpanel", "module", "ssl", "function", "DEL", "data", "sandoces.com.br", "action", ...) called at /usr/local/cpanel/Cpanel/AdminBin.pm line 85
            Cpanel::AdminBin::run_adminbin_with_status("ssl", "DEL", "hide.com.br") called at /usr/local/cpanel/Cpanel/API/SSL.pm line 1421
            Cpanel::API::SSL::delete_ssl(Cpanel::Args=HASH(0x57155c0), Cpanel::Result=HASH(0x5714050)) called at /usr/local/cpanel/Cpanel/API.pm line 213
            Cpanel::API::__ANON__() called at /usr/local/cpanel/Cpanel/API.pm line 285
            eval {...} called at /usr/local/cpanel/Cpanel/API.pm line 285
            Cpanel::API::_eval_guard(Cpanel::Result=HASH(0x5714050), CODE(0x5715d10)) called at /usr/local/cpanel/Cpanel/API.pm line 213
            Cpanel::API::_run_module_function(Cpanel::Args=HASH(0x57155c0), Cpanel::Result=HASH(0x5714050), "SSL", "delete_ssl") called at /usr/local/cpanel/Cpanel/API.pm line 115
            Cpanel::API::execute("SSL", "delete_ssl", HASH(0x572f290)) called at cpanel.pl line 1473
            cpanel::cpanel::docpanelaction("<cpanelaction>\x{a}{\"module\":\"SSL\",\"reqtype\":\"exec\",\"func\":\"delet"...) called at cpanel.pl line 4137
            cpanel::cpanel::dotag_finished_headers(0) called at cpanel.pl line 3927
            cpanel::cpanel::cpanel_parseblock("<cpanelaction>\x{a}{\"module\":\"SSL\",\"reqtype\":\"exec\",\"func\":\"delet"...) called at cpanel.pl line 5197
            cpanel::cpanel::run_standard_mode() called at cpanel.pl line 869
            cpanel::cpanel::script("cpanel::cpanel", "./frontend/dialpanel/index.live.php") called at cpanel.pl line 331
    [2016-05-13 15:08:47 -0300] warn [cpanel] Cpanel::Wrap::send_cpwrapd_request error: namespace=[Cpanel] module=[ssl] function=[DEL]: statusmsg=[The adminbin “ssl” in the “Cpanel” namespace call to function “DEL” ended prematurely: The subprocess reported error number 5 when it ended.] at /usr/local/cpanel/Cpanel/Wrap.pm line 123, <$socket> line 1.
            Cpanel::Wrap::send_cpwrapd_request("no_cperror", 1, "function", "DEL", "namespace", "Cpanel", "env", HASH(0x5715470), "action", ...) called at /usr/local/cpanel/Cpanel/Wrap.pm line 54
            Cpanel::Wrap::send_cpwrapd_request_no_cperror("namespace", "Cpanel", "module", "ssl", "function", "DEL", "data", "sandoces.com.br", "action", ...) called at /usr/local/cpanel/Cpanel/AdminBin.pm line 85
            Cpanel::AdminBin::run_adminbin_with_status("ssl", "DEL", "hide.com.br") called at /usr/local/cpanel/Cpanel/API/SSL.pm line 1421
            Cpanel::API::SSL::delete_ssl(Cpanel::Args=HASH(0x57155c0), Cpanel::Result=HASH(0x5714050)) called at /usr/local/cpanel/Cpanel/API.pm line 213
            Cpanel::API::__ANON__() called at /usr/local/cpanel/Cpanel/API.pm line 285
            eval {...} called at /usr/local/cpanel/Cpanel/API.pm line 285
            Cpanel::API::_eval_guard(Cpanel::Result=HASH(0x5714050), CODE(0x5715d10)) called at /usr/local/cpanel/Cpanel/API.pm line 213
            Cpanel::API::_run_module_function(Cpanel::Args=HASH(0x57155c0), Cpanel::Result=HASH(0x5714050), "SSL", "delete_ssl") called at /usr/local/cpanel/Cpanel/API.pm line 115
            Cpanel::API::execute("SSL", "delete_ssl", HASH(0x572f290)) called at cpanel.pl line 1473
            cpanel::cpanel::docpanelaction("<cpanelaction>\x{a}{\"module\":\"SSL\",\"reqtype\":\"exec\",\"func\":\"delet"...) called at cpanel.pl line 4137
            cpanel::cpanel::dotag_finished_headers(0) called at cpanel.pl line 3927
            cpanel::cpanel::cpanel_parseblock("<cpanelaction>\x{a}{\"module\":\"SSL\",\"reqtype\":\"exec\",\"func\":\"delet"...) called at cpanel.pl line 5197
            cpanel::cpanel::run_standard_mode() called at cpanel.pl line 869
            cpanel::cpanel::script("cpanel::cpanel", "./frontend/dialpanel/index.live.php") called at cpanel.pl line 331
    
    It happens in all our machines, the one on log file is using

    CLOUDLINUX 5.11 x86_64 standard – br36 WHM 56.0 (build 14)

    And after all this happens, the cert is installed correctly and run well if we try to access the page.

    PS: We are not sending the bundle file, since lets encrypt changed it 3 times already.
     
    #3 dialhost, May 13, 2016
    Last edited by a moderator: May 13, 2016
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Would you mind opening a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. WPC

    WPC Registered

    Joined:
    Dec 4, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ontario
    cPanel Access Level:
    Root Administrator
    We're seeing a similar issue, was this resolved?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you describe the specific issue you are facing, including steps to reproduce the problem?

    Thank you.
     
Loading...

Share This Page