The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[ERROR] Username cannot be longer than -1 characters.

Discussion in 'Database Discussions' started by foz, May 17, 2012.

  1. foz

    foz Registered

    Joined:
    Jun 9, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    When adding a new user for a database it gives the error:

    Username cannot be longer than -1 characters.

    regardless of what you enter. I have checked the mysql > user table and this is set to 16 for length so that isn't the problem.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Silly question, how are you adding the user?

    Assuming via cPanel > Databases > MySQL Databases > Add user

    I just tried to reproduce your issue on EDGE and CURRENT tier servers and could not. Works as expected.
     
  3. foz

    foz Registered

    Joined:
    Jun 9, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Yep that is the way I am trying to add the user.

    As soon as any letter is added into the user field the above error appears
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You're using the cPanel default x3 theme and cPanel is up to date, correct? If yes you might want to open a ticket to cPanel Support to come by for a closer look.
     
  5. foz

    foz Registered

    Joined:
    Jun 9, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Using latest version and x3 theme. Will open a support ticket.
     
Loading...

Share This Page