SOLVED Error using UAPI commandline - PassengerApps list_applications

Operating System & Version
CENTOS 7.9 kvm
cPanel & WHM Version
v94.0.4

Naxtools

Registered
Mar 22, 2021
3
0
1
Brasil
cPanel Access Level
Root Administrator
Hello everyone.

I searched but didn't find anything about it, here on the forum.

We have commandline scripts executed as a cPanel user, who make calls to the API and in the last few days we noticed that STDERR is showing some messages but STDOUT seems to continue with the normal output (before anything was shown in STDERR while in STDOUT returned "errors: ~ ")

Code:
--- STDIN ---
/usr/local/cpanel/bin/uapi PassengerApps list_applications

--- STDOUT ---
apiversion: 3
func: list_applications
module: PassengerApps
result:
  data:
    app_name1:
      base_uri: /
      deployment_mode: production
      deps:
        gem: 0
        npm: cd /home/subdominio/repositories/app_name1 && /opt/cpanel/ea-nodejs10/bin/npm install
        pip: 0
      domain: app_name1.subdominio.com.br
      enabled: 1
      envvars: {}

      name: app_name1
      path: /home/subdominio/repositories/app_name1
  errors: ~
  messages: ~
  metadata: {}

  status: 1
  warnings: ~

--- STDERR ---
warn [Internal Warning while parsing unknown 9505] Could not find bundler based on “/opt/cpanel/ea-ruby24/root/usr/libexec/passenger-ruby24”.
at /usr/local/cpanel/Cpanel/API/PassengerApps.pm line 139.
        Cpanel::API::PassengerApps::_get_dep_info_for_app(HASH(0x21b9f30)) called at /usr/local/cpanel/Cpanel/API/PassengerApps.pm line 178
        Cpanel::API::PassengerApps::list_applications(Cpanel::Args=HASH(0x21a5180), Cpanel::Result=HASH(0x21a4dd8)) called at /usr/local/cpanel/Cpanel/API.pm line 366
        eval {...} called at /usr/local/cpanel/Cpanel/API.pm line 368
        Cpanel::API::_run_module_function(Cpanel::Args=HASH(0x21a5180), Cpanel::Result=HASH(0x21a4dd8), "PassengerApps", "list_applications") called at /usr/local/cpanel/Cpanel/API.pm line 243
        Cpanel::API::execute("PassengerApps", "list_applications", HASH(0x21a4ce8)) called at /usr/local/cpanel/Cpanel/API.pm line 651
        Cpanel::API::run_api_mode(HASH(0x21a4ce8)) called at uapi.pl line 307
        main::script() called at uapi.pl line 139
From what I researched, it seems to me that it will be necessary to install/reinstall the "bundle", but everything I found on the internet about bundle and cPanel talks about having to log in with each user of cPanel to execute the installation command in their own terminal ...

As we never had to do this before and the script always worked, if anyone knows what may have changed and how to resolve to return to normal (so we don't have to improvise with a script for new users), I will be very grateful for any help.
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,984
922
313
cPanel Access Level
Root Administrator
Hey there! I'm not seeing that exact error in any of my internal searches either. Could you open a ticket with our team so we could investigate that directly on the system? If you're able to do that, please post the ticket number here so I can follow along and keep this thread updated.
 

Naxtools

Registered
Mar 22, 2021
3
0
1
Brasil
cPanel Access Level
Root Administrator
Hey there! I'm not seeing that exact error in any of my internal searches either. Could you open a ticket with our team so we could investigate that directly on the system? If you're able to do that, please post the ticket number here so I can follow along and keep this thread updated.
Hi cPRex, I maked it, the ticket number is #94309463.
Thanks to your attention.