cp_noob

Registered
Jul 20, 2019
1
0
1
Oslo
cPanel Access Level
Website Owner
When validating a Google Drive backup location, I get:
Error: Validation for transport “Google Drive Backups” failed: Could not upload test file: api_test failed at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/Net/Google/Drive/Simple.pm line 72​

I have read through most other topics on the forum to no avail:
  • IPV6 is disabled in sysctl.conf: net.ipv6.conf.all.disable_ipv6 = 1
  • Credentials have been generated successfully (no popup-blocker)
  • I have not specified a Folder (which is optional)
  • The compressed backup size is about 1.3 Gbyte, and available Google Drive space is 150 Gbytes
  • I can ping accounts.google.com using SSH from the server
  • The server is running CentOS 6.10 kvm, and WHM/cPanel 78.0.34
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,206
363
cPanel Access Level
DataCenter Provider
Twitter
Could not upload test file: api_test failed at /usr/local/cpanel/3rdparty/perl/528/lib/perl5/cpanel_lib/Net/Google/Drive/Simple.pm line 72
Hello @cp_noob,

Here's a response to one of our support tickets where a similar error was reported:

We've seen this caused by the Queries per 100 seconds per user setting in the quota management area of the Google Drive API settings. It seems that this can be set to a value of '1' when the default is '100'. The maximum value for this setting is '1000'. To change this do the following:

Log in at Google Cloud Platform
Go to Google Drive API
Click on the Quotas link
Change the 'Queries per 100 seconds per user' value
Google has more information about this setting in their documentation here Limits and Quotas on API Requests:

Limits and Quotas on API Requests  |  Analytics Reporting API v4  |  Google Developers
Let me know if this helps.

Thank you.