The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error when adding user to database

Discussion in 'Database Discussions' started by Kramadan, Jul 28, 2015.

  1. Kramadan

    Kramadan Registered

    Joined:
    Jul 28, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    I got this error when I tried to add user to a database
    The user “site” does not have a MySQL database named “site_wordpress”.

    I'm doing this with the normal process
    - from the MySQL Databases I created a new database
    - then I created a new user
    - then under Add a User to a Database I select the new user and the new database and click Add
    - from the next screen I select ALL PRIVILEGES and click on Make Changes
    - Then I got this error
    The user “site” does not have a MySQL database named “site_wordpress”.

    Note: The username is " site_user" not “site” !
     
  2. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    Change this option in Tweak Settings to On
    Code:
    Require a username prefix on names of new databases and database users
    Then do the process again from beginning.
     
  3. Kramadan

    Kramadan Registered

    Joined:
    Jul 28, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    Hi Modserv. thanks for your reply.
    This option is already turned on.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page