Error when creating a new account ..

organik81

Registered
Sep 2, 2005
3
0
151
In WHM panel I get this error message below (when creating a new account)

Code:
WWWAcct 10.1 (c) 1997-2006 cPanel, Inc.

   +===================================+
   | New Account Info                  |
   +===================================+
   | Domain: xxxxx.com
   | Ip: 1.1.1.1 (n)
   | HasCgi: y
   | UserName: xxxxx
   | PassWord: xxxxxxx
   | CpanelMod: x2
   | HomeRoot: /home
   | Quota: 100000 Meg
   | NameServer1: ns1.xxx.com
   | NameServer2: ns2.xxx.com
   | NameServer3: 
   | NameServer4: 
   | Contact Email: 
   +===================================+
Changing password for xxxxx
Password for xxxxx has been changed
Keeping Shell Access (y)
Copying skel files from /root/cpanel3-skel/ to /home/xxxxx/
Using Quota v3 Support
Added Entries to httpd.conf
[B][COLOR="Red"][an error occurred while processing this directive][/COLOR][/B]Account Creation Complete!!!
And there is no account..

I typed the command in SSH below ;

Code:
tail /usr/local/cpanel/logs/error_log -f
and got this :

Code:
(internal warning) Fri Jan  5 10:22:50 2007 [13890] warn: Use of inherited AUTOL                                              OAD for non-method cPScript::StringFunc::shuffle() is deprecated at /scripts/cPS                                              cript/DnsRoots.pm line 96.
 at /scripts/cPScript/DnsRoots.pm line 95
        cPScript::DnsRoots::fetchnameservers('xxxxx.com', 0, 1, 'ARRAY(0x                                              9ee3a84)', 'HASH(0x9ee3a6c)') called at /scripts/cPScript/DnsRoots.pm line 175
        cPScript::DnsRoots::fetchnameservers('xxxxx.com') called at /scri                                              pts/wwwacct line 1023
Can't locate auto/cPScript/StringFunc/shuffle.al in @INC (@INC contains: /script                                              s /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/                                              5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /                                              usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site                                              _perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/l                                              ib/perl5/site_perl . /scripts /scripts /scripts) at /scripts/cPScript/DnsRoots.p                                              m line 95
Any idea pls.. Thanks..
 
Last edited:

alwaysweb

Well-Known Member
Mar 8, 2002
97
0
306
Dallas, TX
cPanel Access Level
Root Administrator
Have you tried the good old:

/scripts/upcp --force

?

If you still have trouble use the "Support Center" link in WHM -> Support to submit your issue to the cpanel techs (better than asking on the forums :) )