SOLVED Error when installing mod_security via WHM >> EA4

Pratyush Rohilla

Registered
Dec 8, 2017
2
0
1
India
cPanel Access Level
Reseller Owner
when i am trying to update mod_security2 via easyapache 4 in whm then i am receiving following errors:

Code:
Update Error:

Error: Package: ea-apache24-mod_security2-2.9.2-9.9.13.cpanel.x86_64 (EA4)
Requires: ea-apr-util(x86-64)
Available: ea-apr-util-1.6.1-1.1.1.cpanel.x86_64 (EA4)
ea-apr-util(x86-64) = 1.6.1-1.1.1.cpanel
Available: ea-apr-util-1.6.1-1.1.2.cpanel.x86_64 (EA4)
ea-apr-util(x86-64) = 1.6.1-1.1.2.cpanel
Available: ea-apr-util-1.6.1-2.2.1.cpanel.x86_64 (EA4)
ea-apr-util(x86-64) = 1.6.1-2.2.1.cpanel
Available: ea-apr-util-1.6.1-4.4.2.cpanel.x86_64 (EA4)
ea-apr-util(x86-64) = 1.6.1-4.4.2.cpanel
Available: ea-apr-util-1.6.1-4.4.3.cpanel.x86_64 (EA4)
ea-apr-util(x86-64) = 1.6.1-4.4.3.cpanel
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2018-09-16_19:31:07-1

anyone can help me out of this?????

also i want to enable mbstring module on PHP that's also not enabling due to above issue...

I need help in this, please, help me.....
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello @Pratyush Rohilla,

It looks like you were able to address this issue through a support ticket. Per the ticket, the solution was to remove duplicate EA4 RPMs using the following command:

Code:
/scripts/find_and_fix_rpm_issues
Thank you.