Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Error when switching to php7.2

Discussion in 'EasyApache' started by AndrewSimm84, Jan 19, 2019.

  1. AndrewSimm84

    AndrewSimm84 Registered

    Joined:
    Jan 19, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Website Owner
    Code:
    (XID 5ysxw2) 1 error occurred:
    Error #1: The system failed to apply the “PHP” version to “XXX”: Cpanel::Exception::FeatureNotEnabled/(XID 4jbcjp) The “ea-php72” package does not expose a version number.
     at /usr/local/cpanel/Cpanel/ProgLang/Supported/php.pm line 321.
        Cpanel::ProgLang::Supported::php::get_package(Cpanel::ProgLang::Supported::php=HASH(0x4076b20), "package", "ea-php72") called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache/Handler/base.pm line 101
        Cpanel::WebServer::Supported::apache::Handler::base::init(Cpanel::WebServer::Supported::apache::Handler::fpm=HASH(0x451eba8), HASH(0x451f868)) called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache/Handler/fpm.pm line 47
        Cpanel::WebServer::Supported::apache::Handler::fpm::new("Cpanel::WebServer::Supported::apache::Handler::fpm", "lang", Cpanel::ProgLang::Supported::php=HASH(0x4076b20), "package", "ea-php72", "webserver", Cpanel::WebServer::Supported::apache=HASH(0x45181b8), "lang_obj", ...) called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache/Handler.pm line 148
        Cpanel::WebServer::Supported::apache::Handler::get_handler(Cpanel::WebServer::Supported::apache::Handler=HASH(0x451eef0), "lang", Cpanel::ProgLang::Supported::php=HASH(0x4076b20), "type", "fpm", "package", "ea-php72") called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache.pm line 234
        Cpanel::WebServer::Supported::apache::make_handler(Cpanel::WebServer::Supported::apache=HASH(0x45181b8), "lang", Cpanel::ProgLang::Supported::php=HASH(0x4076b20), "package", "ea-php72", "type", "fpm") called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache.pm line 901
        Cpanel::WebServer::Supported::apache::set_vhost_lang_package(Cpanel::WebServer::Supported::apache=HASH(0x45181b8), "vhost", "xxx", "lang", Cpanel::ProgLang::Supported::php=HASH(0x4076b20), "package", "ea-php72", "userdata", ...) called at /usr/local/cpanel/Cpanel/WebServer.pm line 440
        Cpanel::WebServer::__ANON__() called at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/Try/Tiny.pm line 99
        eval {...} called at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/Try/Tiny.pm line 90
        Try::Tiny::try(CODE(0x4513e20), Try::Tiny::Catch=REF(0x45140a8)) called at /usr/local/cpanel/Cpanel/WebServer.pm line 455
        Cpanel::WebServer::set_vhost_lang_package(Cpanel::WebServer=HASH(0x4573248), "vhost", "xxx", "user", "xxx", "lang", Cpanel::ProgLang::Supported::php=HASH(0x4076b20), "package", ...) called at /usr/local/cpanel/Cpanel/WebServer.pm line 529
        Cpanel::WebServer::__ANON__() called at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/Try/Tiny.pm line 99
        eval {...} called at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/Try/Tiny.pm line 90
        Try::Tiny::try(CODE(0x45734b8), Try::Tiny::Catch=REF(0x45120d0)) called at /usr/local/cpanel/Cpanel/WebServer.pm line 535
        Cpanel::WebServer::set_vhost_lang_packages(Cpanel::WebServer=HASH(0x4573248), "user", "xxx", "vhosts", ARRAY(0x45733f8), "lang", Cpanel::ProgLang::Supported::php=HASH(0x4076b20), "package", ...) called at /usr/local/cpanel/Cpanel/PHP/Vhosts.pm line 97
        Cpanel::PHP::Vhosts::setup_vhosts_for_php(ARRAY(0x40471b8)) called at /usr/local/cpanel/Whostmgr/API/1/Lang/PHP.pm line 268
        Whostmgr::API::1::Lang::PHP::php_set_vhost_versions(HASH(0x1ecf360), HASH(0x3a2a670), HASH(0x3a56090)) called at whostmgr/bin/xml-api.pl line 3265
        whostmgr::bin::xml_api::__ANON__(HASH(0x3a2a670), HASH(0x1ecf360), HASH(0x3a56090), CODE(0x3a7ed50)) called at /usr/local/cpanel/Whostmgr/API/1/Data/Wrapper.pm line 219
        Whostmgr::API::1::Data::Wrapper::__ANON__() called at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/Try/Tiny.pm line 99
        eval {...} called at /usr/local/cpanel/3rdparty/perl/526/lib64/perl5/cpanel_lib/Try/Tiny.pm line 90
        Try::Tiny::try(CODE(0x400fa20), Try::Tiny::Catch=REF(0x3c3ea10)) called at /usr/local/cpanel/Whostmgr/API/1/Data/Wrapper.pm line 238
        Whostmgr::API::1::Data::Wrapper::execute_internal(CODE(0x3a3bf30), HASH(0x1ecf360), HASH(0x3a56090), HASH(0x3a30ca0), CODE(0x3a7ed50)) called at whostmgr/bin/xml-api.pl line 3429
        whostmgr::bin::xml_api::runapp("php_set_vhost_versions", HASH(0x3a56090), HASH(0x20a2b38), 0, CODE(0x3a7ed50)) called at whostmgr/bin/xml-api.pl line 3182
        whostmgr::bin::xml_api::script(CODE(0x3a7ed50), "-json", "./php_set_vhost_versions") called at whostmgr/bin/xml-api.pl line 3128
    I get this error when trying to switch to php72 in the php manager.
     
    #1 AndrewSimm84, Jan 19, 2019
    Last edited by a moderator: Jan 19, 2019
  2. Eminds

    Eminds Well-Known Member

    Joined:
    Nov 10, 2016
    Messages:
    312
    Likes Received:
    28
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,237
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @AndrewSimm84

    Your profile indicates you're a website owner do you have root access to the server? If not you will need to contact your hosting provider to assist you further with this. Based on the error you're getting I believe the php7.2 package needs to be reinstalled though I wouldn't be able to confirm that unless you've got root.

    If you do can you please run the following via SSH:

    Code:
    /usr/local/cpanel/bin/rebuild_phpconf --current
    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. AndrewSimm84

    AndrewSimm84 Registered

    Joined:
    Jan 19, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Website Owner
    I do have root access to the server. I have already tried reinstalled php 7.2 and while it installs fine I still have the same issues.

    I ran the command you suggested and got the following:
    Code:
    [root@host /]# /usr/local/cpanel/bin/rebuild_phpconf --current
    
    DEFAULT PHP: ea-php71
    
    ea-php71 SAPI: cgi
    
    Cpanel::Exception::MissingParameter/(XID gsq64h) Provide the “type” parameter for the “Cpanel::WebServer::Supported::apache::make_handler” function.
    
     at /usr/local/cpanel/Cpanel/WebServer/Supported/apache.pm line 222.
    
    Cpanel::WebServer::Supported::apache::make_handler(Cpanel::WebServer::Supported::apache=HASH(0x2ddc778), "lang", Cpanel::ProgLang::Supported::php=HASH(0x2d0dfa8), "package", "ea-php72", "type", undef) called at /usr/local/cpanel/bin/rebuild_phpconf line 186
    
    bin::rebuild_phpconf::ea4::do_current(HASH(0x26e7ac0), Cpanel::ProgLang::Supported::php=HASH(0x2d0dfa8), Cpanel::WebServer::Supported::apache=HASH(0x2ddc778)) called at /usr/local/cpanel/bin/rebuild_phpconf line 218
    
    bin::rebuild_phpconf::ea4::run(ARRAY(0x2100990)) called at /usr/local/cpanel/bin/rebuild_phpconf line 395
    
     
  5. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,237
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @AndrewSimm84

    Based on this error it looks like php71 is the issue not php72. Can you try running the following and let me know if it persists?

    Code:
    yum reinstall ea-php71* 
    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. AndrewSimm84

    AndrewSimm84 Registered

    Joined:
    Jan 19, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Website Owner
    I tried running the command you mentioned and I still have the same issue.
     
  7. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,237
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    The output would have been helpful in this circumstance but it may be best we have a closer look. Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice