The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error when trying to rebuild EasyApache with PDO extension

Discussion in 'EasyApache' started by Pseudorandom, Jul 29, 2015.

  1. Pseudorandom

    Pseudorandom Member

    Joined:
    Jul 29, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Las Vegas, Nevada, United States
    cPanel Access Level:
    Root Administrator
    I've been trying to add the PDO extension and get the following error:
    Your OS software management system does not appear to be functioning correctly.

    I do have root access, and an SSH connection so I tried running "yum update" and receive:

    Error: Package: git-1.7.1-3.el6_4.1.x86_64 (base)
    Requires: perl-Git = 1.7.1-3.el6_4.1
    Installed: perl-Git-1.7.1-2.el6_0.1.noarch (@base)
    perl-Git = 1.7.1-2.el6_0.1
    Error: Package: perl-Git-1.7.1-2.el6_0.1.noarch (@base)
    Requires: git = 1.7.1-2.el6_0.1
    Removing: git-1.7.1-2.el6_0.1.x86_64 (@base)
    git = 1.7.1-2.el6_0.1
    Updated By: git-1.7.1-3.el6_4.1.x86_64 (base)
    git = 1.7.1-3.el6_4.1
    You could try using --skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    sendmail-cf-8.14.4-8.el6.noarch has missing requires of sendmail = ('0', '8.14.4', '8.el6')

    at the end. I am rather new and am trying to learn how to trouble shoot these issues but I am not sure what to do next.
     
  2. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    Try this:
    Code:
    /usr/local/cpanel/scripts/check_cpanel_rpms --fix
     
  3. Pseudorandom

    Pseudorandom Member

    Joined:
    Jul 29, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Las Vegas, Nevada, United States
    cPanel Access Level:
    Root Administrator
    I entered that code, it took a bit then gave a new line (acting like it was waiting for a command) without having an response. I tried re-running "yum update" and receive the same error.
     
  4. Pseudorandom

    Pseudorandom Member

    Joined:
    Jul 29, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Las Vegas, Nevada, United States
    cPanel Access Level:
    Root Administrator
    Well after working on my own for a bit, I've manage to clean up the server a bit. I have ran into a new error now and I am again stuck. The new error stopping "yum update" is in the spoiler below (a bit long).

    Error: Multilib version problems found. This often means that the root
    cause is something else and multilib version checking is just
    pointing out that there is a problem. Eg.:

    1. You have an upgrade for bash which is missing some
    dependency that another package requires. Yum is trying to
    solve this by installing an older version of bash of the
    different architecture. If you exclude the bad architecture
    yum will tell you what the root cause is (which package
    requires what). You can try redoing the upgrade with
    --exclude bash.otherarch ... this should give you an error
    message showing the root cause of the problem.

    2. You have multiple architectures of bash installed, but
    yum can only see an upgrade for one of those arcitectures.
    If you don't want/need both architectures anymore then you
    can remove the one with the missing update and everything
    will work.

    3. You have duplicate versions of bash installed already.
    You can use "yum check" to get yum show these errors.

    ...you can also use --setopt=protected_multilib=false to remove
    this checking, however this is almost never the correct thing to
    do as something else is very likely to go wrong (often causing
    much more problems).

    Protected multilib versions: bash-4.1.2-29.el6.x86_64 != bash-4.1.2-15.el6_5.2.i686

    It says right there that I have two versions of bash. I have no idea what bash is, and all I have been able to figure out is that those two versions are 64 and 32 bit respectively. I know my server is 64 bit, so how would I go about disabling or removing the other version safely?
     
  5. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    You can find the rpm using:

    Code:
    rpm -qa | grep bash
    Then to remove the needed one, issue this:

    Code:
    rpm -e PACKAGENAME
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,724
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    In addition to the previous response, you may want to use the "--nodeps" flag when removing the duplicate RPM to avoid removing additional packages. EX:

    Code:
    rpm -e --nodeps package-name
    Thank you.
     
    ModServ likes this.
  7. Pseudorandom

    Pseudorandom Member

    Joined:
    Jul 29, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Las Vegas, Nevada, United States
    cPanel Access Level:
    Root Administrator
    I ran the command "rpm -qa | grep bash" and it showes me two packages "bash-4.1.2-15.el6_5.2.i686" and "bash-4.1.2-15.el6_5.2.x86_64".
    I tried doing "rpm -e --test bash-4.1.2-15.e16_5.2.i686" to see if anything would break when removing the 32bit version of bash and I get an error stating that it is not installed. I tried the same test command on the other file, with the same result.

    So at this point the I feel like the "yum update" is getting an error from two programs that appear to not be installed. How can I check where/if those programs are installed?
     
  8. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    The issue is a typo from your side, I will highlight it for you:

    Package name from command:
    bash-4.1.2-15.el6_5.2.i686

    Package name you wrote:
    bash-4.1.2-15.e16_5.2.i686

    Did you see the difference? it's el6 not e16 (EL6 not E"sixteen")

    EL means: Enterprise Linux
     
    Pseudorandom likes this.
  9. Pseudorandom

    Pseudorandom Member

    Joined:
    Jul 29, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Las Vegas, Nevada, United States
    cPanel Access Level:
    Root Administrator
    Okay, change to be EL instead of E 1 and ran "yum update" which is now updating. Seems to be resolved (update is running right now). Thank you for the help and your patience.
     
  10. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    You welcome, glad to hear that your problem has been fixed :)
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,724
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page