Error when updating File-Copy-Recursive-0.27 via WHM ... ?

WebHostDog

Well-Known Member
Sep 3, 2006
144
1
166
cPanel Access Level
Website Owner
Expect is up to date (1.20).
Running install for module File::Copy::Recursive
Running make for D/DM/DMUEY/File-Copy-Recursive-0.27.tar.gz
CPAN: Digest::SHA loaded ok
CPAN: Module::Signature loaded ok
WARNING: This key is not certified with a trusted signature!
Primary key fingerprint: 2E66 557A B97C 19C7 91AF 8E20 328D A867 450F 89EC
Signature for /home/.cpan/sources/authors/id/D/DM/DMUEY/CHECKSUMS ok
CPAN: Compress::Zlib loaded ok
Checksum for /home/.cpan/sources/authors/id/D/DM/DMUEY/File-Copy-Recursive-0.27.tar.gz ok
Scanning cache /home/.cpan/build for sizes
File-Copy-Recursive-0.27/
File-Copy-Recursive-0.27/._Changes
File-Copy-Recursive-0.27/Changes
File-Copy-Recursive-0.27/._Makefile.PL
File-Copy-Recursive-0.27/Makefile.PL
File-Copy-Recursive-0.27/MANIFEST
File-Copy-Recursive-0.27/META.yml
File-Copy-Recursive-0.27/._README
File-Copy-Recursive-0.27/README
File-Copy-Recursive-0.27/._Recursive.pm
File-Copy-Recursive-0.27/Recursive.pm
File-Copy-Recursive-0.27/t/
File-Copy-Recursive-0.27/t/1.t
Removing previously used /home/.cpan/build/File-Copy-Recursive-0.27
Package came without SIGNATURE


CPAN.pm: Going to build D/DM/DMUEY/File-Copy-Recursive-0.27.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for File::Copy::Recursive
CPAN: YAML loaded ok
cp ._Recursive.pm blib/lib/File/Copy/._Recursive.pm
cp Recursive.pm blib/lib/File/Copy/Recursive.pm
Manifying blib/man3/File::Copy::Recursive.3
/usr/bin/perl "-Iblib/arch" "-Iblib/lib" ._Makefile.PL ._Makefile
Unrecognized character \x05 at ._Makefile.PL line 1.
make: *** [._Makefile] Error 255
/usr/bin/make -- NOT OK
Running make install
make had returned bad status, install seems impossible

File::Scan::ClamAV is up to date (1.8).


What is wrong and is it a way to be fixed ?
This is Release version 119 of CPanel.



Thanks.
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
Looks like it is a bug in that perl module release on cpan. If you need that perl module, you'll probably need to download an older one from cpan and install it manually to see if that works.
 

Spiral

BANNED
Jun 24, 2005
2,020
8
193
Regaring "File::Copy::Recursive" ...

Actually that module is now included by default in the new Perl 5.8.8
so CPAN doesn't like to build it seperately by itself anymore.

Speaking of Perl 5.8.8, anyone upgrade to that one yet?
 

WebHostDog

Well-Known Member
Sep 3, 2006
144
1
166
cPanel Access Level
Website Owner
No I am still using Perl 5.8.7
Chirpy how to install old one Perl module ?



Thanks.