The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error while installing Cpanel

Discussion in 'General Discussion' started by abhijeet9135, Sep 22, 2007.

  1. abhijeet9135

    abhijeet9135 Registered

    Joined:
    Sep 19, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Nashik
    Hello,

    I am getting the following error message while I install Cpanel on my VPS.

    Error Message :
    Please help me installing Cpanel.

    Thank You,
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    glibc package is missing. Install it using yum and start the cPanel installation. To install glibc, execute:

    yum install glibc

    If you receive any further errors, paste them here.
     
  3. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    How does one install yum itself on a cpanel vps?

    Code:
    rpm -Uvh yum-3.0.5-1.el5.centos.2.noarch.rpm                                               
    warning: yum-3.0.5-1.el5.centos.2.noarch.rpm: V3 DSA signature: NOKEY, key ID e8562897
    error: Failed dependencies:
            python >= 2.4 is needed by yum-3.0.5-1.el5.centos.2.noarch
            python(abi) = 2.4 is needed by yum-3.0.5-1.el5.centos.2.noarch
            python-elementtree is needed by yum-3.0.5-1.el5.centos.2.noarch
            python-sqlite is needed by yum-3.0.5-1.el5.centos.2.noarch
            rpm >= 0:4.4.2 is needed by yum-3.0.5-1.el5.centos.2.noarch
            urlgrabber is needed by yum-3.0.5-1.el5.centos.2.noarch

    Code:
    ls -lh
    total 7.5M
    -rw-r--r--  1 root root 5.9M Sep 29 15:35 python-2.4.3-19.el5.i386.rpm
    -rw-r--r--  1 root root  84K Sep 29 15:33 python-elementtree-1.2.6-5.i386.rpm
    -rw-r--r--  1 root root  39K Sep 29 15:33 python-sqlite-1.1.7-1.2.1.i386.rpm
    -rw-r--r--  1 root root 127K Sep 29 15:33 python-urlgrabber-3.1.0-2.noarch.rpm
    -rw-r--r--  1 root root 638K Sep 29 15:36 rpm-4.4.2-37.el5.i386.rpm
    -rw-r--r--  1 root root 214K Sep 29 15:33 sqlite-3.3.6-2.i386.rpm
    -rw-r--r--  1 root root 482K Sep 29 15:33 yum-3.0.5-1.el5.centos.2.noarch.rpm
    Code:
    rpm -Uvh *rpm
    warning: python-2.4.3-19.el5.i386.rpm: V3 DSA signature: NOKEY, key ID e8562897
    error: Failed dependencies:
            libc.so.6(GLIBC_2.4) is needed by python-2.4.3-19.el5.i386
            libcrypto.so.6 is needed by python-2.4.3-19.el5.i386
            libdb-4.3.so is needed by python-2.4.3-19.el5.i386
            libreadline.so.5 is needed by python-2.4.3-19.el5.i386
            libssl.so.6 is needed by python-2.4.3-19.el5.i386
            rtld(GNU_HASH) is needed by python-2.4.3-19.el5.i386
            python = 2.3.4-14.2 is needed by python-devel-2.3.4-14.2.i386
            libc.so.6(GLIBC_2.4) is needed by python-elementtree-1.2.6-5.i386
            rtld(GNU_HASH) is needed by python-elementtree-1.2.6-5.i386
            libc.so.6(GLIBC_2.4) is needed by python-sqlite-1.1.7-1.2.1.i386
            rtld(GNU_HASH) is needed by python-sqlite-1.1.7-1.2.1.i386
            m2crypto >= 0.16-5 is needed by python-urlgrabber-3.1.0-2.noarch
            beecrypt >= 4.1.2 is needed by rpm-4.4.2-37.el5.i386
            libc.so.6(GLIBC_2.4) is needed by rpm-4.4.2-37.el5.i386
            librpm-4.4.so is needed by rpm-4.4.2-37.el5.i386
            librpmbuild-4.4.so is needed by rpm-4.4.2-37.el5.i386
            librpmdb-4.4.so is needed by rpm-4.4.2-37.el5.i386
            librpmio-4.4.so is needed by rpm-4.4.2-37.el5.i386
            popt = 1.10.2 is needed by rpm-4.4.2-37.el5.i386
            rtld(GNU_HASH) is needed by rpm-4.4.2-37.el5.i386
            libc.so.6(GLIBC_2.4) is needed by sqlite-3.3.6-2.i386
            libreadline.so.5 is needed by sqlite-3.3.6-2.i386
            rtld(GNU_HASH) is needed by sqlite-3.3.6-2.i386
            python = 2.3.4-14.2 is needed by (installed) python-devel-2.3.4-14.2.i386
            /usr/lib/python2.3 is needed by (installed) libxml2-python-2.6.16-6.i386
            rpm = 4.3.3-18_nonptl is needed by (installed) rpm-python-4.3.3-18_nonptl.i386
            rpm = 4.3.3-18_nonptl is needed by (installed) rpm-devel-4.3.3-18_nonptl.i386
            rpm = 4.3.3-18_nonptl is needed by (installed) rpm-build-4.3.3-18_nonptl.i386

    I have centos 5
     
  4. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    Most glibc issues aren't that it isn't installed, but that yum isn't working properly, if yum errors out, you will receive the errors referring to glibc.

    Run 'yum info glibc' and see if yum errors out, most of the time this happens when resolver or yum config is corrupt.


    Below is a script to install yum on a 64bit box, this may help you get yum installed, however, be sure to use the rpms for your specific architecture, as the rpms in this scripts are for 64bit.

    Code:
    #!/bin/bash
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/libxml2-2.6.16-10.x86_64.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/libxml2-python-2.6.16-10.x86_64.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/python-elementtree-1.2.6-5.el4.centos.x86_64.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/sqlite-3.3.6-2.x86_64.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/python-sqlite-1.1.7-1.2.1.x86_64.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/rpm-4.3.3-22_nonptl.x86_64.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/rpm-python-4.3.3-22_nonptl.x86_64.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/python-urlgrabber-2.9.8-2.noarch.rpm
    rpm -Uvh ftp://ftp.icm.edu.pl/vol/rzm1/linux-kde-redhat/centos/4.4/os/x86_64/CentOS/RPMS/centos-yumconf-4-4.5.noarch.rpm
    rpm -Uvh http://mirror.centos.org/centos/4/os/x86_64/CentOS/RPMS/yum-2.4.3-3.el4.centos.noarch.rpm
    
     
Loading...

Share This Page