Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Error while installing tomcat 7

Discussion in 'EasyApache' started by TakeThat, Sep 2, 2014.

  1. TakeThat

    TakeThat Registered

    Joined:
    Sep 2, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hello!

    I'm trying to install Tomcat 7 with EasyApache and always getting next error:
    Code:
    !! RPM install/uninstall failed:
    [20140903.010536] 
    
    [20140903.010536] Problems were detected with cPanel-provided files which are RPM controlled.
    [20140903.010536] If you did not make these changes intentionally, you can correct them by running:
    [20140903.010536]
    [20140903.010536] > /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    [20140903.010536] The following RPMs are missing from your system:
    [20140903.010536] easy-basesystem-1.0.0-1
    [20140903.010536] easy-jakarta-commons-daemon-1.0.15-1
    [20140903.010536] easy-jakarta-commons-daemon-javadoc-1.0.15-1
    [20140903.010536] easy-jakarta-commons-daemon-jsvc-1.0.15-1
    [20140903.010536] easy-mysql-connector-java-5.1.25-1
    [20140903.010536] easy-tomcat7-7.0.42-2
    [20140903.010536] easy-tomcat7-admin-webapps-7.0.42-2
    [20140903.010536] easy-tomcat7-docs-webapp-7.0.42-2
    [20140903.010536] easy-tomcat7-el-2.2-api-7.0.42-2
    [20140903.010536] easy-tomcat7-javadoc-7.0.42-2
    [20140903.010536] easy-tomcat7-jsp-2.2-api-7.0.42-2
    [20140903.010536] easy-tomcat7-lib-7.0.42-2
    [20140903.010536] easy-tomcat7-servlet-3.0-api-7.0.42-2
    [20140903.010536] easy-tomcat7-webapps-7.0.42-2
    [20140903.010536] Removing 0 broken rpms:
    [20140903.010536] rpm: no packages given for erase
    [20140903.010537] Downloading [url]http://httpupdate.cpanel.net/RPM/easyapache/cloudlinux/6/x86_64/rpm.md5[/url]
    [20140903.010538] easy-tomcat7-jsp-2.2-api-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-tomcat7-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-tomcat7-lib-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-tomcat7-javadoc-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-jakarta-commons-daemon-jsvc-1.0.15-1.x86_64.rpm already downloaded
    [20140903.010538] easy-basesystem-1.0.0-1.noarch.rpm already downloaded
    [20140903.010538] easy-jakarta-commons-daemon-1.0.15-1.x86_64.rpm already downloaded
    [20140903.010538] easy-mysql-connector-java-5.1.25-1.noarch.rpm already downloaded
    [20140903.010538] easy-tomcat7-servlet-3.0-api-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-jakarta-commons-daemon-javadoc-1.0.15-1.x86_64.rpm already downloaded
    [20140903.010538] easy-tomcat7-admin-webapps-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-tomcat7-webapps-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-tomcat7-el-2.2-api-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] easy-tomcat7-docs-webapp-7.0.42-2.noarch.rpm already downloaded
    [20140903.010538] Hooks system enabled
    [20140903.010538] Checking for and running RPM::Versions 'pre' hooks for any RPMs about to be installed
    [20140903.010538] All required 'pre' hooks have been run
    [20140903.010538] No RPMS need to be uninstalled
    [20140903.010538] Installing new rpms: easy-tomcat7-jsp-2.2-api-7.0.42-2.noarch.rpm easy-tomcat7-7.0.42-2.noarch.rpm easy-tomcat7-lib-7.0.42-2.noarch.rpm easy-tomcat7-javadoc-7.0.42-2.noarch.rpm easy-jakarta-commons-daemon-jsvc-1.0.15-1.x86_64.rpm easy-basesystem-1.0.0-1.noarch.rpm easy-jakarta-commons-daemon-1.0.15-1.x86_64.rpm easy-mysql-connector-java-5.1.25-1.noarch.rpm easy-tomcat7-servlet-3.0-api-7.0.42-2.noarch.rpm easy-jakarta-commons-daemon-javadoc-1.0.15-1.x86_64.rpm easy-tomcat7-admin-webapps-7.0.42-2.noarch.rpm easy-tomcat7-webapps-7.0.42-2.noarch.rpm easy-tomcat7-el-2.2-api-7.0.42-2.noarch.rpm easy-tomcat7-docs-webapp-7.0.42-2.noarch.rpm
    [20140903.010538] error: Failed dependencies:
    [20140903.010538] jakarta-commons-logging is needed by easy-tomcat7-0:7.0.42-2.noarch
    [20140903.010538] jakarta-commons-collections is needed by easy-tomcat7-0:7.0.42-2.noarch
    [20140903.010538] jakarta-commons-dbcp is needed by easy-tomcat7-0:7.0.42-2.noarch
    [20140903.010538] jakarta-commons-pool is needed by easy-tomcat7-0:7.0.42-2.noarch
    [20140903.010538] java-1.7.0-openjdk-devel is needed by easy-tomcat7-0:7.0.42-2.noarch
    [20140903.010538] log4j is needed by easy-tomcat7-0:7.0.42-2.noarch
    [20140903.010538] ecj >= 4.2.1 is needed by easy-tomcat7-lib-0:7.0.42-2.noarch
    [20140903.010538] jakarta-commons-collections is needed by easy-tomcat7-lib-0:7.0.42-2.noarch
    [20140903.010538] jakarta-commons-dbcp is needed by easy-tomcat7-lib-0:7.0.42-2.noarch
    [20140903.010538] jakarta-commons-pool is needed by easy-tomcat7-lib-0:7.0.42-2.noarch
    [20140903.010538] jpackage-utils is needed by easy-tomcat7-javadoc-0:7.0.42-2.noarch
    [20140903.010538] java-1.7.0-openjdk >= 1:1.7.0 is needed by easy-jakarta-commons-daemon-1.0.15-1.x86_64
    [20140903.010538] java-1.7.0-openjdk >= 1.7.0 is needed by easy-mysql-connector-java-5.1.25-1.noarch
    [20140903.010538] jakarta-taglibs-standard >= 0:1.1 is needed by easy-tomcat7-webapps-0:7.0.42-2.noarch
    [20140903.010538] W Error Code: 14
    [20140903.010538] E The following possible errors were detected while installing RPMs:
    [20140903.010538] E Failed dependencies
    [20140903.010538] The Administrator will be notified to review this output when this script completes
    [20140903.010538] Checking for and running RPM::Versions 'post' hooks for any RPMs just installed
    [20140903.010538] All required 'post' hooks have been run !!
    Any solution to fix this?
     
  2. ScottTh

    ScottTh Well-Known Member

    Joined:
    Jan 28, 2013
    Messages:
    157
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hi TakeThat,

    Did you manually install any other version of Tomcat before attempting to build Tomcat 7 with EasyApache?

    What was the outcome of running /usr/local/cpanel/scripts/check_cpanel_rpms --fix ?

    Thank you for the information.
     
  3. TakeThat

    TakeThat Registered

    Joined:
    Sep 2, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi, cpScottT.

    No. I didn't try install any of other versions manually.

    When i run ../check_cpanel_fprms --fix i was got almost the same error, which was publicated in first message.
     
  4. ScottTh

    ScottTh Well-Known Member

    Joined:
    Jan 28, 2013
    Messages:
    157
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I believe the quickest solution at this point would be to contact our technical support staff and open a ticket.

    Please post the ticket ID in this thread so we can follow it and learn why you were having difficulties with Tomcat 7.

    Thank you.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice