Error while running /scripts/quotacheck

Losmi

Member
Feb 14, 2017
7
0
1
Fiji
cPanel Access Level
Root Administrator
This is the error that is showing when i run /scripts/quotacheck command:

Use of uninitialized value in substitution (s///) at /scripts/quotacheck line 283.

Piece of code on that line is: $d->[0] =~ s{/}{}g;
Any help, question or suggestion is is welcome.
Thank you.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston

Losmi

Member
Feb 14, 2017
7
0
1
Fiji
cPanel Access Level
Root Administrator
HI,

Thank you for your answer.

Platform that i running is dedicated server HP ProLiant DL360p Gen8 with CLOUDLINUX 7.6 and WHM & cPanel version 78.0.24.

Same environment is running on the different server, where mentioned command /scripts/quotacheck is working without smoothly.

Kind Regards.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
Hi @Losmi

As far as logs is anything noted in the cPanel error log, or messages when you run quotacheck? You can find these logs files in the following locations:

Code:
/usr/local/cpanel/logs/error_log
Code:
/var/log/messages
Are quotas enabled on the system? To test this you might run something like:
Code:
repquota -a
Can you also provide the output of the following:

Code:
cat /etc/fstab
 

Losmi

Member
Feb 14, 2017
7
0
1
Fiji
cPanel Access Level
Root Administrator
HI,

Thank you for your answer.

Regarding the logs "/usr/local/cpanel/logs/error_log" and "/var/log/messages" , i do not get any output messages when I run the script.
Also, i have checked few more log files, and situation is the same.

On the other hand, when i run repquota -a, in section "used" i get values which do not match real values of used space in user accounts.
upload_2019-5-24_12-44-12.png

As far as "fstab" file is concerned, things get little confused for me.

Current configuration of fstab file is:
upload_2019-5-24_14-1-35.png

but, when i run /scripts/fixquotas, value "usrjquota=quota.user,jqfmt=vfsv0" for /dev/sdb1 changes to "defaults".

And that's where i also need your help :-D
 

Attachments

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
Hi @Losmi

The documentation here may be helpful: How to Fix Quotas - cPanel Knowledge Base - cPanel Documentation

Also, if you run the following first instead of fixquotas does it resolve the situation?

Code:
/scripts/initquotas
The fstab file looks good so I wouldn't want to see that changed, but there are some things to take into account with CloudLinux 7 that the documentation touches on.
 

Losmi

Member
Feb 14, 2017
7
0
1
Fiji
cPanel Access Level
Root Administrator
Hi,

When i run /scripts/initquotas value "usrjquota=quota.user,jqfmt=vfsv0" for /dev/sdb1 again changes to "defaults".

Here is the output after executing script:

upload_2019-5-27_16-27-20.png

Kind Regrads.
 

Losmi

Member
Feb 14, 2017
7
0
1
Fiji
cPanel Access Level
Root Administrator
Hi,

I have almost the same environment on different server, and there everything works just fine.

Script /scripts/quotacheck is executing without mentioned error, and when i run repquota -a, i get proper value of used space:

upload_2019-5-30_15-49-11.png

Also backup is generating in /home directory /home/backup-inc.

Here is the configuration of fstab file on the other server:

upload_2019-5-30_15-54-7.png
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
You can see on /home it's set to defaults though - quotas are not enabled on that system.
But to look further into what the differences are and why the error is only occurring on one server we'd need access to investigate. Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!