Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Error while updating to 11.66.0.15

Discussion in 'General Discussion' started by benito, Aug 29, 2017.

Tags:
  1. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    304
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    Hello, since several days i got these update failed emails. Munin is working fine, what means with "MySQL-server is needed by cpanel-perl-524-munin-2.0.30-1.cp1162.x86_64" ?

    Thanks

    The system detected an error during the cPanel & WHM version change from “11.64.0.36” to “11.66.0.15”, which prevented the updatenow process from completing normally.


    Review the attached log for further details.
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-HTML-Formatter-2.16-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-Template-Toolkit-2.26-7.cp1162.x86_64.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-TermReadKey-2.37-1.cp1162.x86_64.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-MCE-1.820-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-libwww-perl-6.24-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-Catalyst-Runtime-5.90114-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-Test-Mock-Cmd-0.7-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-Dist-Zilla-Plugin-GitHub-0.43-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-Params-Validate-1.26-1.cp1162.x86_64.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-Gearman-v2.3.1-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] cpanel-perl-524-List-AllUtils-0.14-1.cp1162.noarch.rpm already downloaded
    [2017-08-29 00:40:58 -0300] All files Staged
    [2017-08-29 00:40:58 -0300] Testing if the newly downloaded RPMS can be installed without conflict
    [2017-08-29 00:40:58 -0300] Testing RPM transaction
    [2017-08-29 00:41:00 -0300] error: Failed dependencies:
    [2017-08-29 00:41:00 -0300] MySQL-server is needed by cpanel-perl-524-munin-2.0.30-1.cp1162.x86_64
    [2017-08-29 00:41:00 -0300] W Exit Code: 176
    [2017-08-29 00:41:00 -0300] ***** FATAL: Test install failed: error: Failed dependencies:
    [2017-08-29 00:41:00 -0300] MySQL-server is needed by cpanel-perl-524-munin-2.0.30-1.cp1162.x86_64
    [2017-08-29 00:41:00 -0300] The Administrator will be notified to review this output when this script completes
    [2017-08-29 00:41:00 -0300] ***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:
    [2017-08-29 00:41:00 -0300] MySQL-server is needed by cpanel-perl-524-munin-2.0.30-1.cp1162.x86_64
    [2017-08-29 00:41:00 -0300] see RPM Installation Failures - cPanel Knowledge Base - cPanel Documentation for more information
    [2017-08-29 00:41:00 -0300] The Administrator will be notified to review this output when this script completes
    => Log closed Tue Aug 29 00:41:00 2017​
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you verify if CloudLinux and MySQL Governor are installed on this server?

    Thank you.
     
  3. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    304
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    Hello Michael, yes, we have cloudlinux. Governor is installed but not active as far i can see.

    [root@alfonsina ~]# tail /var/log/dbgovernor-restrict.log

    [root@alfonsina ~]# cat /var/log/dbgovernor-restrict.log

    [root@alfonsina ~]# dbtop

    Can't connect to socket. Maybe governor is not started

    [root@alfonsina ~]#

    Thanks
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Can you remove MySQL Governor and let us know if the issue persists? Documentation on how to remove it is available from CloudLinux at:

    MySQL Governor > Removing MySQL Governor

    Note the documented script will install the original MySQL server, and remove MYSQL Governor.

    Thank you.
     
  5. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    304
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    Hi!

    I run the script and the first thing tries to do is to update cPanel and then stops at the same error.

    First part:

    Code:
    [root@alfonsina ~]# /usr/share/lve/dbgovernor/mysqlgovernor.py --delete
    Loaded plugins: fastestmirror, rhnplugin
    This system is receiving updates from CLN.
    Cleaning of cl-MySQL packages completed
    Loaded plugins: fastestmirror, rhnplugin
    This system is receiving updates from CLN.
    Cleaning of Percona-Server packages completed
    Loaded plugins: fastestmirror, rhnplugin
    This system is receiving updates from CLN.
    Cleaning of cl-Percona packages completed
    
    Stopping mysql (via systemctl):                            [  OK  ]
    Redirecting to /bin/systemctl stop  restart.service
    Failed to stop restart.service: Unit restart.service not loaded.
    [2017-08-30 11:15:59 -0300]   Detected cron=0 (--force passed on command line)
    ----------------------------------------------------------------------------------------------------
    => Log opened from cPanel Update (upcp) - Slave (2849) at Wed Aug 30 11:15:59 2017
    [2017-08-30 11:15:59 -0300]   Detected cron=0 (--force passed on command line)
    [2017-08-30 11:15:59 -0300]   1% complete
    [2017-08-30 11:15:59 -0300]   Running /usr/local/cpanel/scripts/preupcp
    [2017-08-30 11:15:59 -0300]   Running Standardized hooks
    [2017-08-30 11:16:00 -0300]   2% complete
    [2017-08-30 11:16:00 -0300]   mtime on upcp is 1491968323 (Wed Apr 12 00:38:43 2017)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow (2855) at Wed Aug 30 11:16:01 2017
    [2017-08-30 11:16:01 -0300]   Detected version '11.64.0.36' from version file.
    [2017-08-30 11:16:01 -0300]   Running version '11.64.0.36' of updatenow.
    [2017-08-30 11:16:01 -0300]   --force passed on command line. Upgrade will disregard update config settings.
    [2017-08-30 11:16:01 -0300]   Retrieved public key from vendor: cpanel, category: development, url: https://securedownloads.cpanel.net/cPanelDevelopmentKey.asc
    [2017-08-30 11:16:02 -0300]   Retrieved public key from vendor: cpanel, category: release, url: https://securedownloads.cpanel.net/cPanelPublicKey.asc
    [2017-08-30 11:16:02 -0300]   Target version set to '11.66.0.15'
    [2017-08-30 11:16:02 -0300]   Switching to 11.66.0.15 to determine if we can reach that version without failure.
    [2017-08-30 11:16:02 -0300]   Retrieving and staging /cpanelsync/11.66.0.15/cpanel/scripts/updatenow.static.bz2
    [2017-08-30 11:16:02 -0300]   Using mirror '185.53.12.144' for host 'httpupdate.cpanel.net'.
    Last part:

    Code:
    [2017-08-30 11:18:43 -0300]   cpanel-perl-524-Email-MIME-1.940-1.cp1162.noarch.rpm already downloaded
    [2017-08-30 11:18:43 -0300]   All files Staged
    [2017-08-30 11:18:43 -0300]   Testing if the newly downloaded RPMS can be installed without conflict
    [2017-08-30 11:18:43 -0300]   Testing RPM transaction
    [2017-08-30 11:18:45 -0300]   error: Failed dependencies:
    [2017-08-30 11:18:45 -0300]     MySQL-server is needed by cpanel-perl-524-munin-2.0.30-1.cp1162.x86_64
    [2017-08-30 11:18:45 -0300] W Exit Code: 178
    [2017-08-30 11:18:45 -0300] ***** FATAL: Test install failed: error: Failed dependencies:
    [2017-08-30 11:18:45 -0300]     MySQL-server is needed by cpanel-perl-524-munin-2.0.30-1.cp1162.x86_64
    [2017-08-30 11:18:45 -0300]   The Administrator will be notified to review this output when this script completes
    [2017-08-30 11:18:45 -0300] ***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:
    [2017-08-30 11:18:45 -0300]     MySQL-server is needed by cpanel-perl-524-munin-2.0.30-1.cp1162.x86_64
    [2017-08-30 11:18:45 -0300]   see https://go.cpanel.net/rpmcheckfailed for more information
    [2017-08-30 11:18:45 -0300]   The Administrator will be notified to review this output when this script completes
    => Log closed Wed Aug 30 11:18:45 2017
    [2017-08-30 11:18:45 -0300]   17% complete
    [2017-08-30 11:18:45 -0300] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1504102559.log --force` failed, exited with code 1 (signal = 0)
    => Log closed Wed Aug 30 11:18:45 2017
    => Log closed Wed Aug 30 11:18:45 2017
    warning: /etc/container/mysql-governor.xml saved as /etc/container/mysql-governor.xml.rpmsave
    [root@alfonsina ~]# 
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look?

    Thank you.
     
  7. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    304
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Mar del Plata - Argentina
    Thanks Michael, the ticket # is 8828527
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, this was fixed by installing the missing MariaDB RPM on the system:

    Code:
    yum install MariaDB-server
    Thank you.
     
Loading...

Share This Page