Error while upgrading account via API

pqpier

Active Member
Aug 12, 2022
26
1
3
Brazil
cPanel Access Level
Root Administrator
While trying to modify package of an account via cpanel API:

I'm getting the following error:
Sorry you may not create any more accounts with the package XXX.

I tried checking maximum privileges to API Token but that didn't solve the issue.

I also edited all my packages to 999,999 mb of bandwith limit cause I saw somewhore that going beyond that could cause this error.

Still the error persists.

Any idea why is that happening?
 

cPanelWilliam

Administrator
Staff member
Mar 13, 2018
161
23
93
Houston
cPanel Access Level
Root Administrator
Hi! Do you have "Limit accounts that $reseller can create by Resource Usage." option checked for the reseller account? You can check this in WHM > Edit Reseller Nameservers and Privileges. If this option is enabled, disk space and bandwidth limits can prevent packages from being modified if it would cause those limits to be exceeded. You could either choose to disable this option or temporarily allow overselling so you can modify the package (these can both be done via the WHM > Edit Reseller Nameservers and Privileges interface).