The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error with BIND 9.3.1

Discussion in 'Bind / DNS / Nameserver Issues' started by bnn121, Apr 13, 2005.

  1. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Would anybody be able to tell me why I get this error after trying to restart bind? I looked in server stauts and noticed that the bind is a red ball...so I deicded to restart it...well as you can see...I get that error above...any idea?
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    named.root holds the information on root name servers needed to
    initialize cache of Internet domain name servers. You need to recreate that file.

    Are you using FreeBSD?
     
  3. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Thank You for your reply...Yes I am running FreeBSD 5.3-Release

    Forgive me as I'm just switching over from a Fedora Core2 OS to this FreeBSD box...so I have not researched how to recreate this file...I was hoping that Cpanel had a way of doing it...so I did not have to ssh to root...
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
  5. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    We just installed a new FREEBSD box 5.3 over the weekend and it was borked from the get go....We ended up manually installing bind from hand. From your error, your rc.conf file is looking for bind at;

    /etc/namedb/named.conf

    But its no longer there;

    Seems to have installed it in /var/named/etc/namedb

    You need to edit your rc.conf file to the path of your named.conf

    named_flags="-u bind -c /etc/namedb/named.conf" <<path to named.conf

    As Andy said, make sure the named.root is is the proper directory.

    What we ended up doing is moving bind from /var back to /etc/named and also found our named.conf file was corrupted upon the new install..Once we copied in a new named.conf...all was good.
     
    #5 easyhoster1, Apr 14, 2005
    Last edited: Apr 14, 2005
  6. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I do appreaite the help...and will try to figure this all out...where can I get a new named.conf file to replace the one I have...knowing its probably corupt.
     
  7. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Also...I'm trying to do a locate to find out where files are located...when I run locate filename I get this return

    locate: database too small: /var/db/locate.database


    any way to fix that?
     
  8. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I did a find named.root and it did not find the file. so I looked in the path that the erros says it suppoese to be and all I see are these

    host# find named.root
    find: named.root: No such file or directory
    host# cd var
    host# ls
    .snap crash heimdal named tmp
    account cron lib preserve yp
    at db log run
    backups empty mail rwho
    cpanel games msgs spool
    host# cd named
    host# ls
    dev etc named.ca var
    host# pwd
    /var/named


    The only thinng there is the named.ca

    Not sure where else or how else to find it. I have changed my rc.conf to look at the correct location for named.conf and will restart bind to see if it worked...

    if it does not work...I am hoping somebody can help me install it manually and make the corrections amde in the post above me.
     
  9. autumnwalker

    autumnwalker Member

    Joined:
    Jan 5, 2005
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    if your having probs like i did with bsd and bind do this:






    cd /usr/ports/dns/bind9
    make install clean


    fixes it :)
     
  10. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    That did not help...I tried to re-install and I beleive all went well with the install...but not sure how to tell if there was a problem...even after a clean install I still get this error with bind

    named has failed, please contact the sysadmin (result was "named is not running"). Apr 15 09:00:10 host named[27817]: starting BIND 9.3.1 -u bind -c /var/named/etc/namedb/named.config Apr 15 09:00:10 host named[27817]: none:0: open: /var/named/etc/namedb/named.config: file not found Apr 15 09:00:10 host named[27817]: loading configuration: file not found Apr 15 09:00:10 host named[27817]: exiting (due to fatal error)
     
  11. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    You have the named file name in your path wrong;

    you have named.config

    should be

    named.conf
     
  12. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    You just confused me to no end :confused:

    could you explain that a little better for me...I'm not that versed with these settings...so pease be gental.

     
  13. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Configuration files, use .conf not config

    in your rc.conf file change it to


    named_flags="-u bind -c /var/named/etc/namedb/named.conf

    Then restart Bind and see if it starts up
     
  14. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    that did not help either...I get this error now

    named has failed, please contact the sysadmin (result was "named is not running"). Apr 16 02:36:41 host named[1775]: starting BIND 9.3.1 -u bind -c /var/named/etc/namedb/named.cong Apr 16 02:36:41 host named[1775]: none:0: open: /var/named/etc/namedb/named.cong: file not found Apr 16 02:36:41 host named[1775]: loading configuration: file not found Apr 16 02:36:41 host named[1775]: exiting (due to fatal error)

    I guess this will never work

    My host said he would take a look at it...but has not and I dont think he will either...
     
  15. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    You still miss spelled it;

    named.conf

    not named.cong

    Take a closer look at your error... It tells you what is wrong...If the file is not found, you need to find it, or make sure it exist. In this case, you have a typo in the rc.conf file.

    Fix your typo and try again.
     
    #15 easyhoster1, Apr 15, 2005
    Last edited: Apr 15, 2005
  16. bnn121

    bnn121 Member

    Joined:
    Jan 11, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I've been so frustrated with getting this to work I completely overlooked the typo. I corrected it and it appears to be working now.

    Thanks for yours and the other who helped patients.

    I'm sure I'll be back with something else...untill I get this server back up and running correctly.
     
Loading...

Share This Page