error with spamassassin and perl

jcorreia

Well-Known Member
Apr 25, 2005
53
0
156
Hi,
today I´ve done

Code:
spamassassin --lint
and the following error messages appeared

Code:
Subroutine IO::Socket::INET6::sockaddr_in6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 65.
 at /usr/lib/perl5/site_perl/5.8.8/IO/Socket/INET6.pm line 21
I´ve restart exim, and everything looks ok, but I dont like this errors and I´m afraid something might be broked.

I´ve updated perl packages with
Code:
/scripts/checkperlmodules --full --force
but the error remains.
My WHM version is 11.30.5 (build 6), and the easy answer to solve this is to upgrade to the last, but I dont want yet, because of the changes in exim..


How can I fix this ?
Thanks