The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"error_log" always set off mode

Discussion in 'General Discussion' started by greenworld, Dec 15, 2011.

  1. greenworld

    greenworld Registered

    Joined:
    Dec 14, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi,
    When i cpanel update or apache server recompiled(easy apache) the php values like "error_log" will be ON . But we want how to set always OFF mode. How solve this issue?

    Thanks,
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you let us know an example of the changes you are making? Please include which files you are editing, and the specific changes you are making to these files.

    Thank you.
     
  3. greenworld

    greenworld Registered

    Joined:
    Dec 14, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi,

    Thank you for your quick reply,
    When i cpanel update or apache server recompiled(easy apache) the php values like "error_log" will be ON . But we want how to set always OFF mode. How to solve this issue?

    The file path Name : /usr/local/lib/php.ini

    Thank you,
     
  4. laks

    laks Member

    Joined:
    Dec 14, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    Any one can solve this issue ,

    Thank you,
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's possible you have an option enabled in EasyApache that is updating this value in your php.ini file. Could you open a support ticket so we may take a closer look at this issue?

    Submit A Ticket

    Thank you.
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Do you mean that this is set to On when recompiling Apache using EasyApache?

    Code:
    log_errors = On
    Because error_log itself is normally set to a value like the path such as this:

    Code:
    error_log = error_log
    It is "log_errors =" that would be set to "Off" value rather than the error_log line.

    Of note, I changed "log_errors = On" to "log_errors = Off" in my /usr/local/lib/php.ini file, then I ran "/scripts/easyapache" and it didn't change that value to On again.
     
Loading...

Share This Page