Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

error_log massive size

Discussion in 'EasyApache' started by kwmlr439, Feb 12, 2016.

  1. kwmlr439

    kwmlr439 Member

    Joined:
    Aug 24, 2013
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Website Owner
    I am getting massive errors on my error log:

    [12-Feb-2016 12:14:38 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20121212/apc.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20121212/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0

    I logged in using terminal and went to: nano /usr/local/lib/php.ini and edited the ini file with every solution I read about and couldn't get it to stop. Any ideas how to get started on solving these errors? They are filling in my error log quickly!!!

    Thanks again
     
  2. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    567
    Likes Received:
    40
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    Are you receiving these error messages on a specific account, or for all accounts? You should check to ensure an account is not using a custom php.ini file.
     
    kwmlr439 likes this.
  3. kwmlr439

    kwmlr439 Member

    Joined:
    Aug 24, 2013
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Website Owner
    There is only one domain name!
     
  4. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    567
    Likes Received:
    40
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    You should check to ensure an account is not using a custom php.ini file.

    find /home/USERName/public_html -name php.ini

    Also, check the apc is installed and enable.
     
  5. ElviCities

    ElviCities Member

    Joined:
    Aug 9, 2012
    Messages:
    19
    Likes Received:
    6
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Twitter:
    Also, not to be Mr. Obvious - once you make changes to the php.ini file - you should restart apache for the change to take effect.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Yes, as mentioned, review the account's home directory to see if you are using a custom php.ini file. If so, disable that file to ensure the account uses the system's php.ini file (customization is not required if you only host one account).

    Thank you.
     
Loading...

Share This Page