The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ErrorDocument in htaccess error

Discussion in 'General Discussion' started by nimonogi, Mar 11, 2011.

  1. nimonogi

    nimonogi Member

    Joined:
    Mar 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I'm getting the following error in every account that have ErrorDocument declared in .htaccess

    Title: 500 Internal Server Error
    --------------------
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster [at] domain [dot] com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    -----------------------

    When i comment out ErrorDocument from .htaccess the websites are working fine.

    Any thoughts on what misconfiguration causing this error server-wide?

    Thanks in advance.
     
  2. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hey.

    How you have declared that in .htaccess and also paste the result of grep user /usr/local/apache/logs/error_log here to have a further check on it.
     
  3. nimonogi

    nimonogi Member

    Joined:
    Mar 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Ex. ErrorDocument 404 /404.shtml

    Is this caused by mod_security?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    It would appear to be caused by mod_security from what it is stating. You would want to check the /usr/local/apache/conf/modsec2.user.conf file for line 41 to check for matches.
     
  5. nimonogi

    nimonogi Member

    Joined:
    Mar 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    This was probably due to misconfiguration of mod_security.
    Invalid command 'SecFilterEngine', perhaps misspelled or defined by a module not included in the server configuration.
     
  6. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hey!

    You can always disable the particular rule for the domain !
     
Loading...

Share This Page