The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Errors after update to WHM 11.24

Discussion in 'General Discussion' started by pjpsoft, Dec 23, 2008.

  1. pjpsoft

    pjpsoft Member

    Joined:
    Oct 4, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I have installed a new server with Centos 5.2 x86_64
    everything was working fine

    I then updated to version : cPanel 11.24.4-R32603 - WHM 11.24.2 - X 3.9

    Now I have two problems
    as each reboot, the computer recompile something
    it looks like it is glib then freefont and again
    perhaps it is related to something else but I can't find what

    I have read a thread about something like that and then updated to last fix but doesn't change

    second problem, I receive an email titled
    [checkperlmodules] The perl module Tie::Watch could not be installed.

    This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install attempt:

    Test Run
    ==============
    Can't locate Tie/Watch.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at - line 1.
    BEGIN failed--compilation aborted at - line 1.
    ...
    long email with error at the end

    gcc-64bit-hack: enabled
    /usr/bin/ld: skipping incompatible /usr/lib/libX11.so when searching for -lX11
    /usr/bin/ld: cannot find -lX11
    collect2: ld returned 1 exit status
    make: *** [blib/arch/auto/Tk/Tk.so] Error 1
    SREZIC/Tk-804.028.tar.gz
    /usr/bin/make OTHERLDFLAGS=-L/usr/lib64 LDFLAGS=-L/usr/lib64 EXTRALIBDIR=/usr/lib64 OTHERLDFLAGS=-L/usr/lib64 LDFLAGS=-L/usr/lib64 EXTRALIBDIR=/usr/lib64 -- NOT OK


    CPAN: YAML loaded ok (v0.68)
    Running make install
    Make had returned bad status, install seems impossible
    perlmod--Install done


    any help appreciated
    pierre
     
  2. -jdk-

    -jdk- Well-Known Member

    Joined:
    Aug 28, 2005
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Use the search tool. There is already a couple threads regarding this with answers.
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Please try installing a 64bit version of libX11 with yum and then run /scripts/upcp --force
     
  4. pjpsoft

    pjpsoft Member

    Joined:
    Oct 4, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    For everybody searching on this problem:
    I have submitted a ticket and got a fast answer that resolved everything

    Your upgrade is complete, I noticed the error in your first reply about X11, and I remembered about a recent ticket I did where it was missing libX11-devel.x86_64

    So I went ahead and installed that with;

    yum -y install libX11-devel.x86_64

    And upcp then worked fine :)

    CPanel is great and support staff is even better!
     
Loading...

Share This Page