The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Errors Attempting to do a System Update

Discussion in 'General Discussion' started by adelgado7, Sep 30, 2014.

  1. adelgado7

    adelgado7 Registered

    Joined:
    Sep 30, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    So... it's time to update again.

    Log in to WHM
    Scroll down to Update System Software.

    it's all running fine and dandy until I get to the end and this shows up:

    Code:
    mod_python-3.2.8-4.el5.i386 from base has depsolving problems
      --> Missing Dependency: httpd >= 2.0.40 is needed by package mod_python-3.2.8-4.el5.i386 (base)
    mod_python-3.2.8-4.el5.i386 from base has depsolving problems
      --> Missing Dependency: httpd-mmn = 20051115 is needed by package mod_python-3.2.8-4.el5.i386 (base)
    --> Running transaction check
    ---> Package kernel-devel.i686 0:2.6.18-308.20.1.el5 set to be erased
    ---> Package mod_python.i386 0:3.2.8-4.el5 set to be updated
    --> Processing Dependency: httpd-mmn = 20051115 for package: mod_python
    --> Processing Dependency: httpd >= 2.0.40 for package: mod_python
    --> Finished Dependency Resolution
    mod_python-3.2.8-4.el5.i386 from base has depsolving problems
      --> Missing Dependency: httpd >= 2.0.40 is needed by package mod_python-3.2.8-4.el5.i386 (base)
    mod_python-3.2.8-4.el5.i386 from base has depsolving problems
      --> Missing Dependency: httpd-mmn = 20051115 is needed by package mod_python-3.2.8-4.el5.i386 (base)
    Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_python-3.2.8-4.el5.i386 (base)
    Error: Missing Dependency: httpd >= 2.0.40 is needed by package mod_python-3.2.8-4.el5.i386 (base)
     You could try using --skip-broken to work around the problem
     You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    checkyum version 21.1
    
    Anybody have any ideas on how to fix it?

    Thanks MUCHO!
     
    #1 adelgado7, Sep 30, 2014
    Last edited by a moderator: Oct 1, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's likely mod_python was installed during your OS installation as a dependency of the "httpd" package. However, cPanel removes the "httpd" RPM during the cPanel installation because that package is managed by EasyApache. Thus, mod_python is not a required package. You can keep the RPM and hide it from the RPM database with a command such as:

    Code:
    rpm -e --nodeps --justdb mod_python-3.2.8-4
    Thank you.
     
  3. adelgado7

    adelgado7 Registered

    Joined:
    Sep 30, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for the starting point!

    I actually did a rpm -q mod_python to find what was installed, then did a

    rpm -e --nodeps --justdb mod_python-3.2.8-3.1

    I am now able to "Update System Software"

    Thank you for your help!!
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page