Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Errors from WordPress plug-ins

Discussion in 'General Discussion' started by Thunderchild, Feb 27, 2018.

Tags:
  1. Thunderchild

    Thunderchild Well-Known Member

    Joined:
    Jan 28, 2018
    Messages:
    61
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I am getting various errors from WordPress plug-ins. These normally take the following forms:


    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 3072 bytes) in /home/simonelec/public_html/wp-admin/custom-header.php on line 55

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 49152 bytes) in /home/simonelec/public_html/wp-admin/includes/plugin.php on line 900

    can anybody tell me what sort of problem I have here? This was trying to install woo commerce which worked fine on my previous shared hosting server account. The only real changes I have made to my default setup of cPanel server is that I am running Apache 4 as recommended and I am using maria database rather than the older MySQL whose end-of-life is imminent. Could either of these because the problems above? Obviously I can't revert the database change at least according to my web host manager and I believe it is best to have the latest Apache.

    I have a couple of other accounts on my server where we have had issues with plug-ins that have prevented us from moving WordPress based websites. Is there any hope for us?
     
  2. Tearabite

    Tearabite Well-Known Member

    Joined:
    Nov 28, 2010
    Messages:
    76
    Likes Received:
    11
    Trophy Points:
    58
    Location:
    Southern California
    cPanel Access Level:
    Root Administrator
    looks like a max_memory type issue which is easily adjustable in php.ini or in the cPanel custom PHP ini interface. on mobile now will try to get more info later if someone else doesnt step in
     
  3. Thunderchild

    Thunderchild Well-Known Member

    Joined:
    Jan 28, 2018
    Messages:
    61
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I see, where in the file do I find this setting?
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. flyingscot

    flyingscot Registered

    Joined:
    May 2, 2018
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Saint George, Utah
    cPanel Access Level:
    Root Administrator

    Did you ever solve this? I was getting the same error as well as HTTP 500 errors when sites were loading. I had tried changing the memory_limit in wpconfig with no luck and in php.ini via SSH. Again no luck. This moring, on my 4th cup of coffee, I logged into whm and searched PHP. Clicked MultiPHP INI Editor and then Configure basic settings of a PHP version. In the dropdown were my two PHP versions. ea-php56 and ea-php72. I had upgraded my centos 72 server to php v7.2 a while ago. I scrolled down the settings to find the default memory_limit was set to 32mb. YIKES! I changed it to 256mb as I have 4gb of ram on that Atlantic server. Solved my problems. So much for trying all of the "expert" solutions prior to that stupid simple fix.
     
    cPanelMichael likes this.
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @flyingscot,

    I'm glad to see you were able to solve the issue on your system. Thank you for sharing the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice