PivotalCrossroads

Registered
Mar 17, 2021
2
0
1
Central Florida
cPanel Access Level
Root Administrator
Brand new cPanel install. Moved over a couple of test sites from previous server.
Installed Imunify360 & CSF. Otherwise, touched very little.

CentOS 8 / cPanel

During cPanel setup, found that EasyApache didn't work. Can select all the modules but says nothing to provision at the end.
Then found this error when trying to update:

---------------------------------------------------------------------------------------------------------------------------------------------------
System update process has started.

“yum” reported error code “1” when it ended: w/ yum -y
Last metadata expiration check: 0:06:12 ago on Wed Mar 17 04:15:15 2021.
<span class='text-danger'>Error: </span>
Problem: cannot install the best update candidate for package ea-apr-util-1.6.1-8.8.16.cpanel.x86_64
- nothing provides ea-openssl11 >= 1:1.1.1d-1 needed by ea-apr-util-1:1.6.1-7.el8.cloudlinux.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Often errors like this can be resolved by running `yum makecache`

System update process has finished.
------------------------------------------------------------------------------------------------------------------------------------------------------

Can anyone help me? This has me completely stalled.

Thanks.
 

PivotalCrossroads

Registered
Mar 17, 2021
2
0
1
Central Florida
cPanel Access Level
Root Administrator
Thank you for the reply. I'm still having this problem.
This was the result.

Last metadata expiration check: 0:00:57 ago on Thu 25 Mar 2021 01:36:39 AM EDT.
Error:
Problem: cannot install the best update candidate for package ea-apr-util-1.6.1-8.8.16.cpanel.x86_64
- nothing provides ea-openssl11 >= 1:1.1.1d-1 needed by ea-apr-util-1:1.6.1-7.el8.cloudlinux.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Hey there! Can you try running this command on the system to see if that will perform the update?

Code:
dnf -y update
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,781
591
273
cPanel Access Level
Root Administrator
Thanks for the additional details. I did some more research on this and found the issue is related to a problem with the Imunify360 packages. If your license for Imunify360 was purchased through cPanel, please open a ticket with us so we can check that directly and see if there is a problem with the software.