Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Errors with cPanel/apache & wordpress

Discussion in 'EasyApache' started by StarbuckII, Mar 22, 2012.

  1. StarbuckII

    StarbuckII Member

    Joined:
    Nov 13, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    51
    Some of my users are getting the following errors when attempting to upload plugins to their wordpress sites.
    Everything I have found indicates that this is an issue with cPanel/Apache settings.

    Here is the error that is generated.

    Fatal Error: Allowed memory size of XXXX bytes exhausted. (tried to allocate XXXX bytes in /home/XXXX/public_html/wp-includes/class-simplepie.php line 5410

    This is very frustrating as what I see presented elsewhere involves hacking each installation. Clearly I don't want to do that, nor do I want users doing it.

    Everything I have found points to issues with Apache settings but I can't find where I would change them globally for all users. I am hoping that somebody knows how to do this & can point me in the right direction.
     
  2. LeadDogGraphics

    LeadDogGraphics Well-Known Member

    Joined:
    Feb 25, 2012
    Messages:
    97
    Likes Received:
    1
    Trophy Points:
    58
    Location:
    West Palm Beach, FL
    cPanel Access Level:
    Root Administrator
    Change it in WHM > Service Configuration > PHP Configuration Editor

    The setting you are looking for is called 'memory_limit'

    Increase this setting, for wordpress it should be no less than 64MB or you will get that error constantly. I have mine set at 128 and never see that error even with a few graphic plugins that use a lot of memory when run.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. StarbuckII

    StarbuckII Member

    Joined:
    Nov 13, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    51
    Thanks that fixed it.



     
  4. leytdg1

    leytdg1 Registered

    Joined:
    Apr 15, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Website Owner
    Hi there,

    I am having exactly the same problem, but I don't understand how to apply the solution posted above.

    How do I get to:
    WHM > Service Configuration > PHP Configuration Editor

    within my cpanel?

    Thank you.

    Deven.
     
  5. Oleg.Gricik

    Oleg.Gricik Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    56
    cPanel Access Level:
    Root Administrator
    Within WHM, but sometimes you need to increase memory_limit option in your main php.ini file.
    Also, you can make a local copy (for certain user)
    in order to propagate this php.ini file for whole account you need to add the following string in .htaccess file (works for SuPHP+SuExec, DSO doesn't work)
    SetEnv PHPRC /home/username/public_html/php.ini

    Where /home/username/public_html/php.ini is your local PHP.ini file.
    Modified .htaccess file should be located in root or under public_html (I prefer in public_html)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice