Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

escaped characters in cpanel redirect...

Discussion in 'General Discussion' started by 4u123, Apr 8, 2009.

  1. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    788
    Likes Received:
    6
    Trophy Points:
    168
    Customer complained that they added a redirect and it doesnt work so I tested it and he is correct.

    cpanel added the following to the htaccess file...

    When visiting the domain in a browser it just sits there forever.

    So I changed the rule to...

    ...and it works perfectly

    The escaped characters seem to be causing the problem somehow?
     
  2. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    68
    Location:
    sanctum sanctorum
    Because it is
    RewriteCondition <TestString> <Pattern>
    RewriteRule <Pattern> <SubstitutionString>

    i.e. first argument to Condition and second argument to Rule are not patterns.

    :)
     
  3. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    788
    Likes Received:
    6
    Trophy Points:
    168
    So what does that mean in english?
     
  4. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    788
    Likes Received:
    6
    Trophy Points:
    168
    Had another customer complain today - same problem. The rewrite rules put in automatically by the cpanel "redirect" function definately do not work.

    Isnt this problem happening for anyone else?
     
Loading...

Share This Page