The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/etc/init.d/chkservd stop - no longer works?

Discussion in 'General Discussion' started by Hoss, Dec 17, 2008.

  1. Hoss

    Hoss Active Member

    Joined:
    Oct 15, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    And for the life of me I cannot figure out how to start and stop the new chkservd configuration?
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Code:
    /scripts/restartsrv_tailwatchd
    should do it
     
  3. Hoss

    Hoss Active Member

    Joined:
    Oct 15, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Nick, but a further question then. There are times I do need to shut down chkservd and start it again later.
    So how is this now accomplished?

    I just got the 11.24 update. And wow there are a few new settings and a few issues I need to attend to there. :)
    May have a few more ?'s before this is all over.
    But let's deal with this one for now :D
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    killall -TERM tailwatchd

    should take care of taking it down

    or

    /usr/local/cpanel/etc/init/stoptailwatchd
     
  5. Hoss

    Hoss Active Member

    Joined:
    Oct 15, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the quick reply!
    I got this error message when I shut it down via /usr/local/cpanel/etc/init/stoptailwatchd...

    I can always take a look later. But since your around, any ideas?
    Oops, bet I know. I have to change a few things in order for the exim 5.700000 update to take place.

    But seems I'm always getting Eximstats errors
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Please see the following thread for discussion and resolution for that message:

    http://forums.cpanel.net/showthread.php?t=101477&goto=newpost
     
  7. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    Stopping tailwatchd will result in everything it does being turned off.

    To just disable only chkservd and let everything else run as it should:

    Disable the Chkservd tailwatchd driver (IE "shut down chkservd") and then enable (IE "start it again") it later when you want it back.

    /usr/local/cpanel/bin/tailwatchd --disable=Cpanel::TailWatch::ChkServd
    /usr/local/cpanel/bin/tailwatchd --enable=Cpanel::TailWatch::ChkServd

    See:
    /usr/local/cpanel/bin/tailwatchd --help
    for more information.
     
    #7 cPDan, Dec 18, 2008
    Last edited: Dec 18, 2008
  8. Hoss

    Hoss Active Member

    Joined:
    Oct 15, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Thank you guyz. Just what I was looking for!
     
Loading...

Share This Page