The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/etc/init.d/exim: pipe error: Too many open files in system

Discussion in 'Security' started by NetX, Apr 11, 2005.

  1. NetX

    NetX Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    I cannot send out mails from my server, I have tried stop/restart/reinstall exim.
    stop/restart/update/restart cpanel but nothinh works.

    All domains can receive mails but suddenly they cannot send out mails.

    I tries too changing exim port to 26, but the problem is not fixed.

    I'm receiving athis message:

    /etc/init.d/exim: pipe error: Too many open files in system


    Do you have any ide about the solution for this problem?

    Thanks for your help.
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    You need to consult the documentation of your OS to understand how to increase these limits. I would suggest you also run a search on google as well. As you haven't provided your OS in your post, there's very little I can do to help further at this point.
     
  3. Kerstin

    Kerstin Well-Known Member

    Joined:
    Apr 9, 2005
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Berlin
    Probably a hardware error ,
    pipe error ;) , defect memory , processor or
    mathematics unit ;) (MPU) occuring
    algorythmic ;) saving problems in the hash-table :eek:
    of the system memory :p .
     
  4. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    This is most likely a file descriptor issue. do you have teh fork bomb protection turned on?
     
  5. Kerstin

    Kerstin Well-Known Member

    Joined:
    Apr 9, 2005
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Berlin
    The numbers of the open files can be setted in the boot files of the OS.
    linux -> init.d

    Othervise to many open files occuring a stack overflow error in the
    system memory :p

    Apparently it only a explorer error (borwser cacher settings) or
    a port error caused by the port setup ;) in your explorer.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Kerstin,

    Please stay on topic and provide an answer if you are trying to help. If are not positive of the answer, or you do not know the answer or cannot help, then posting something irrelevant is not helping anyone.
     
Loading...

Share This Page