The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/etc/localdomains

Discussion in 'General Discussion' started by Nico, Apr 16, 2002.

  1. Nico

    Nico Well-Known Member

    Joined:
    Dec 5, 2001
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Edmond, OK
    We have a client using Bigmaibox.com for email.
    the problem is in order for the form results to be delivered to the correct email address the domain needs to be commented out of /etc/localdomains and for some reason Cpanel will add another entry for the domain making the form results be delivered to the local inbox.
    Is there a way to prevent this?
     
  2. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    If you want to lock /etc/localdomains use #chattr +i /etc/localdomains
     
  3. Nico

    Nico Well-Known Member

    Joined:
    Dec 5, 2001
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Edmond, OK
    [quote:d9212956ff][i:d9212956ff]Originally posted by DaveDark[/i:d9212956ff]

    If you want to lock /etc/localdomains use #chattr +i /etc/localdomains[/quote:d9212956ff]


    Will that keep new domains from being wriiten to the file afterwards? If so, will that create any problems?
     
  4. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    I guess that way would be lose lose since you would have to manually change the file. N'mind that one.
     
  5. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    [quote:863f0e40d9][i:863f0e40d9]Originally posted by Nico[/i:863f0e40d9]

    We have a client using Bigmaibox.com for email.
    the problem is in order for the form results to be delivered to the correct email address the domain needs to be commented out of /etc/localdomains and for some reason Cpanel will add another entry for the domain making the form results be delivered to the local inbox.
    Is there a way to prevent this?[/quote:863f0e40d9]

    Is this a bug of cpanel?
     
  6. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Yea it is actually--
    Seems that somebody mentioned this mechanism before, is there a flag somewhere or cpanel user profile modification that you can put in to prevent a local domain from being added back into /etc/localdomains?


    This information would be good to know- if this is posted elsewhere please let myself as well as the others know about it.

    Thanks!

    ;)
     
  7. snowgod

    snowgod Well-Known Member

    Joined:
    Sep 23, 2001
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    I summited a patch for this some time ago. Nick already has it in bugzilla.

    See http://web.cpanel.net/bugzilla/show_bug.cgi?id=228

    I submitted a patch that creates a /etc/remotemx file which is a list of domains to exclude from /etc/localdomains

    Just to clearify: Nick has not patched this into cpanel yet.
     
  8. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Thank you very, very, very much
    have a great night snow-person
    :p
     
Loading...

Share This Page