The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/etc/mailips IP keeps disappearing

Discussion in 'E-mail Discussions' started by glenwheeler, May 21, 2015.

  1. glenwheeler

    glenwheeler Member

    Joined:
    May 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,

    I am having a very strange issue with my dedicated server. Just over a year ago now I had an attack on my dedicated server which had killed and IP I was using to send email. I then changed that IP so I had something clean.

    I'm having a very strange issue where I add my IP to /etc/mailips via SSH. I then save it and then do an service exim restart. All works fine for the whole day. Until the next day when it drops out, I start getting mail errors because the IP doesnt exist.

    Does anyone at all know why this would be happening. At the moment every single day I have to SSH to the server enter /etc/mailips and then add the IP back in. Its becoming a real pain and wondered if anyone else have had this issue?

    Any help would be fantastic, the problem has gone on way too long :(

    Thanks,
    Glen
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you have the "Send mail from account's dedicated IP address" option enabled in WHM's "Exim Configuration Manager" interface? If so, cPanel will automatically overwrite the /etc/mailips file. This is explained in the following document, along with instructions on how to configure the outgoing IP address:

    How to Configure Exim's Outgoing IP Address

    Thank you.
     
  3. glenwheeler

    glenwheeler Member

    Joined:
    May 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    No, this is set to "off" at the moment
     
  4. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    And that is the reason you are facing this issues with the /etc/mailips file. Please enable "Send mail from account's dedicated IP address" option enabled in WHM's "Exim Configuration on your server.
     
    LostNerd likes this.
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can see what's overwriting that file. It should not be overwritten if you have the referenced option disabled. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  6. psfrog

    psfrog Member

    Joined:
    Jul 13, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sweden
    cPanel Access Level:
    Root Administrator

    Hello!

    Please try this command:
    [Removed - setting /etc/mailips to immutable can result in several problems, including failed account creation attempts]

    Then the file will not be overwritten.

    If You want to edit the file later just do this before you edit it:
    [Removed - setting /etc/mailips to immutable can result in several problems, including failed account creation attempts]
     
    #6 psfrog, May 22, 2015
    Last edited by a moderator: Nov 18, 2016
  7. glenwheeler

    glenwheeler Member

    Joined:
    May 10, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,

    Thanks for all of the feedback. I have now put these in place and will monitor it over this week.

    Thanks,
    Glen
     
Loading...

Share This Page