The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/etc/namedb/rndc.conf missing in FreeBSD 4.9R

Discussion in 'General Discussion' started by PbG, Jul 18, 2004.

  1. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Whenever I modify a DNS zone in WHM I get the following error:

    Fatal, neither ndc or rndc was found on this server (ns.domain.com)

    I believe the error is caused by the fact that the following files are missing:

    /etc/namedb/rndc.conf
    /etc/namedb/rndc.conf.sample

    Note: /scripts/fixndc does not correct this issue. Any suggestions are appreciated.
     
  2. Ben-Orbital

    Ben-Orbital Member
    PartnerNOC

    Joined:
    Oct 6, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    I am also having the same problem :(
     
  3. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    The techs fixed it they said named was not starting. What exactly they did above and beyond restarting ndc I do not know. However after the nightly CP update, the problem got worse and there was a bind update in that cp update. Now I get the following error:

    rndc: connection to remote host closed This may indicate that the remote server is using an older version of the command protocol, this host is not authorized to connect, or the key is invalid.

    I suspect the cp update is the problem. I could be wrong tho since our other FreeBSD box did not suffer the same error. We will confirm/deny this theory.

     
    #3 PbG, Jul 20, 2004
    Last edited: Jul 20, 2004
  4. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    same thing!!!!

    What is going on. Please help someone. I can't get any of my freebsd box to work. All bind are down?? what is going on. even on a brand new box of installed. BIND is not starting!!!
     
Loading...

Share This Page