/etc/rrdtooldisable is exists, but rrd files are still genereated

sodapopinski

Well-Known Member
Aug 13, 2001
90
2
308
I created an empty file /etc/rrdtooldisable, deleted all /var/cpanel/bandwidth/*.rrd files and restart cpanel service. But within few minutes alot of rrd files are generated again by the system. Is there anyway to disable the system generate .rrd files into /var/cpanel/bandwidth dir?

Thanks alot in advance.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,606
33
238
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello,

I've opened case 73185 regarding this specific issue. We have prior discussions on our site about utilizing /etc/rrdtooldisable as a way to avoid creating these graphs:

cPanel 11.25 Tech Bulletin: updated bandwidth tracking requirements | cPanel, Inc.

There are no internal cases discussing removal of /etc/rrdtooldisable and /usr/local/cpanel/bin/chk_bwrrd_size also references it:

Code:
Bandwidth processing has therefore been disabled.

To re-enable:
  1. Symlink /var/cpanel/bandwidth to a partition with sufficient space
  2. Remove the file /etc/rrdtooldisable
  3. Re-run /usr/local/cpanel/install/bandwidth
EOM

        # Send message if space is too small.
        require Cpanel::iContact;
        Cpanel::iContact::icontact(
            app     => 'installbandwidth',
            level   => 1,
            subject => 'Unable to upgrade bandwidth files',
            message => $msg
        );
        Cpanel::FileUtils::TouchFile::touchfile('/etc/rrdtooldisable');
    }
    exit 1;
}

exit 0;
The biggest issue with the fact /etc/rrdtooldisable isn't working would be that the tool is supposed to detect if you do not have sufficient disk space. If it isn't able to stop running graphs by detecting the existence of that file, then that could cause /var partition to go over in usage on some systems. That makes this a bug.

Thanks!